Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#13577 closed defect (duplicate)

aqbanking-2.2.9 build: ld: cycle in dylib re-exports with /usr/X11R6/lib/libGL.dylib

Reported by: caveman.al@… Owned by: mas@…
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: Cc:
Port:

Description (last modified by jmpp@…)

Here is the screen capture:

$ QTDIR="/opt/local/lib/qt3/"; export QTDIR; sudo port install gnucash
Password:
--->  Building aqbanking with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_aqbanking/work/aqbanking-2.2.9" && make all " returned error 2
Command output: make[6]: Nothing to be done for `all'.
Making all in dialogs
make[6]: Nothing to be done for `all'.
Making all in views
make[6]: Nothing to be done for `all'.
make[6]: Nothing to be done for `all-am'.
Making all in qbanking
Making all in lib
make  all-recursive
Making all in widgets
make  all-am
make[8]: Nothing to be done for `all-am'.
Making all in dialogs
make  all-am
make[8]: Nothing to be done for `all-am'.
Making all in views
make  all-am
make[8]: Nothing to be done for `all-am'.
/bin/sh ../../../../libtool --tag=CXX --mode=link g++  -O2 -g -Wall  -L/opt/local/lib -g -o testlib  testlib.o libqbanking.la /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_aqbanking/work/aqbanking-2.2.9/src/libs/aqbanking/libaqbanking.la -lintl 
g++ -O2 -g -Wall -g -o .libs/testlib testlib.o -Wl,-bind_at_load  -L/opt/local/lib ./.libs/libqbanking.dylib -L/usr/lib -L/sw/lib -L/opt/local/lib/qt3/lib /opt/local/lib/qt3/lib/libqt-mt.dylib -L/usr/X11R6/lib -lresolv -lz -lGL /usr/X11/lib/libXmu.6.2.0.dylib /opt/local/lib/libXrender.dylib /usr/X11/lib/libXrandr.2.0.0.dylib /usr/X11/lib/libXcursor.1.0.2.dylib /usr/X11/lib/libXinerama.1.0.0.dylib /opt/local/lib/libXft.dylib /opt/local/lib/libfreetype.dylib /opt/local/lib/libfontconfig.dylib /usr/X11/lib/libXext.6.4.0.dylib /usr/X11/lib/libX11.6.2.0.dylib -lm /usr/X11/lib/libSM.6.0.0.dylib /usr/X11/lib/libICE.6.3.0.dylib -ldl /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_aqbanking/work/aqbanking-2.2.9/src/libs/aqbanking/.libs/libaqbanking.dylib /opt/local/lib/libgwenhywfar.dylib -lssl -lcrypto /opt/local/lib/libintl.dylib /opt/local/lib/libiconv.dylib -lc
ld: cycle in dylib re-exports with /usr/X11R6/lib/libGL.dylib
collect2: ld returned 1 exit status
make[7]: *** [testlib] Error 1
make[6]: *** [all-recursive] Error 1
make[5]: *** [all] Error 2
make[4]: *** [all-recursive] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: The following dependencies failed to build: aqbanking evince audiofile avahi dbus xmlto getopt dbus-glib dbus-python25 py25-gobject python25 py25-numeric gdbm libdaemon py25-gdbm py25-gtk py25-cairo esound gconf intltool orbit2 libidl gnome-doc-utils iso-codes py25-hashlib openssl py25-libxml2 gnome-icon-theme icon-naming-utils p5-getopt-long p5-pathtools p5-xml-simple p5-test-simple p5-test-harness p5-xml-namespacesupport p5-xml-sax gnome-keyring libgcrypt libgpg-error gnome-vfs gnome-mime-data howl neon libart_lgpl libgnome libbonobo popt libgnomecanvas gail libgnomeui libbonoboui nautilus eel gnome-desktop fribidi startup-notification gnome-menus libexif librsvg libcroco libgsf shared-mime-info poppler poppler-data gnucash-docs yelp firefox-x11 zip libgtkhtml goffice03 libgnomeprintui libgnomeprint bison libgnomecups guile16 readline libgtkhtml3 p5-finance-quote p5-crypt-ssleay p5-libwww-perl p5-compress-zlib p5-compress-raw-zlib p5-io-compress-base p5-scalar-list-utils p5-io-compress-zlib p5-html-parser p5-html-tagset p5-uri p5-datemanip p5-html-tableextract slib slib-guile16
Error: Status 1 encountered during processing.

Change History (4)

comment:1 Changed 13 years ago by jmpp@…

Description: modified (diff)
Milestone: Port Bugs

comment:2 Changed 13 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-dev@… to mas@…
Summary: port aqbanking-2.2.9 build erroraqbanking-2.2.9 build error

comment:3 Changed 13 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed
Summary: aqbanking-2.2.9 build erroraqbanking-2.2.9 build: ld: cycle in dylib re-exports with /usr/X11R6/lib/libGL.dylib

Duplicate of #13173.

comment:4 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.