Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#13547 closed defect (fixed)

Bison 2.3.1 fails without sudo rights

Reported by: simon@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: bison permissions Cc: mww@…, simon@…
Port:

Description

Hi,

I just tried upgrading bison to 2.3.1 and got an access denied error. I'm using macports without sudo and most of the time it works fine.

The problem is that the directory settings in post-destroot are too strict and don't give the current user write access. Here is a patch which should change this and works fine for me.

--- Portfile    (revision 31841)
+++ Portfile    (working copy)
@@ -33,7 +33,7 @@
 
  post-destroot {
          set docdir ${prefix}/share/doc/${name}
          -       xinstall -d -m 0555 ${destroot}${docdir}
          +       xinstall -d -m 0755 ${destroot}${docdir}
                  xinstall -m 0444 -W ${worksrcpath} AUTHORS COPYING ChangeLog
                  NEWS \
                                  THANKS TODO ${destroot}${docdir}
                                   }

Thanks for your help, Simon

PS: I tried sending you this as email but got an error from the Apple Mail Server.

    550 <mmw@macports.org>: Recipient address rejected: User unknown in virtual
    alias table (in reply to RCPT TO command)

Change History (3)

comment:1 Changed 13 years ago by simon@…

Cc: mww@… added; mmw@… removed

Ignore the email part, I used to wrong email :-/. Thanks to Maun Suang Boey for noticing this.

I corrected the CC.

Simon

comment:2 Changed 13 years ago by mww@…

Keywords: bison permissions added
Resolution: fixed
Status: newclosed

thanks, fixed!

comment:3 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.