Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#13548 closed defect (duplicate)

cant build python25 update 2.5.1_4

Reported by: frstan@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: python25 Cc: mww@…, rwoodsmall@…
Port:

Description (last modified by jmpp@…)

unable to build python25 update 2.5.1_4

gcc -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE  -c ./Modules/posixmodule.c -o Modules/posixmodule.o
./Modules/posixmodule.c: In function 'posix_setpgrp':
./Modules/posixmodule.c:3724: error: too few arguments to function 'setpgrp'
make: *** [Modules/posixmodule.o] Error 1

Warning: the following items did not execute (for python25): org.macports.destroot org.macports.build
DEBUG:
Error: Unable to upgrade port: 1

Attachments (1)

python25-leopard_fix.diff (310 bytes) - added by skymoo (Adam Mercer) 13 years ago.
fix build on leopard

Download all attachments as: .zip

Change History (7)

comment:1 Changed 13 years ago by skymoo (Adam Mercer)

Cc: rwoodsmall@… added

comment:2 Changed 13 years ago by skymoo (Adam Mercer)

the attached patch fixes the build for me on Intel Leopard

Changed 13 years ago by skymoo (Adam Mercer)

Attachment: python25-leopard_fix.diff added

fix build on leopard

comment:3 Changed 13 years ago by jmpp@…

Description: modified (diff)
Priority: HighNormal

comment:4 Changed 13 years ago by rwoodsmall@…

python25-leopard_fix.diff worked as expected - I was able to upgrade the package using this patch.

comment:5 Changed 13 years ago by mww@…

Resolution: duplicate
Status: newclosed

This is a duplicate of #13335

comment:6 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.