Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#13653 closed defect (fixed)

apache2 2.2.6_0 (2.2.8_0) build failure: unable to infer tagged configuration

Reported by: jerry.jalava@… Owned by: danielluke (Daniel J. Luke)
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: Cc: imajes@…, jryan2002de@…, DavidBAEpstein, jyrkiwahlstedt
Port:

Description (last modified by jmpp@…)

Is it just my machine or is there something wrong with the script in Apache 2.2.6 port? This is what I get when trying to upgrade:

-------->  Building apache2 with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/work/httpd-2.2.6" && make all " returned error 2
Command output: Making all in srclib
Making all in os
Making all in unix
/opt/local/share/apr-1/build/libtool --silent --mode=compile /usr/bin/gcc-4.0 -I/opt/local/include  -O2  -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp  -I/opt/local/include  -I. -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/work/httpd-2.2.6/os/unix -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/work/httpd-2.2.6/server/mpm/prefork -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/work/httpd-2.2.6/modules/http -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/work/httpd-2.2.6/modules/filters -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/work/httpd-2.2.6/modules/proxy -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/work/httpd-2.2.6/include -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/work/httpd-2.2.6/modules/generators -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/work/httpd-2.2.6/modules/mappers -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/work/httpd-2.2.6/modules/database -I/opt/local/include/apr-1 -I/opt/local/include -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/work/httpd-2.2.6/server -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/work/httpd-2.2.6/modules/proxy/../generators -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/work/httpd-2.2.6/modules/ssl -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/work/httpd-2.2.6/modules/dav/main  -prefer-non-pic -static -c unixd.c && touch unixd.lo
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make[3]: *** [unixd.lo] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1

Error: Unable to upgrade port: 1
------

Attachments (4)

apache2.build.log.gz (4.3 KB) - added by josh-macports@… 13 years ago.
apache2.diff (1.5 KB) - added by juno@… 13 years ago.
work around
patch-configure.diff (343 bytes) - added by jyrkiwahlstedt 13 years ago.
configure patch
Portfile.diff (352 bytes) - added by jyrkiwahlstedt 13 years ago.
Portfile diff with patch files for configure

Download all attachments as: .zip

Change History (22)

comment:1 Changed 13 years ago by jmpp@…

Description: modified (diff)
Milestone: Port Bugs

comment:2 Changed 13 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to imajes@…
Summary: Latest Apache 2 doesn't compileapache2 2.2.6_0 build failure: unable to infer tagged configuration

Never seen such a problem. apache2 2.2.6_0 works fine for me on Mac OS X 10.4.11 Intel with Xcode 2.4.1 and MacPorts compiled from trunk. You should tell us your version of Mac OS X, Xcode and MacPorts, and what architecture your processor is. You should also try "sudo port selfupdate" followed by "sudo port clean --work apache2" and "sudo port install apache2" and see if it works then. Assigning ticket to port's maintainer.

comment:3 Changed 13 years ago by ryandesign (Ryan Schmidt)

Interesting, the same error message was reported for the mjpegtools port in #13648.

comment:4 Changed 13 years ago by christian@…

Also seeing this on OS X 10.5.1 with XCode 3.0 and MacPorts 1.600. Did both sudo port selfupdate, sudo port clean --work apache2 and sudo port install apache2. How may I provide more debugging information?

comment:5 Changed 13 years ago by josh-macports@…

I'm seeing this too. MacPorts 1.60, XCode 3.0, OS 10.5.1, x86. I'm attaching a full debug-mode build log.

Changed 13 years ago by josh-macports@…

Attachment: apache2.build.log.gz added

comment:6 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: jryan2002de@… added

Has duplicate #13775.

comment:7 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: David.Epstein@… added

Changed 13 years ago by juno@…

Attachment: apache2.diff added

work around

comment:8 Changed 13 years ago by jyrkiwahlstedt

This applies to 2.2.8, too. Seems to go further, if one patches configure in addition to/instead of configure.in.

Changed 13 years ago by jyrkiwahlstedt

Attachment: patch-configure.diff added

configure patch

comment:9 Changed 13 years ago by jyrkiwahlstedt

Cc: jwa@… added

Well, my environment in which apache2 2.2.8 doesn't initially build before the patched configure, is OS X 10.4.11 with Xcode 2.5. I also add myself to cc: list to get notifications about updates.

comment:10 Changed 13 years ago by jyrkiwahlstedt

Summary: apache2 2.2.6_0 build failure: unable to infer tagged configurationapache2 2.2.6_0 (2.2.8_0) build failure: unable to infer tagged configuration

comment:11 Changed 13 years ago by dbraband@…

How do i apply these patches?

Thanks for your help.

comment:12 Changed 13 years ago by jyrkiwahlstedt

I'll attach my Portfile diff. Patch your's with that (or edit Portfile), add the patchfiles in subdirectory 'files' in apache2 port directory.

Changed 13 years ago by jyrkiwahlstedt

Attachment: Portfile.diff added

Portfile diff with patch files for configure

comment:13 Changed 13 years ago by dbraband@…

It worked. Thank you!

comment:14 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: imajes@… added
Owner: changed from imajes@… to dluke@…

No patch to the apache2 portfile should be necessary. There has been a long discussion on macports-users in which it seems the problem is that apr was installed with MacPorts < 1.6.0 and now users are trying to install apache2 with MacPorts >= 1.6.0. MacPorts 1.6.0 changed the name of the compiler from "gcc" to "/usr/bin/gcc-4.0" and even though these are the same compiler, the libtool in apr doesn't know this, and complains. The solution is to rebuild apr with MacPorts 1.6.0. Daniel, I'm reassigning this to you since apr is your port. I see the current apr portfile 1.2.12 was last modified 2007-12-04 and MacPorts 1.6.0 was released 2007-12-16 so it's entirely possible that someone built apr 1.2.12 with MacPorts < 1.6.0. I believe the solution is to simply bump the revision number of the apr portfile by one, making no other changes, to force everyone to rebuild it so that we know it was built with MacPorts >= 1.6.0.

comment:15 Changed 13 years ago by danielluke (Daniel J. Luke)

Resolution: fixed
Status: newclosed

apr's revision bumped in r33741

comment:16 Changed 13 years ago by ryandesign (Ryan Schmidt)

Thanks. And in case anyone was wondering, apr0 should not be affected since its version was already bumped on 2008-01-12.

comment:17 Changed 13 years ago by ryandesign (Ryan Schmidt)

Has duplicate #14145.

comment:18 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.