Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#14308 closed defect (fixed)

ntop fails to build: unable to infer tagged configuration

Reported by: darrell.usenet6@… Owned by: markd@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: protsman@…, macports.users@…, rory.tarabay@…, mattwilkens@…, eugene.vasserman@…, jgonian@…, blb@…
Port: ntop

Description

I tried the fix in ticket 13648. Didn't work for me. Running on an iBook G4, 10.4.11, Xcode 2.5

Many thanks

Darrell

--

aabs:~ darrell$ sudo port selfupdate

MacPorts base version 1.600 installed

Downloaded MacPorts base version 1.600

The MacPorts installation is not outdated and so was not updated
selfupdate done!

aabs:~ darrell$ sudo port upgrade libtool
--->  Fetching libtool
--->  Attempting to fetch libtool-1.5.24.tar.gz from
http://ftp.gnu.org/gnu/libtool
--->  Verifying checksum(s) for libtool
--->  Extracting libtool
--->  Configuring libtool
--->  Building libtool with target all
--->  Staging libtool into destroot
--->  Installing libtool 1.5.24_2
--->  Activating libtool 1.5.24_2
--->  Cleaning libtool
aabs:~ darrell$ sudo port clean --work mjpegtools
--->  Cleaning mjpegtools
aabs:~ darrell$ sudo port install mjpegtools
--->  Fetching mjpegtools
--->  Attempting to fetch mjpegtools-1.6.2.tar.gz from
http://downloads.sourceforge.net/mjpeg
--->  Verifying checksum(s) for mjpegtools
--->  Extracting mjpegtools
--->  Applying patches to mjpegtools
--->  Configuring mjpegtools
--->  Building mjpegtools with target all
--->  Staging mjpegtools into destroot
--->  Installing mjpegtools 1.6.2_2+darwin_8
--->  Activating mjpegtools 1.6.2_2+darwin_8
--->  Cleaning mjpegtools
aabs:~ darrell$ sudo port clean --work ntop
Password:
--->  Cleaning ntop
aabs:~ darrell$ sudo port install ntop
--->  Fetching ntop
--->  Verifying checksum(s) for ntop
--->  Extracting ntop
--->  Configuring ntop
--->  Building ntop with target all
Error: Target org.macports.build returned: shell command " cd
"/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_ntop/work/ntop-3.3"
&& gnumake all " returned error 2
Command output: gnumake  all-recursive
Making all in .
source='address.c' object='address.lo' libtool=yes \
depfile='.deps/address.Plo' tmpdepfile='.deps/address.TPlo' \
depmode=gcc3 /bin/sh ./depcomp \
/bin/sh ./libtool --mode=compile /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I.
-I. -I. -I. -I/usr/local/include -g -Os -pipe -Ddarwin8
-I/System/Library/Frameworks/System.framework/PrivateHeaders -I.
-I/usr/include    -I/opt/local/include -DDARWIN -DTIGER
-I/usr/local/include  -g -no-cpp-precomp -O2 -I/opt/local/include
-I/usr/local/include -g -Wshadow -Wpointer-arith -Wmissing-prototypes
-Wmissing-declarations -Wnested-externs  -fno-common -DPIC -c -o
address.lo `test -f 'address.c' || echo './'`address.c
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
gnumake[2]: *** [address.lo] Error 1
gnumake[1]: *** [all-recursive] Error 1
gnumake: *** [all] Error 2

Error: Status 1 encountered during processing.

aabs:~ darrell$ port -v
MacPorts 1.600

aabs:~ darrell$ uname -a
Darwin aabs.dyndns.org 8.11.0 Darwin Kernel Version 8.11.0: Wed Oct 10 18:26:00 PDT 2007; root:xnu-792.24.17~1/RELEASE_PPC Power Macintosh powerpc


Change History (19)

comment:1 Changed 13 years ago by ryandesign (Ryan Schmidt)

Milestone: Port Bugs
Owner: changed from macports-tickets@… to markd@…
Summary: ntop fails to buildntop fails to build: unable to infer tagged configuration

Right, the fix from #13648 (forcing a rebuild of the libtool port), while it seems to have helped mjpegtools to build, apparently doesn't help ntop, which doesn't depend on the libtool port and seems to have its own built-in libtool. Maybe ntop needs to depend on the libtool port and use something like LIBTOOL=${prefix}/bin/glibtool in its environment?

comment:2 Changed 13 years ago by peter@…

Could you please install the automake, and autoconf ports as well as the libtool port, then try to build ntop again.

comment:3 in reply to:  2 Changed 13 years ago by darrell.usenet6@…

Replying to peter@pogma.com:

Could you please install the automake, and autoconf ports as well as the libtool port, then try to build ntop again.

Sure. I just did so. I still have the problem.

Many thanks,

Darrell

aabs:~ darrell$ sudo port install automake
Password:
--->  Fetching p5-locale-gettext
--->  Attempting to fetch gettext-1.05.tar.gz from http://ftp.ucr.ac.cr/Unix/CPAN/modules/by-module/Locale
--->  Verifying checksum(s) for p5-locale-gettext
--->  Extracting p5-locale-gettext
--->  Configuring p5-locale-gettext
--->  Building p5-locale-gettext with target all
--->  Staging p5-locale-gettext into destroot
--->  Installing p5-locale-gettext 1.05_0
--->  Activating p5-locale-gettext 1.05_0
--->  Cleaning p5-locale-gettext
--->  Fetching help2man
--->  Attempting to fetch help2man-1.36.4.tar.gz from http://ftp.gnu.org/gnu/help2man
--->  Verifying checksum(s) for help2man
--->  Extracting help2man
--->  Applying patches to help2man
--->  Configuring help2man
--->  Building help2man with target all
--->  Staging help2man into destroot
--->  Installing help2man 1.36.4_1
--->  Activating help2man 1.36.4_1
--->  Cleaning help2man
--->  Fetching m4
--->  Attempting to fetch m4-1.4.10.tar.bz2 from http://ftp.gnu.org/gnu/m4
--->  Verifying checksum(s) for m4
--->  Extracting m4
--->  Applying patches to m4
--->  Configuring m4
--->  Building m4 with target all
--->  Staging m4 into destroot
--->  Installing m4 1.4.10_1
--->  Activating m4 1.4.10_1
--->  Cleaning m4
--->  Fetching autoconf
--->  Attempting to fetch autoconf-2.61.tar.bz2 from http://ftp.gnu.org/gnu/autoconf
--->  Verifying checksum(s) for autoconf
--->  Extracting autoconf
--->  Configuring autoconf
--->  Building autoconf with target all
--->  Staging autoconf into destroot
--->  Installing autoconf 2.61_1
--->  Activating autoconf 2.61_1
--->  Cleaning autoconf
--->  Fetching automake
--->  Attempting to fetch automake-1.10.1.tar.bz2 from http://ftp.gnu.org/gnu/automake
--->  Verifying checksum(s) for automake
--->  Extracting automake
--->  Configuring automake
--->  Building automake with target all
--->  Staging automake into destroot
--->  Installing automake 1.10.1_0
--->  Activating automake 1.10.1_0
--->  Cleaning automake
aabs:~ darrell$ sudo port install libtool
Password:
Skipping org.macports.activate (libtool ) since this port is already active
--->  Cleaning libtool
aabs:~ darrell$ sudo port install ntop
--->  Building ntop with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_ntop/work/ntop-3.3" && gnumake all " returned error 2
Command output: gnumake  all-recursive
Making all in .
source='address.c' object='address.lo' libtool=yes \
depfile='.deps/address.Plo' tmpdepfile='.deps/address.TPlo' \
depmode=gcc3 /bin/sh ./depcomp \
/bin/sh ./libtool --mode=compile /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I. -I. -I/usr/local/include -g -Os -pipe -Ddarwin8 -I/System/Library/Frameworks/System.framework/PrivateHeaders -I. -I/usr/include    -I/opt/local/include -DDARWIN -DTIGER -I/usr/local/include  -g -no-cpp-precomp -O2 -I/opt/local/include -I/usr/local/include -g -Wshadow -Wpointer-arith -Wmissing-prototypes -Wmissing-declarations -Wnested-externs  -fno-common -DPIC -c -o address.lo `test -f 'address.c' || echo './'`address.c
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
gnumake[2]: *** [address.lo] Error 1
gnumake[1]: *** [all-recursive] Error 1
gnumake: *** [all] Error 2

Error: Status 1 encountered during processing.

comment:4 Changed 13 years ago by peter@…

Oh well, thought that would help - the ntop port runs autogen.sh to run libtoolize, automake, autoconf etc in the build directory - since you are on Tiger and that comes with quite old version s of those tools, I thought that may be the problem. I guess I will just leave it to the ntop maintainer.

Another thing I noticed when looking at autogen.sh is this

echo "2. Preparing for libtool ...."
$LIBTOOLIZE --copy --force

if [ ! -f libtool.m4.in ]; then
  echo "    Finding libtool.m4.in"
  if [ -f /usr/local/share/aclocal/libtool.m4 ]; then
     echo "        .... found /usr/local/share/aclocal/libtool.m4"
     cp /usr/local/share/aclocal/libtool.m4 libtool.m4.in
  else
     if [ -f /usr/share/aclocal/libtool.m4 ]; then
      echo "        .... found /usr/share/aclocal/libtool.m4"
      cp /usr/share/aclocal/libtool.m4 libtool.m4.in
     else
      echo "        .... not found - aborting!"
     fi
  fi
fi
echo "        .... done"
echo ""

So it will probably get the ltmain.sh from MacPorts' relatively recent version of libtool, but generate the configure script from /usr/share/aclocal/libtool.m4, which is relatively old. It may be an issue, but I doubt that it is this one.

comment:5 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: protsman@… added

comment:6 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: macports.users@… added

comment:7 Changed 13 years ago by markd@…

I'm not able to resolve this. I'll try the ntop list though.

comment:8 Changed 13 years ago by darrell.usenet6@…

I just tried to install ntop again after a report that it was fixed. Ntop still fails to install for me.

The error output is different after the first few error lines.

aabs:/Users/darrell adm$ sudo port selfupdate

MacPorts base version 1.600 installed

Downloaded MacPorts base version 1.600

The MacPorts installation is not outdated and so was not updated
selfupdate done!

aabs:/Users/darrell adm$ sudo port clean --all ntop 
--->  Cleaning ntop

aabs:/Users/darrell adm$ sudo port install ntop
--->  Fetching ntop
--->  Attempting to fetch ntop-3.3.tar.gz from
http://downloads.sourceforge.net/ntop
--->  Verifying checksum(s) for ntop
--->  Extracting ntop
--->  Applying patches to ntop
--->  Configuring ntop
--->  Building ntop with target all
Error: Target org.macports.build returned: shell command " cd
"/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.mac
ports.org_release_ports_net_ntop/work/ntop-3.3" && gnumake all "
returned error 2
Command output: address.c:634: error: request for member
'addressQueuedCurrent' in something not a structure or union
address.c:635: error: request for member 'queueAddressMutex' in
something not a structure or union
address.c: In function 'dequeueAddress':
address.c:651: error: request for member 'ntopRunState' in something
not a structure or union
address.c:656: error: request for member 'queueAddressCondvar' in
something not a structure or union
address.c:658: error: request for member 'ntopRunState' in something
not a structure or union
address.c:664: error: request for member 'addressQueueFile' in
something not a structure or union
address.c:669: error: request for member 'ntopRunState' in something
not a structure or union
address.c:696: error: request for member 'queueAddressMutex' in
something not a structure or union
address.c:697: error: request for member 'addressQueuedCurrent' in
something not a structure or union
address.c:697: error: request for member 'addressQueuedCurrent' in
something not a structure or union
address.c:698: error: request for member 'queueAddressMutex' in
something not a structure or union
address.c:700: error: request for member 'addressQueueFile' in
something not a structure or union
address.c:702: error: request for member 'addressQueueFile' in
something not a structure or union
address.c:707: error: request for member 'dequeueAddressThreadId' in
something not a structure or union
address.c: In function 'fetchAddressFromCache':
address.c:843: error: request for member
'numFetchAddressFromCacheCalls' in something not a structure or union
address.c:854: error: request for member 'dnsCacheFile' in something
not a structure or union
address.c:856: error: request for member 'dnsCacheFile' in something
not a structure or union
address.c:871: error: request for member 'actTime' in something not a
structure or union
address.c:872: error: request for member
'numFetchAddressFromCacheCallsOK' in something not a structure or union
address.c:875: error: request for member
'numFetchAddressFromCacheCallsSTALE' in something not a structure or
union
address.c:881: error: request for member
'numFetchAddressFromCacheCallsFAIL' in something not a structure or
union
address.c: In function 'ipaddr2str':
address.c:914: error: request for member 'numipaddr2strCalls' in
something not a structure or union
address.c: In function 'checkSpoofing':
address.c:1823: error: request for member 'runningPref' in something
not a structure or union
gnumake[2]: *** [address.lo] Error 1
gnumake[1]: *** [all-recursive] Error 1
gnumake: *** [all] Error 2

Error: Status 1 encountered during processing.

aabs:~ darrell$ uname -a
Darwin aabs.dyndns.org 8.11.0 Darwin Kernel Version 8.11.0: Wed Oct 10
18:26:00 PDT 2007; root:xnu-792.24.17~1/RELEASE_PPC Power Macintosh
powerpc

comment:9 Changed 13 years ago by jmroot (Joshua Root)

Cc: rory.tarabay@… added

Cc reporter of duplicate #14879.

comment:10 Changed 13 years ago by mattwilkens@…

Cc: mattwilkens@… added

Cc Me!

comment:11 Changed 13 years ago by eugene.vasserman@…

Cc: eugene.vasserman@… added

Cc Me!

comment:12 Changed 13 years ago by jgonian@…

Cc: jgonian@… added

Cc Me!

comment:13 Changed 12 years ago by blb@…

Cc: blb@… added
Port: ntop added

Is this still an issue, the ntop port is currently at version 3.3.8?

comment:14 Changed 12 years ago by markd@…

I was never able to reproduce it myself so I don't know. I suppose it is reasonable to close it since the update may have fixed and we have no way to test this. It could always be reopened if it crops up again.

comment:15 Changed 12 years ago by eugene.vasserman@…

I DID have this problem originally, and can confirm that it now works with ntop 3.3.8.

comment:16 Changed 12 years ago by markd@…

Resolution: fixed
Status: newclosed

Thanks for reporting.

comment:17 Changed 12 years ago by darrell.usenet6@…

I initiated this ticket. After seeing the comments today I updated and tried again.

I can confirm ntop 3.3.8 is running fine now on my iBook G4. Since the original report I have upgraded my OS to 10.5.6, Xcode to 3.1, MacPorts to 1.7.

comment:18 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:19 Changed 12 years ago by markd@…

This is actually still a problem on 10.4, but I don't know of a fix.

Note: See TracTickets for help on using tickets.