Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#14840 closed defect (duplicate)

mod_pyhton25 fails to compile on 10.5.2: unable to execute -DNDEBUG: No such file or directory

Reported by: calvi_paolo@… Owned by: mww@…
Priority: High Milestone:
Component: ports Version: 1.6.0
Keywords: mod_pyhton Cc: jyrkiwahlstedt
Port:

Description

Cannot compile mod_python:

sudo port install mod_python25 +universal
--->  Fetching mod_python25
--->  Verifying checksum(s) for mod_python25
--->  Extracting mod_python25
--->  Configuring mod_python25
--->  Building mod_python25 with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_mod_python25/work/mod_python-3.3.1" && make all " returned error 2
Command output: creating build/lib.macosx-10.3-i386-2.5/mod_python
copying /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_mod_python25/work/mod_python-3.3.1/lib/python/mod_python/__init__.py -> build/lib.macosx-10.3-i386-2.5/mod_python
copying /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_mod_python25/work/mod_python-3.3.1/lib/python/mod_python/apache.py -> build/lib.macosx-10.3-i386-2.5/mod_python
copying /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_mod_python25/work/mod_python-3.3.1/lib/python/mod_python/cache.py -> build/lib.macosx-10.3-i386-2.5/mod_python
copying /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_mod_python25/work/mod_python-3.3.1/lib/python/mod_python/cgihandler.py -> build/lib.macosx-10.3-i386-2.5/mod_python
copying /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_mod_python25/work/mod_python-3.3.1/lib/python/mod_python/Cookie.py -> build/lib.macosx-10.3-i386-2.5/mod_python
copying /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_mod_python25/work/mod_python-3.3.1/lib/python/mod_python/importer.py -> build/lib.macosx-10.3-i386-2.5/mod_python
copying /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_mod_python25/work/mod_python-3.3.1/lib/python/mod_python/psp.py -> build/lib.macosx-10.3-i386-2.5/mod_python
copying /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_mod_python25/work/mod_python-3.3.1/lib/python/mod_python/publisher.py -> build/lib.macosx-10.3-i386-2.5/mod_python
copying /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_mod_python25/work/mod_python-3.3.1/lib/python/mod_python/python22.py -> build/lib.macosx-10.3-i386-2.5/mod_python
copying /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_mod_python25/work/mod_python-3.3.1/lib/python/mod_python/Session.py -> build/lib.macosx-10.3-i386-2.5/mod_python
copying /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_mod_python25/work/mod_python-3.3.1/lib/python/mod_python/testhandler.py -> build/lib.macosx-10.3-i386-2.5/mod_python
copying /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_mod_python25/work/mod_python-3.3.1/lib/python/mod_python/util.py -> build/lib.macosx-10.3-i386-2.5/mod_python
running build_ext
building 'mod_python._psp' extension
creating build/temp.macosx-10.3-i386-2.5
creating build/temp.macosx-10.3-i386-2.5/opt
creating build/temp.macosx-10.3-i386-2.5/opt/local
creating build/temp.macosx-10.3-i386-2.5/opt/local/var
creating build/temp.macosx-10.3-i386-2.5/opt/local/var/macports
creating build/temp.macosx-10.3-i386-2.5/opt/local/var/macports/build
creating build/temp.macosx-10.3-i386-2.5/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_mod_python25
creating build/temp.macosx-10.3-i386-2.5/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_mod_python25/work
creating build/temp.macosx-10.3-i386-2.5/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_mod_python25/work/mod_python-3.3.1
creating build/temp.macosx-10.3-i386-2.5/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_mod_python25/work/mod_python-3.3.1/src
-DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_mod_python25/work/mod_python-3.3.1/src/include -I/opt/local/include/python2.5 -c /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_mod_python25/work/mod_python-3.3.1/src/psp_string.c -o build/temp.macosx-10.3-i386-2.5/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_mod_python25/work/mod_python-3.3.1/src/psp_string.o
unable to execute -DNDEBUG: No such file or directory
error: command '-DNDEBUG' failed with exit status 1
make[1]: *** [build] Error 1
make: *** [do_dso] Error 2

Error: Status 1 encountered during processing.

Change History (3)

comment:1 Changed 13 years ago by jmroot (Joshua Root)

Cc: jwa@… added
Owner: changed from macports-tickets@… to mww@…

Assigning to maintainers. It will probably work if you clean and try again; known issue with Python ports.

comment:2 Changed 13 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #13930.

comment:3 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.