Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#15563 closed update (fixed)

Update Groovy port to groovy 1.5.6

Reported by: tomaslin@… Owned by: jberry@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: groovy 1.5.6 java lang Cc: wsiegrist@…, tyler.black@…, febeling@…
Port:

Description

Current groovy portFile needs to be updated to the latest version of Groovy, which is 1.5.6

The portFile to do so has been attached

Attachments (1)

Portfile (2.1 KB) - added by tomaslin@… 12 years ago.

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by tomaslin@…

Attachment: Portfile added

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Cc: jberry@… removed
Owner: changed from macports-tickets@… to jberry@…

comment:2 Changed 12 years ago by jmroot (Joshua Root)

Milestone: Port BugsPort Updates
Type: defectenhancement

comment:3 Changed 12 years ago by febeling@…

I ran into this problem on build:

...
ensureGrammars:

BUILD FAILED
/opt/local/var/macports/build/_Users_febeling_vendor_macports-svn_dports_java_groovy/work/groovy-1.5.6/build.xml:65: Problem: failed to create task or type antlr
Cause: the class org.apache.tools.ant.taskdefs.optional.ANTLR was not found.
        This looks like one of Ant's optional components.
Action: Check that the appropriate optional JAR exists in
        -/usr/share/ant/lib
        -/Users/febeling/.ant/lib
        -a directory added on the command line with the -lib argument

Do not panic, this is a common problem.
The commonest cause is a missing JAR.

This is not a bug; it is a configuration problem


Total time: 2 seconds

Warning: the following items did not execute (for groovy): org.macports.activate org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.

comment:4 Changed 12 years ago by febeling@…

Cc: febeling@… added

Cc Me!

comment:5 Changed 12 years ago by jberry@…

Resolution: fixed
Status: newclosed

Updated to 1.5.6 in r38365. Thanks for the patch. I'm dropping maintainership of this port, as I clearly haven't kept it up to date ;)

comment:6 Changed 11 years ago by jmroot (Joshua Root)

Type: enhancementupdate

comment:7 Changed 11 years ago by (none)

Milestone: Port Updates

Milestone Port Updates deleted

Note: See TracTickets for help on using tickets.