Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#16612 closed defect (fixed)

git-svn broken after upgrading to git 1.6.0.2 ... Errno architecture (darwin-2level-9.4.0) does not match executable architecture (darwin-thread-multi-2level-9.0)

Reported by: bretthoerner@… Owned by: blb@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: git git-core git-svn perl Cc: maccheck@…
Port: git-core

Description (last modified by blb@…)

$ git svn
Errno architecture (darwin-2level-9.4.0) does not match executable architecture (darwin-thread-multi-2level-9.0) at /opt/local/lib/perl5/site_perl/5.8.8/Errno.pm line 11.
Compilation failed in require at /System/Library/Perl/5.8.8/File/Temp.pm line 138.
BEGIN failed--compilation aborted at /System/Library/Perl/5.8.8/File/Temp.pm line 138.
Compilation failed in require at /opt/local/libexec/git-core/git-svn line 3089.
BEGIN failed--compilation aborted at /opt/local/libexec/git-core/git-svn line 3089.

Attachments (1)

Portfile.patch (1.4 KB) - added by maccheck@… 13 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 13 years ago by bretthoerner@…

Here's the output with proper formatting,

$ git svn
Errno architecture (darwin-2level-9.4.0) does not match executable architecture (darwin-thread-multi-2level-9.0) at /opt/local/lib/perl5/site_perl/5.8.8/Errno.pm line 11.
Compilation failed in require at /System/Library/Perl/5.8.8/File/Temp.pm line 138.
BEGIN failed--compilation aborted at /System/Library/Perl/5.8.8/File/Temp.pm line 138.
Compilation failed in require at /opt/local/libexec/git-core/git-svn line 3089.
BEGIN failed--compilation aborted at /opt/local/libexec/git-core/git-svn line 3089.

comment:2 Changed 13 years ago by bretthoerner@…

I temporarily fixed the problem by moving /opt/local/lib/perl5/site_perl/5.8.8/Errno.pm out of my Perl path, but it should be noted that I have made no previous changes to anything under /opt/local so this is definitely something funky in MacPorts.

comment:3 Changed 13 years ago by raimue (Rainer Müller)

Can't reproduce here:

$ git --version
git version 1.6.0.2
$ git svn
git-svn - bidirectional operations between a single Subversion tree and git
Usage: git svn <command> [options] [arguments]
...

comment:4 Changed 13 years ago by blb@…

Description: modified (diff)

comment:5 Changed 13 years ago by blb@…

Compilation failed in require at /System/Library/Perl/5.8.8/File/Temp.pm line 138.

Looks like some perl stuff is being brought in from the system-installed perl, not MacPorts' perl. What's your PATH?

comment:6 Changed 13 years ago by bretthoerner@…

PATH=/opt/local/sbin:/opt/local/bin:/opt/local/lib/postgresql83/bin/:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin

No PERL5LIB or anything set.

comment:7 Changed 13 years ago by blb@…

Cc: maccheck@… added
Owner: changed from macports-tickets@… to bryan@…

One interesting thing is that /opt/local/libexec/git-core/git-svn has a system perl shebang line:

#!/usr/bin/perl
use lib (split(/:/, $ENV{GITPERLLIB} || "/opt/local/lib/perl5/site_perl"));

Then it brings in MacPorts' perl stuff...that can't be right. Though, like raimue@, it works fine for me.

comment:8 Changed 13 years ago by bretthoerner@…

I opened this on git-core because it's the only place I've had a problem. It's possible that something else I've installed has taken over a system default? Like I said, I removed the Errno.pm file from the MacPorts directory and everything works fine.

 port installed 'p5-*'
The following ports are currently installed:
  p5-bsd-resource @1.28_0 (active)
  p5-compress-raw-zlib @2.015_0 (active)
  p5-compress-zlib @2.015_0 (active)
  p5-danga-socket @1.59_0 (active)
  p5-error @0.17015_0 (active)
  p5-html-parser @3.56_0 (active)
  p5-html-tagset @3.20_0 (active)
  p5-inline @0.44_2 (active)
  p5-io-aio @3.07_0 (active)
  p5-io-compress-base @2.015_0 (active)
  p5-io-compress-zlib @2.015_0 (active)
  p5-io-kqueue @0.32_0 (active)
  p5-libwww-perl @5.814_0 (active)
  p5-locale-gettext @1.05_0 (active)
  p5-net-netmask @1.9015_0 (active)
  p5-parse-recdescent @1.94_1 (active)
  p5-svn-simple @0.27_0 (active)
  p5-sys-syscall @0.22_0 (active)
  p5-term-readkey @2.30_0 (active)
  p5-time-hires @1.9715_0 (active)
  p5-uri @1.35_1 (active)

comment:9 Changed 13 years ago by blb@…

As an experiment, try putting the Errno.pm back (so things should be as MacPorts originally installed), then edit /opt/local/libexec/git-core/git-svn so the shebang line which looks like

#!/usr/bin/perl

instead reads

#!/opt/local/bin/perl

See what happens.

comment:10 Changed 13 years ago by maccheck@…

Sorry, that was my fault when I removed the PERL_PATH environment variable in the Portfile. The Makefile in git-core defaults to /usr/bin/perl if that environment variable isn't set.

I'm attaching an updated Portfile to that bug.

Changed 13 years ago by maccheck@…

Attachment: Portfile.patch added

comment:11 Changed 13 years ago by Damien.Pollet@…

Not sure if this is actually related… I get this when attempting an svn+ssh clone on a G5:

Network connection closed unexpectedly: Connection closed unexpectedly at /opt/local/libexec/git-core/git-svn line 1400

It works nicely on a MacBook. Both machines have git-core @1.6.0.2_0+bash_completion+doc+svn

comment:12 Changed 13 years ago by alakazam@…

Hi, I too have encountered this bug. I have not yet tested the attached patch, but if it does fix the issue, I think it would be nice to have it checked it ! Thanks !

comment:13 Changed 13 years ago by blb@…

Owner: changed from bryan@… to blb@…
Status: newassigned

comment:14 Changed 13 years ago by blb@…

Resolution: fixed
Status: assignedclosed

Patch applied (though I quoted the paths for safety) in r40841.

comment:15 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.