Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#16778 closed enhancement (fixed)

cairo @1.8.0 requesting a +no_quartz variant

Reported by: mail_ben_schmidt@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: mail_ben_schmidt@…
Port: cairo, cairo-devel, pango, pango-devel

Description

Could a +no_quartz variant be added to the cairo port, please? The Quartz backend causes problems for me with Hebrew text. By the look of it, Quartz has some built-in bidirectional support that screws things up.

I guess there is a slight chance this is related to #15626. Even if it isn't related, the users experiencing the deficiency of that ticket may benefit from such a variant, too.

A simple patch that adds the variant is attached.

To make the problem go away, one must activate cairo with +no_quartz and then recompile pango (I do port -vf deactivate cairo, port -vf install cairo +no_quartz, port -vf uninstall pango @1.22.0_0, port -vf install pango). I guess this means pango must link against cairo statically. Is there any chance of changing that, too? I would open a second ticket, but I believe the maintainer is the same, so perhaps just a comment here will suffice.

The problem is demonstrated in the attached pictures, which show a GTK2 GUI version of Vim displaying the attached text file with :set rightleft wrap linebreak. My suspicion that it is to do with bidi is substantiated by the fact that portions of the lines seem to be simply reversed in the consonant-only text (the part at the bottom without all the dots).

Attachments (4)

quartz.png (38.1 KB) - added by mail_ben_schmidt@… 12 years ago.
no_quartz.png (36.9 KB) - added by mail_ben_schmidt@… 12 years ago.
heb.txt (444 bytes) - added by mail_ben_schmidt@… 12 years ago.
Portfile.patch (1.5 KB) - added by mail_ben_schmidt@… 12 years ago.

Download all attachments as: .zip

Change History (10)

Changed 12 years ago by mail_ben_schmidt@…

Attachment: quartz.png added

Changed 12 years ago by mail_ben_schmidt@…

Attachment: no_quartz.png added

Changed 12 years ago by mail_ben_schmidt@…

Attachment: heb.txt added

comment:1 Changed 12 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to ryandesign@…
Port: cairo added

Assigning to maintainer.

Changed 12 years ago by mail_ben_schmidt@…

Attachment: Portfile.patch added

comment:2 Changed 12 years ago by mail_ben_schmidt@…

Cc: mail_ben_schmidt@… added

Cc Me!

comment:3 in reply to:  description ; Changed 12 years ago by ryandesign (Ryan Schmidt)

Replying to mail_ben_schmidt@…: I guess this means pango must link against cairo statically. Is there any chance of changing that, too? I would open a second ticket, but I believe the maintainer is the same, so perhaps just a comment here will suffice.

Please file a separate issue against pango for that, or better yet, file a bug report with the developers of Pango. I don't think I would know what to do to fix it.

comment:4 in reply to:  3 Changed 12 years ago by mail_ben_schmidt@…

Replying to ryandesign@…:

Replying to mail_ben_schmidt@…: Please file a separate issue against pango for that, or better yet, file a bug report with the developers of Pango. I don't think I would know what to do to fix it.

OK, I'll try to do that when I have a moment: check it isn't just a configure flag and then nag the Pango guys about it. Same with the actual text rendering bug: I'll try to report that to the cairo folks. This ticket can just be about adding a no_quartz variant as a workaround/option.

comment:5 Changed 12 years ago by ryandesign (Ryan Schmidt)

Port: cairo-devel pango pango-devel added
Resolution: fixed
Status: newclosed

The problem is fixed, slightly differently than you suggested: in r47716 I moved Quartz support in cairo and pango to a +quartz variant which is off by default, giving you your no-quartz option.

comment:6 Changed 12 years ago by (none)

Milestone: Port Enhancements

Milestone Port Enhancements deleted

Note: See TracTickets for help on using tickets.