Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#17380 closed defect (fixed)

perl5 activation error when installing gimp

Reported by: pfo.mac@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: gimp, perl5, perl5.8 Cc:
Port: perl5

Description

On a clean MacPorts system (with MacPorts installed but no additional port) on a MacBook running MacOS 10.5.5. I tried to install gimp. When trying to install perl5 I get an installation error. My guess is that it has something to do with perl5.8 that installed earlier and has version 5.8.8_3, whereas perl5 has version 5.8.8_0.

See attached file with the terminal log of the port command.

Attachments (1)

port gimp.txt (14.5 KB) - added by pfo.mac@… 12 years ago.

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by pfo.mac@…

Attachment: port gimp.txt added

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Keywords: perl5 perl5.8 added; pearl5 pearl5.8 removed
Owner: changed from macports-tickets@… to mcalhoun@…
Port: perl5 added; gimp removed

See #16830 for the source of your troubles.

comment:2 in reply to:  1 Changed 12 years ago by pfo.mac@…

Replying to jmr@…:

See #16830 for the source of your troubles.

I agree that the problem is caused by two versions of perl. But that it arises when installing gimp, is caused by the fact that gimp is (indirectly) dependent on two different versions of a single component and in my opinion that should not be the case. Unfortunately I am not yet good enough to see at what level in the dependency hierarchy of gimp the problem is caused, but the problem can not be solved by a perl maintainer. That person can never make a client module that is dependent on two versions of perl be dependent on only one version of pearl.

Is there an easy way to see the complete dependency tree of gimp?

comment:3 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

I believe that

sudo port uninstall perl5
sudo port install gimp

should solve your problem.

If not, then I think that

sudo port -f uninstall perl5
sudo port install gimp

is ok.

The error seems to stem (at least partially) from the p5-* ports.
The p5-* dependencies were changed in r42484 and r42584, but there is no way to get them to everybody until MacPorts 1.7.0 is released.
#14553 has more to say on why that is.

Please let me know if this fixes the problem.

comment:4 in reply to:  3 Changed 12 years ago by pfo.mac@…

Replying to mcalhoun@…:

Trying your first suggestion, installing gimp now passes the point of the perl error.

The gimp installation now halts at a supposedly unrelated gegl error (see #17409).

comment:5 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: fixed
Status: newclosed

Glad to hear that you're at least a few steps closer.

comment:6 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.