Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#18520 closed defect (fixed)

ffmpeg-15261 fetch error - svn repository moved

Reported by: toru-macports@… Owned by: acho@…
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: Cc: gooroo175@…
Port: ffmpeg

Description

--->  Fetching ffmpeg
Error: Target org.macports.fetch returned: shell command "svn co -r15261 --ignore-externals svn://svn.mplayerhq.hu/ffmpeg/trunk /opt/local/var/macports/distfiles/ffmpeg/15261/trunk" returned error 1
Command output: svn: Unknown hostname 'svn.mplayerhq.hu'

Error: Status 1 encountered during processing.

Source code repository seems to have moved to svn://svn.ffmpeg.org/ffmpeg/. I tried to replace svn.mplayerhq.hu with svn.ffmpeg.org in Portfile and succeeded in building the port.

Change History (6)

comment:1 Changed 12 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to acho@…
Priority: HighNormal

comment:2 Changed 12 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

Unable to reproduce and svn.ffmpeg.org and svn.mplayerhq.hu both resolve to the same address

$ host svn.ffmpeg.org
svn.ffmpeg.org has address 213.144.138.186
$ host svn.mplayerhq.hu
svn.mplayerhq.hu has address 213.144.138.186

so this must have been a transient DNS problem.

However, ffmpeg.org does appear to be the preferred domain (based on svn instructions on the newly updated website) so have updated both ffmpeg and ffmpeg-devel to use this domain for both homepage and svn fetch urls.

Changes committed in r46923.

comment:3 Changed 12 years ago by gooroo175@…

Cc: gooroo175@… added

Cc Me!

comment:4 Changed 12 years ago by gooroo175@…

The server is currently not responding on both of the urls. Is there a possibility to store the needed revision somewhere else?

comment:5 Changed 12 years ago by dbevans (David B. Evans)

See #18818.

comment:6 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.