Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#18732 closed enhancement (fixed)

RFE: Remove p5-getopt-long from dependencies

Reported by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez) Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: Cc: sal@…, mklein-de (Michael Klein), simon@…
Port: uagen, snmptt, p5-app-cl, p5-getopt-simple, i, p5-postscript-font, p5-test-inline

Description (last modified by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez))

Since perl seems to provide version 2.37 of p5-getopt-long, I propose it be removed as a dependency.
This would also go toward fixing #12875.

Affected ports:

  • mail/uagen
  • net/snmptt
  • perl/p5-app-cli
  • perl/p5-getopt-simple
  • perl/p5-postscript-font
  • perl/p5-test-inline

Change History (5)

comment:1 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Description: modified (diff)
Status: newassigned

comment:2 Changed 12 years ago by raimue (Rainer Müller)

Will this dependency come back again as soon as a new version of Getopt::Long is available? Or has this only been used for some newer feature before?

comment:3 in reply to:  2 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Replying to raimue@…:

Will this dependency come back again as soon as a new version of Getopt::Long is available? Or has this only been used for some newer feature before?

It is difficult to say for certain.
It depends on when a new version is released and how quickly the developers decide to start using the new features.

Since p5-getopt-long can not be installed without the "-f" option, I still think this is an acceptable step.

comment:4 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: fixed
Status: assignedclosed

Fixed in r49118.

comment:5 Changed 12 years ago by (none)

Milestone: Port Enhancements

Milestone Port Enhancements deleted

Note: See TracTickets for help on using tickets.