Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#19456 closed defect (duplicate)

port upgrade does not utilize binary archives

Reported by: fracai Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 1.7.1
Keywords: upgrade, archive Cc:
Port:

Description

While "port install" makes use of binary archives located in macports/packages/, "port upgrade" proceeds to fetch, configure, build, etc.

"upgrade" should utilize available archived packages, as well as honor binary-only mode.

Upgrades work as expected if the package is first unarchived. A new archive is then NOT created following an "unarchive" and "upgrade".

A new archive IS created, overwriting the existing, unused package, during a straight upgrade process.

Change History (2)

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #10785.

comment:2 Changed 11 years ago by jmroot (Joshua Root)

Milestone: MacPorts Future
Note: See TracTickets for help on using tickets.