Opened 12 years ago

Closed 12 years ago

#19732 closed defect (invalid)

murmur will not compile; error is "gcc: cannot specify -o with -c or -S and multiple compilations"

Reported by: jlg@… Owned by: nerdling (Jeremy Lavergne)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: murmur

Description (last modified by tobypeterson)

This is on Mac OS X Server 10.4.11.

# port install murmur
--->  Fetching murmur
--->  Attempting to fetch mumble-1.1.7.tar.gz from http://downloads.sourceforge.net/mumble
--->  Verifying checksum(s) for murmur
--->  Extracting murmur
--->  Configuring murmur
--->  Building murmur
Error: Target org.macports.build returned: shell command "cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_murmur/work/mumble-1.1.7 && make" returned error 2
Command output: cd src/murmur/ && /opt/local/bin/qmake-mac murmur.pro -macx CONFIG-=app_bundle CONFIG+=\ release\ no-universal\ no-client\ no-ice\  -o Makefile
cd src/murmur/ && make -f Makefile 
make -f Makefile.Release
/usr/bin/g++-4.0 -pipe -Wshadow -Woverloaded-virtual -Wold-style-cast -Wconversion -Wsign-compare -fvisibility=hidden -Os -I/opt/local/include -Wall -W -arch ppc -isysroot /Developer/SDKs/MacOSX10.4u.sdk -DRESTRICT=__restrict__ -DMUMBLE_VERSION_STRING=1.1.7 -DQT_NO_DEBUG -DQT_SQL_LIB -DQT_XML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/opt/local/libexec/qt4-mac/mkspecs/macx-g++ -I. -I/opt/local/libexec/qt4-mac/lib/QtCore.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtCore -I/opt/local/libexec/qt4-mac/lib/QtNetwork.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtNetwork -I/opt/local/libexec/qt4-mac/lib/QtXml.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtXml -I/opt/local/libexec/qt4-mac/lib/QtSql.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtSql -I/opt/local/libexec/qt4-mac/include -I/opt/local/libexec/qt4-mac/lib/QtDBus.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtDBus -I/opt/mumble/boost -I../../src -Irelease -I. -F/opt/local/libexec/qt4-mac/lib -x c++-header -c murmur_pch.h -o release/murmurd.gch/c++
gcc -pipe -Wshadow -Wconversion -Wsign-compare -fvisibility=hidden -Os -I/opt/local/include -Wall -W -arch ppc -isysroot /Developer/SDKs/MacOSX10.4u.sdk -DRESTRICT=__restrict__ -DMUMBLE_VERSION_STRING=1.1.7 -DQT_NO_DEBUG -DQT_SQL_LIB -DQT_XML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/opt/local/libexec/qt4-mac/mkspecs/macx-g++ -I. -I/opt/local/libexec/qt4-mac/lib/QtCore.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtCore -I/opt/local/libexec/qt4-mac/lib/QtNetwork.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtNetwork -I/opt/local/libexec/qt4-mac/lib/QtXml.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtXml -I/opt/local/libexec/qt4-mac/lib/QtSql.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtSql -I/opt/local/libexec/qt4-mac/include -I/opt/local/libexec/qt4-mac/lib/QtDBus.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtDBus -I/opt/mumble/boost -I../../src -Irelease -I. -F/opt/local/libexec/qt4-mac/lib -x objective-c++-header -c murmur_pch.h -o release/murmurd.gch/objective-c++
gcc: cannot specify -o with -c or -S and multiple compilations
make[2]: *** [release/murmurd.gch/objective-c++] Error 1
make[1]: *** [release] Error 2
make: *** [sub-src-murmur-make_default-ordered] Error 2

Error: Status 1 encountered during processing.

Change History (5)

comment:1 Changed 12 years ago by tobypeterson

Description: modified (diff)
Keywords: murmur gcc error removed
Version: 1.7.1

comment:2 Changed 12 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to snc@…

comment:3 Changed 12 years ago by nerdling (Jeremy Lavergne)

Status: newassigned

Presently attempting to build 10.4u ppc tree.

comment:4 Changed 12 years ago by nerdling (Jeremy Lavergne)

This built for the ticket submitter on his G5 10.5 box. This issue appears to strictly be a 10.4 issue.

comment:5 Changed 12 years ago by nerdling (Jeremy Lavergne)

Resolution: invalid
Status: assignedclosed

Ticket submitter was able to successfully build murmur by reinstalling Xcode.

Note: See TracTickets for help on using tickets.