Opened 11 years ago

Closed 10 years ago

#19937 closed defect (duplicate)

SuiteSparse - 3.3.0 - initial compile fails

Reported by: jameskyle@… Owned by: stechert@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc:
Port: SuiteSparse

Description

I have noticed this over the last couple of months of ports development. SuiteSparse *always* fails on the first compile attempt, but if I restart the install it succeeds without error.

I wish I could provide more information, but the fact that it succeeds the second time makes it a bit difficult:

--->  Building SuiteSparse
Error: Target org.macports.build returned: shell command " cd "/Users/jkyle/Projects/macports/ports_test/var/macports/build/_Users_jkyle_Projects_macports_dports_math_SuiteSparse/work/SuiteSparse" && make -j8 " returned error 2
Command output: /usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../Cholesky/cholmod_rcond.c -o cholmod_l_rcond.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../Cholesky/cholmod_resymbol.c -o cholmod_l_resymbol.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../Cholesky/cholmod_rowcolcounts.c -o cholmod_l_rowcolcounts.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../Cholesky/cholmod_rowfac.c -o cholmod_l_rowfac.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../Cholesky/cholmod_solve.c -o cholmod_l_solve.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../Cholesky/cholmod_spsolve.c -o cholmod_l_spsolve.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../MatrixOps/cholmod_drop.c -o cholmod_l_drop.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../MatrixOps/cholmod_horzcat.c -o cholmod_l_horzcat.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../MatrixOps/cholmod_norm.c -o cholmod_l_norm.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../MatrixOps/cholmod_scale.c -o cholmod_l_scale.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../MatrixOps/cholmod_sdmult.c -o cholmod_l_sdmult.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../MatrixOps/cholmod_ssmult.c -o cholmod_l_ssmult.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../MatrixOps/cholmod_submatrix.c -o cholmod_l_submatrix.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../MatrixOps/cholmod_vertcat.c -o cholmod_l_vertcat.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../MatrixOps/cholmod_symmetry.c -o cholmod_l_symmetry.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../Modify/cholmod_rowadd.c -o cholmod_l_rowadd.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../Modify/cholmod_rowdel.c -o cholmod_l_rowdel.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../Modify/cholmod_updown.c -o cholmod_l_updown.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../Supernodal/cholmod_super_numeric.c -o cholmod_l_super_numeric.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../Supernodal/cholmod_super_solve.c -o cholmod_l_super_solve.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../Supernodal/cholmod_super_symbolic.c -o cholmod_l_super_symbolic.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../Partition/cholmod_ccolamd.c -o cholmod_l_ccolamd.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../Partition/cholmod_csymamd.c -o cholmod_l_csymamd.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../Partition/cholmod_metis.c -o cholmod_l_metis.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../Partition/cholmod_nesdis.c -o cholmod_l_nesdis.o
/usr/bin/gcc-4.0 -O3 -fno-common -no-cpp-precomp -fexceptions  -DDLONG -c -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include -I/Users/jkyle/Projects/macports/ports_test/include -I../../CCOLAMD/Include -I../../CAMD/Include -I../Include -I../../UFconfig ../Partition/cholmod_camd.c -o cholmod_l_camd.o
ar cr libcholmod.a cholmod_aat.o cholmod_add.o cholmod_band.o cholmod_change_factor.o cholmod_common.o cholmod_complex.o cholmod_copy.o cholmod_dense.o cholmod_error.o cholmod_factor.o cholmod_memory.o cholmod_sparse.o cholmod_transpose.o cholmod_triplet.o cholmod_check.o cholmod_read.o cholmod_write.o cholmod_amd.o cholmod_analyze.o cholmod_colamd.o cholmod_etree.o cholmod_factorize.o cholmod_postorder.o cholmod_rcond.o cholmod_resymbol.o cholmod_rowcolcounts.o cholmod_rowfac.o cholmod_solve.o cholmod_spsolve.o cholmod_drop.o cholmod_horzcat.o cholmod_norm.o cholmod_scale.o cholmod_sdmult.o cholmod_ssmult.o cholmod_submatrix.o cholmod_vertcat.o cholmod_symmetry.o cholmod_rowadd.o cholmod_rowdel.o cholmod_updown.o cholmod_super_numeric.o cholmod_super_solve.o cholmod_super_symbolic.o cholmod_ccolamd.o cholmod_csymamd.o cholmod_metis.o cholmod_nesdis.o cholmod_camd.o cholmod_l_aat.o cholmod_l_add.o cholmod_l_band.o cholmod_l_change_factor.o cholmod_l_common.o cholmod_l_complex.o cholmod_l_copy.o cholmod_l_dense.o cholmod_l_error.o cholmod_l_factor.o cholmod_l_memory.o cholmod_l_sparse.o cholmod_l_transpose.o cholmod_l_triplet.o cholmod_l_check.o cholmod_l_read.o cholmod_l_write.o cholmod_l_amd.o cholmod_l_analyze.o cholmod_l_colamd.o cholmod_l_etree.o cholmod_l_factorize.o cholmod_l_postorder.o cholmod_l_rcond.o cholmod_l_resymbol.o cholmod_l_rowcolcounts.o cholmod_l_rowfac.o cholmod_l_solve.o cholmod_l_spsolve.o cholmod_l_drop.o cholmod_l_horzcat.o cholmod_l_norm.o cholmod_l_scale.o cholmod_l_sdmult.o cholmod_l_ssmult.o cholmod_l_submatrix.o cholmod_l_vertcat.o cholmod_l_symmetry.o cholmod_l_rowadd.o cholmod_l_rowdel.o cholmod_l_updown.o cholmod_l_super_numeric.o cholmod_l_super_solve.o cholmod_l_super_symbolic.o cholmod_l_ccolamd.o cholmod_l_csymamd.o cholmod_l_metis.o cholmod_l_nesdis.o cholmod_l_camd.o
ranlib libcholmod.a
make[1]: *** [library] Error 2
make: *** [default] Error 2

Error: The following dependencies failed to build: octave SuiteSparse fftw-3 g95 gawk glpk gnuplot aquaterm gd2 xpm pdflib hdf5 pcre bzip2 qhull texinfo python_select
Error: Status 1 encountered during processing.

Change History (5)

comment:1 Changed 11 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to stechert@…
Port: SuiteSparse added

In the future, please set the port field and assign tickets to the port's maintainer.

comment:2 in reply to:  1 Changed 11 years ago by jameskyle@…

Replying to macsforever2000@…:

In the future, please set the port field and assign tickets to the port's maintainer.

Will do.

comment:3 Changed 11 years ago by stechert@…

Status: newassigned

The fact that it succeeds the second time may be spurious. E.g., if a partial .lib file is being created, /usr/bin/make will be satisfied that the target is up to date, but it may be missing some compilation units.

I've verified that it "works for me", but please, as discussed in email, try building with -dv so we can get to whatever the actual error is. Also would be helpful to know more about what hardware and OS version you're on.

comment:4 Changed 11 years ago by blb@…

Definitely looks like a parallel build issue, setting use_parallel_build no gets it to build on the first try. Note that if you aren't seeing this, MacPorts 1.7 disables parallel building by default but trunk enables it, which may explain why some see it and some don't.

comment:5 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed

Duplicate of #20687.

Note: See TracTickets for help on using tickets.