Opened 11 years ago

Closed 11 years ago

#21536 closed defect (fixed)

cryptlib 3.3.1 fails to compile under SL

Reported by: pkutzner+macports@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: Cc:
Port: cryptlib

Description

I'm trying to install cryptlib, but compilation fails stating my processor doesn't support x86-64, which is untrue. I'm running a MacBook 4,1 (core2-duo, which *is* x86-64 capable) and Snow Leopard 10.6.1 along with the latest version of Macports synced just before attempting the installation. I've attached a text file of the compiler output.

Attachments (1)

cryptlib_compile_fail.txt (4.2 KB) - added by pkutzner+macports@… 11 years ago.

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by pkutzner+macports@…

Attachment: cryptlib_compile_fail.txt added

comment:1 Changed 11 years ago by tobypeterson

The selected CPU in this case is pentium, due to the -march=pentium flag.

comment:2 Changed 11 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.