Opened 7 years ago

Closed 6 years ago

#21624 closed defect (fixed)

pango @1.26.0_0+macosx makes software freeze

Reported by: vinc17@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: Cc: cduvivier@…, david@…, jpenney@…, whitley@…, carpeneto@…, yacoob@…, elelay (Eric Le Lay)
Port: pango

Description

After upgrading from pango @1.24.5_0+macosx to pango @1.26.0_0+macosx, at least two applications based on pango started to freeze, without any error message: liferea (the window didn't appear) and a Perl script using rrdtool (freezing and taking 100% CPU time, probably in RRDs::graph).

Attachments (1)

gq crash details.txt (30.1 KB) - added by Russell-Jones-OxPhys (Russell Jones) 7 years ago.
"Problem Report for gq" Problem Details and System Configuration

Download all attachments as: .zip

Change History (24)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

The only thing I can do about that is report it to the pango developers, so it would be more efficient for you to do so, since you can better describe the problem and test possible fixes.

comment:2 Changed 7 years ago by vinc17@…

OK, I'll do that (since this is always reproducible, I can try to look at traces and so on). But it would be interesting to know if other users can reproduce the problem too, and on which OS X version.

I have Mac OS X 10.4.11 / PowerPC.

comment:3 Changed 7 years ago by avsmith@…

I have some unexplained problem where a number of applications have slowed to a crawl when I try to start them up. I've seen issues with 'gnubg', 'gimp2', and 'inkscape'. I've also suspected that the underlying issue is from pango. I've also had the problem on two different computers. I can't put any more exact description on the problem, but it is more than annoying.

comment:4 Changed 7 years ago by ryandesign (Ryan Schmidt)

Please report these issues to the developers of pango.

comment:5 Changed 7 years ago by ryandesign (Ryan Schmidt)

comment:6 Changed 7 years ago by hanche

I just reported ticket #21679 which seems to be the same problem. There is a sample of a hanging inkscape there.

comment:7 Changed 7 years ago by ryandesign (Ryan Schmidt)

  • Status changed from new to assigned

I've reverted the pango port back to 1.24.5 (r58513) until the developers of pango figure out how to fix this.

comment:8 Changed 7 years ago by ryandesign (Ryan Schmidt)

Has duplicates #21678, #21679, #21701. Was also reported several times on the mailing list.

comment:9 Changed 7 years ago by cduvivier@…

  • Cc cduvivier@… added

Cc Me!

comment:10 Changed 7 years ago by david@…

  • Cc david@… added

Cc Me!

comment:11 Changed 7 years ago by jpenney@…

  • Cc jpenney@… added

Cc Me!

comment:12 Changed 7 years ago by whitley@…

  • Cc whitley@… added

Cc Me!

comment:13 Changed 7 years ago by ryandesign (Ryan Schmidt)

Has duplicate #22054 (requested update to 1.26.0; referred back here explaining why we can't right now).

The upstream bug report now indicates this appears to be an incompatibility with Apple's gcc; it allegedly works fine with normal gcc. So we could possibly make pango compile using, say, the gcc44 port. But I don't know what impact that would have on other ports -- e.g., would ports that want to link with pango also have to use gcc44? If so, that wouldn't be an acceptable solution since half the known universe depends on pango.

comment:14 Changed 7 years ago by carpeneto@…

  • Cc carpeneto@… added

Cc Me!

comment:15 Changed 7 years ago by mike@…

Gtk-demo was freezing for me. Adding "configure.compiler macports-gcc-4.3" to pango's Portfile fixed this. Obviously, this is not a permanent solution. However, it does seem to support the upstream diagnosis.

comment:16 Changed 7 years ago by mike@…

This Portfile worked for me: http://trac.macports.org/attachment/ticket/17049/Portfile. As far as I can tell I this Portfile builds pango using Apple's gcc.

comment:17 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

The upstream bugzilla mentions a patch that might fix this. I'm testing.

comment:18 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

And it seems ineffective...

comment:19 Changed 7 years ago by yacoob@…

  • Cc yacoob@… added

Cc Me!

comment:20 Changed 7 years ago by Russell-Jones-OxPhys (Russell Jones)

Cross posted from #22801

Replying to russell.jones@…:

Replying to ryandesign@…:

This should fix itself when we upgrade pango to 1.26.x, because we then won't use the muniversal portgroup anymore. But we can't upgrade to 1.26.x right now because it causes problems.

For now, it looks like you cannot install pango 1.24.5 universal with quartz. I could possibly work around this by looking at how pango 1.26.0 generates its libpangocairo-1.0.la file when building universal with quartz, and apply that to 1.24.5's file.

I tried building 1.26.0 (may try 1.26.2 in a bit) using the Portfile attached to #21624, but I get the same error. I commented out the PortGroup muniversal 1.0 line and then pango and GTK2 built +no_x11 +quartz. I'm hoping to go on to build gq then to try to build workrave using the instructions here: http://old.nabble.com/How-I-got-1.9.0-compiled-on-Mac-OS-X-10.6-(-Snow-Leopard)-td25547590.html

I can't get openldap to build, which is unrelated, but is stopping me building gq to see if GTK2 works at all. After I've prodded about a bit I'll file a bug against the openldap port (I couldn't find anything like openldap +universal x86_64 fails to build )

OK, Ryan Schmidt kindly fixed up the openldap port, so I could build gq with my altered portfile. It runs, but the underlined letters in the menus look odd, and it crashes a lot. I'll try with 1.26.2. (How does one compute rmd160 checksums?) Right, rebuilt pango. port doesn't seem to think gtk2 and gq need to be rebuilt.

I've attached the crash report details from when I press the "Options" button.

Changed 7 years ago by Russell-Jones-OxPhys (Russell Jones)

"Problem Report for gq" Problem Details and System Configuration

comment:21 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

This should be working for pango-devel as of r64195

comment:22 Changed 7 years ago by elelay (Eric Le Lay)

  • Cc elelay@… added

Cc Me!

comment:23 Changed 6 years ago by jmroot (Joshua Root)

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.