Opened 11 years ago

Closed 11 years ago

#21678 closed defect (duplicate)

"pango @1.26.0_0+macosx" breaks "meld @1.2_1"

Reported by: cduvivier@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: Cc:
Port: pango

Description

A recent upgrade (58293) bumped "pango @1.24.5_0+macosx" to "pango @1.26.0_0+macosx".

This new version makes "meld" broken/unusable. Starting meld makes the python interpreter endlessly run some pango code.

Going back to "pango @1.24.5_0+macosx" (using method described at http://journal.bitshaker.com/articles/2007/10/20/install-old-versions-of-ports-using-macports/) fixes the problem.

Uninstalling "pango @1.26.0_0+macosx" and using "pango-devel @1.25.6_0+macosx" instead is also problematic.

Change History (7)

comment:1 Changed 11 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to ryandesign@…
Priority: HighNormal

comment:2 Changed 11 years ago by ryandesign (Ryan Schmidt)

Since I don't use meld, it will be more efficient for you to report this directly to the developers of pango.

comment:3 Changed 11 years ago by cduvivier@…

meld is now at 1.3.1 (http://git.gnome.org/cgit/meld/), maybe the solution is to update the meld port (later meld may be more compatible with latest pango).

comment:4 Changed 11 years ago by ryandesign (Ryan Schmidt)

Updating meld was already requested here.

comment:5 Changed 11 years ago by cduvivier@…

I've also filed a bug against pango regarding this issue: https://bugzilla.gnome.org/show_bug.cgi?id=596674

comment:6 Changed 11 years ago by cduvivier@…

If anyone else has the issue, the way to restore a working meld is:
1) Add a line with "file:///Users/Shared/dports" before the rsync line in "/opt/local/etc/macports/sources.conf", this will tell port to also use some local packages.
2) Run "mkdir -p /Users/Shared/dports", this will create a directory for local packages.
3) Run "cd /Users/Shared/dports && svn co --revision 58292 http://svn.macports.org/repository/macports/trunk/dports/x11/pango/ x11/pango/", this will load the old working version of pango as local package.
4) Run "portindex /Users/Shared/dports", this will create a file port need to see the local packages.
5) Run "sudo port uninstall --follow-dependents pango" (keep a list of what gets uninstalled), this will properly uninstall the newer problematic pango and evrything depending on it.
6) Run "sudo port install meld", this will install meld and its dependencies (including the old working version of pango)
7) Install whatever else you missed which was uninstalled by 5)

comment:7 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #21624.

Note: See TracTickets for help on using tickets.