Opened 11 years ago

Closed 10 years ago

#23100 closed enhancement (fixed)

New port for grisbi 0.5.9

Reported by: gerald@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch maintainer Cc: roederja
Port: grisbi

Description

Patch for grisbi 0.5.9 work on Snow Leopard

Attachments (2)

Portfile-rrdtool.diff (1.1 KB) - added by gerald@… 11 years ago.
Portfile-grisbi.diff (1.4 KB) - added by gerald@… 10 years ago.
Portfile for the new stable (0.6.0) version of Grisbi

Download all attachments as: .zip

Change History (14)

Changed 11 years ago by gerald@…

Attachment: Portfile-rrdtool.diff added

comment:1 Changed 11 years ago by mf2k (Frank Schima)

Keywords: haspatch maintainer added; grisbi removed
Port: grisbi added
Type: submissionenhancement
Version: 1.8.2

comment:2 Changed 11 years ago by jmroot (Joshua Root)

Please don't patch the Id line. And why on earth is the patch file called "Portfile-rrdtool.diff"?

comment:3 Changed 11 years ago by gerald@…

Sorry, it was a mistake. I have stupidly copied the example from the documentation. Attached the good file, with the good name.

Regards.

comment:4 Changed 11 years ago by roederja

Cc: jann@… added

I think you should distinguish on platform i386 and ppc. What you are doing with build_arch seems wrong.

comment:5 Changed 10 years ago by gerald@…

Sorry for my english... some dependancies are not compiled in universal arch (x86_64 and i386) on a x86_64 platform. If grisbi compiled with universal flags on x86_64 platform execution of grisbi failed with a core dumped. I think i have find how to make this work : if {$build_arch == "x86_64"} {

configure.universal_archs i386

}

I will submit another patch for this Portfile, because the latest version of Grisbi is now the 0.6.0.

comment:6 Changed 10 years ago by gerald@…

I have submited the new diff file for the new 0.6.0 version of Grisbi. I have tested this and it works fine for me. I hope it is right.

comment:7 Changed 10 years ago by roederja

if {$build_arch == "x86_64"} {
    configure.universal_archs i386
}

This is not a good idea and I don't see the purpose of this. universal_archs is a user-setable variable to configure the platforms to build in a universal build. It should not be set in a portfile. If universal builds don't work for a port use

universal_variant   no

Also if you update the version of a port the revision should be reset to 0. i.e. remove the revision line.

comment:8 Changed 10 years ago by gerald@…

Using universal_variant do not work by default on x86_64 architecture on Snow Leopard. Some dependences require by Grisbi are not compiled in x86_64 mode and if i do not make that grisbi will be compiled for X86_64 architecture and his execution failed with a core dumped.

comment:9 Changed 10 years ago by roederja

I'm not quite sure I understand you correctly. So I will rephrase:

  1. Grisbi must be compiled in 32bit mode because of some dependencies
  2. Grisbi will not work properly in 64bit mode
  3. You force the universal variant to be 32bit only, so that the port will work as intended when installed as universal variant

However, if you install the port normally (i.e. not the universal variant) it will be built in 64bit mode and thus not work properly. Is that correct? Therefore I suggest you disable universal builds and force a 32bit build on intel platforms by patching the makefile or passing the -arch compiler flag.

comment:10 Changed 10 years ago by gerald@…

You understand correctly. I have look how make other ports to do that. I think the new Portfile i will submit now will be right.

Changed 10 years ago by gerald@…

Attachment: Portfile-grisbi.diff added

Portfile for the new stable (0.6.0) version of Grisbi

comment:11 Changed 10 years ago by nerdling (Jeremy Lavergne)

I think what you're after is this:

universal_variant no
supported_archs	ppc i386

comment:12 Changed 10 years ago by nerdling (Jeremy Lavergne)

Resolution: fixed
Status: newclosed

Updated in r70900.

Note: See TracTickets for help on using tickets.