Opened 10 years ago

Closed 10 years ago

#25234 closed defect (fixed)

kdelibs4 @4.4.4 fails to build on 10.6.3 due to attempting to use libxslt installed in /Library/Frameworks

Reported by: aidenn0@… Owned by: nerdling (Jeremy Lavergne)
Priority: Normal Milestone:
Component: ports Version: 1.9.0
Keywords: Cc: sharky@…
Port: kdelibs4

Description

I've attached the full log. The snippet that I believe shows the problem is below.

dden -fvisibility-inlines-hidden -O2 -DNDEBUG -DQT_NO_DEBUG -arch x86_64 -isysroot /Developer/SDKs/MacOSX10.6.sdk -mmacosx-version-min=10.6 -bundle -headerpad_max_install_names -multiply_defined suppress -L/opt/local/lib -o ../lib/kio_ghelp.so CMakeFiles/kio_ghelp.dir/kio_ghelp_automoc.o CMakeFiles/kio_ghelp.dir/kio_help.o CMakeFiles/kio_ghelp.dir/main_ghelp.o CMakeFiles/kio_ghelp.dir/xslt.o -F/opt/local/libexec/qt4-mac/lib -L/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdelibs4/work/build/lib -L/opt/local/lib ../lib/libkdecore.5.4.0.dylib ../lib/libkio.5.4.0.dylib /opt/local/lib/libxml2.dylib -framework libxslt ../lib/libkdeui.5.4.0.dylib ../lib/libkdecore.5.4.0.dylib -framework QtDBus -framework QtCore -lpthread -framework Carbon -framework QtSvg -framework QtNetwork -framework QtXml -framework QtGui ../lib/libsolid.4.4.0.dylib 
:info:build make[2]: Nothing to be done for `kfile/CMakeFiles/kfile.dir/build'.
:info:build /opt/local/bin/cmake -E cmake_progress_report /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdelibs4/work/build/CMakeFiles 
:info:build [ 56%] Built target kfile
:info:build /usr/bin/make -f kdoctools/CMakeFiles/kio_help.dir/build.make kdoctools/CMakeFiles/kio_help.dir/depend
:info:build ld: warning: in /Developer/SDKs/MacOSX10.6.sdk/Library/Frameworks//libxslt.framework/libxslt, missing required architecture x86_64 in file
:info:build Undefined symbols:
:info:build   "_xsltSaveResultTo", referenced from:
:info:build       transform(QString const&, QString const&, QVector<char const*> const&)in xslt.o
:info:build   "_xsltNewTransformContext", referenced from:
:info:build       transform(QString const&, QString const&, QVector<char const*> const&)in xslt.o
:info:build   "_xsltParseStylesheetFile", referenced from:
:info:build       transform(QString const&, QString const&, QVector<char const*> const&)in xslt.o
:info:build   "_xsltApplyStylesheet", referenced from:
:info:build       transform(QString const&, QString const&, QVector<char const*> const&)in xslt.o
:info:build   "_xsltFreeStylesheet", referenced from:
:info:build       transform(QString const&, QString const&, QVector<char const*> const&)in xslt.o
:info:build ld: symbol(s) not found
:info:build collect2: ld returned 1 exit status

Attachments (1)

main.log (507.0 KB) - added by aidenn0@… 10 years ago.
Log of build

Download all attachments as: .zip

Change History (11)

Changed 10 years ago by aidenn0@…

Attachment: main.log added

Log of build

comment:1 Changed 10 years ago by aidenn0@…

Cc: aidenn0@… added

Cc Me!

comment:2 Changed 10 years ago by mf2k (Frank Schima)

Cc: sharky@… added; aidenn0@… removed
Owner: changed from macports-tickets@… to snc@…
Port: kdelibs4 added

comment:3 Changed 10 years ago by jmroot (Joshua Root)

Summary: kdelibs4 @4.4.4 fails to build on 10.6.3 due to missing x86_64 libxsltkdelibs4 @4.4.4 fails to build on 10.6.3 due to attempting to use libxslt installed in /Library/Frameworks

/Developer/SDKs/MacOSX10.6.sdk/Library/Frameworks is a symlink to /Library/Frameworks.

comment:4 Changed 10 years ago by nerdling (Jeremy Lavergne)

I plan to add post-configure to examine the cmake cache file to see if it found the correct libxslt and if not manually replace it with a ${prefix} one.

This will need to wait on #25258.

comment:5 Changed 10 years ago by nerdling (Jeremy Lavergne)

Status: newassigned

comment:6 Changed 10 years ago by nerdling (Jeremy Lavergne)

Could you please run the following:

sudo port clean kdelibs4
sudo port configure kdelibs4
cp `port work kdelibs4`/build/CMakeCache.txt ~/

Then attach CMakeCache.txt from your home directory? Thanks.

comment:7 Changed 10 years ago by nerdling (Jeremy Lavergne)

If you're adventurous, you might also try adding this inside the configure.args lines via sudo port edit kdelibs4:

                        -DXSLT_INCLUDEDIR=${prefix}/include/ \
                        -DXSLT_LIBDIR=${prefix}/lib/ \

comment:8 Changed 10 years ago by nerdling (Jeremy Lavergne)

Ah, think I got it:

                        -DLIBXSLT_INCLUDE_DIR=${prefix}/include/ \
                        -DLIBXSLT_LIBRARIES=${prefix}/lib/libxslt.dylib \
                        -DLIBEXSLT_LIBRARIES=${prefix}/lib/libexslt.dylib \

comment:9 Changed 10 years ago by nerdling (Jeremy Lavergne)

Fixed in r69539.

comment:10 Changed 10 years ago by nerdling (Jeremy Lavergne)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.