Opened 10 years ago

Closed 10 years ago

#25235 closed defect (fixed)

slime: invalid command name "registry_installed"

Reported by: luis.beca@… Owned by: easye
Priority: Normal Milestone:
Component: ports Version: 1.9.0
Keywords: Cc:
Port: slime

Description

Slime 20100504 fails in the configure phase. See attached buildlog. Thanks.

Attachments (1)

slime_buildlog.txt (4.2 KB) - added by luis.beca@… 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by luis.beca@…

Attachment: slime_buildlog.txt added

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: easieste@… removed
Owner: changed from macports-tickets@… to easieste@…
Summary: Slime fails to buildslime: invalid command name "registry_installed"

Confirmed on my Mac with Snow Leopard and MacPorts 1.9.0.

Mark, "registry_installed" is not part of the portfile interface, and I'd guess that though this may have worked in 1.8.x it has changed and now doesn't work in 1.9.0. Ideally, find an alternate method to use in the portfile to determine if another port is installed; commonly, we test for the presence of a file the port is known to install.

comment:2 Changed 10 years ago by easye

Status: newassigned

comment:3 Changed 10 years ago by easye

Resolution: fixed
Status: assignedclosed

Remove use of 'registry_installed' in r68805, instead checking for existence of Emacs binary.

Note that the port does not currently use this value, as FASL compilation is disabled by default due to previous problems. Someday, we should check if this is still the case with emacs-23, possibly renabling.

Note: See TracTickets for help on using tickets.