Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#25418 closed defect (fixed)

mpfr upgrade failure: "Patch file patch01 is missing" on Snowleopard 10.6.4

Reported by: nilstec_inc@… Owned by: vinc17@…
Priority: Normal Milestone: MacPorts 1.9.2
Component: base Version: 1.9.1
Keywords: Cc:
Port: mpfr

Description

version:1
:msg:main --->  Computing dependencies for mpfr:info:main .:debug:main Searching for dependency: gmp
:debug:main Found Dependency: receipt exists for gmp
:msg:main 
:debug:main Executing org.macports.main (mpfr)
:debug:main Skipping completed org.macports.fetch (mpfr)
:debug:main Skipping completed org.macports.checksum (mpfr)
:debug:main setting option extract.cmd to /usr/bin/bzip2
:debug:main Skipping completed org.macports.extract (mpfr)
:debug:patch patch phase started at Fri Jun 25 13:15:32 CEST 2010
:debug:patch Executing org.macports.patch (mpfr)
:msg:patch --->  Applying patches to mpfr
:error:patch Target org.macports.patch returned: Patch file patch01 is missing
:debug:patch Backtrace: Patch file patch01 is missing
    while executing
"$procedure $targetname"
:info:patch Warning: the following items did not execute (for mpfr): org.macports.destroot org.macports.patch org.macports.configure org.macports.build
:notice:patch Log for mpfr is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_mpfr/main.log

Attachments (3)

installed.txt (8.3 KB) - added by nilstec_inc@… 11 years ago.
Output of "port installed"
mpfr-clean-upgrade.log (2.5 KB) - added by nilstec_inc@… 11 years ago.
upgrade-sudo.txt (451.6 KB) - added by nilstec_inc@… 11 years ago.
upgrade mpfr without sudo

Download all attachments as: .zip

Change History (14)

Changed 11 years ago by nilstec_inc@…

Attachment: installed.txt added

Output of "port installed"

comment:1 Changed 11 years ago by nilstec_inc@…

I am working in a 64bit system.

comment:2 Changed 11 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to vinc17@…
Port: mpfr added

In the future, please fill in the port field and Cc the maintainer(s).

comment:3 in reply to:  2 Changed 11 years ago by nilstec_inc@…

Replying to macsforever2000@…:

In the future, please fill in the port field and Cc the maintainer(s).

I am sorry! Thanks for your effort!

comment:4 Changed 11 years ago by jmroot (Joshua Root)

Looks like the extract phase was run and then the patch file was deleted. Clean and try again, it should re-fetch the patch.

comment:5 Changed 11 years ago by vinc17@…

I cannot reproduce the problem on Tiger, but I doubt the OS version matters here. This seems to be either a bug in base or a user-side error. Unfortunately the bug report doesn't say anything about the extract phase that occurred in the past.

comment:6 Changed 11 years ago by nilstec_inc@…

I did sudo port clean mpfr and sudo port upgrade outdated, this gives me the following log. Can i supply anything else which might help? Thanks again!

Changed 11 years ago by nilstec_inc@…

Attachment: mpfr-clean-upgrade.log added

comment:7 in reply to:  6 ; Changed 11 years ago by snowflake (Dave Evans)

Replying to nilstec_inc@…:

sudo port patch mpfr fails for me, but without the sudo it works. Maybe there is a permissions problem. I'm using Snow Leopard.

comment:8 in reply to:  7 Changed 11 years ago by nilstec_inc@…

Replying to dave.evans55@…:

Replying to nilstec_inc@…:

sudo port patch mpfr fails for me, but without the sudo it works. Maybe there is a permissions problem. I'm using Snow Leopard.

Hey, your're right, without the sudo ist builds something. But of course it fails when it tries to install that. Is there some workaround possible with that? Or is it building the wrong thing?

I'll supply port -v upgrade mpfr done after a cleaning.

Changed 11 years ago by nilstec_inc@…

Attachment: upgrade-sudo.txt added

upgrade mpfr without sudo

comment:9 Changed 11 years ago by jmroot (Joshua Root)

Component: portsbase
Resolution: fixed
Status: newclosed

Technically a base bug. You fetched mpfr without using sudo. Run sudo port clean --dist mpfr or delete the mpfr distfiles subdir under ~/.macports to work around.

Fixed in r69334.

comment:10 in reply to:  9 Changed 11 years ago by nilstec_inc@…

Replying to jmr@…:

Technically a base bug. You fetched mpfr without using sudo. Run sudo port clean --dist mpfr or delete the mpfr distfiles subdir under ~/.macports to work around.

Fixed in r69334.

It worked! Thank you very much! :)

comment:11 Changed 11 years ago by jmroot (Joshua Root)

Milestone: MacPorts 1.9.2
Note: See TracTickets for help on using tickets.