Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#25417 closed defect (invalid)

t1lib did not build /opt/local/lib/libt1.dylib

Reported by: nilstec_inc@… Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: gabrielesvelto (Gabriele Svelto), vortexfive@…, ted@…, rob.patro@…, ryandesign (Ryan Schmidt)
Port: t1lib

Description

version:1
:debug:main Executing org.macports.main (texlive-bin)
:debug:main Skipping completed org.macports.fetch (texlive-bin)
:debug:main Skipping completed org.macports.checksum (texlive-bin)
:debug:main setting option extract.cmd to /usr/bin/bzip2
:debug:main Skipping completed org.macports.extract (texlive-bin)
:debug:main Skipping completed org.macports.patch (texlive-bin)
:msg:main --->  Configuring texlive-bin
:debug:main Using compiler 'Mac OS X gcc 4.2'
:debug:configure configure phase started at Fri Jun 25 13:24:39 CEST 2010
:debug:configure Executing proc-pre-org.macports.configure-configure-0
:error:configure The file /opt/local/lib/libt1.dylib does not exist, though it was
:error:configure expected to have been provided by one of texlive-bin's dependencies. Try
:error:configure rebuilding the port that should have provided that file by running
:error:configure 
:error:configure     sudo port -n upgrade --force <portname>
:error:configure 
:error:configure Target org.macports.configure returned: missing required file
:debug:configure Backtrace: missing required file
    while executing
"$pre $targetname"
:info:configure Warning: the following items did not execute (for texlive-bin): org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
:notice:configure Log for texlive-bin is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_tex_texlive-bin/main.log

Attachments (5)

installed.txt (8.3 KB) - added by nilstec_inc@… 10 years ago.
Output of "port installed"
t1libinstall.txt (33.8 KB) - added by nilstec_inc@… 10 years ago.
output of "sudo port -v install t1lib"
contents1lib.txt (208 bytes) - added by nilstec_inc@… 10 years ago.
Output of "port contents t1lib"
t1libinstall-gfortran.txt (33.2 KB) - added by nilstec_inc@… 10 years ago.
Output of sudo port -v install t1lib
main.log (3.4 KB) - added by nilstec_inc@… 9 years ago.
output of sudo port -u upgrade outdated

Download all attachments as: .zip

Change History (42)

comment:1 Changed 10 years ago by nilstec_inc@…

I don't know if it's important, but i've got MacTex installed (TeXShop, ...). I just need these ports for their dependency.

Changed 10 years ago by nilstec_inc@…

Attachment: installed.txt added

Output of "port installed"

comment:2 Changed 10 years ago by nilstec_inc@…

I am working in a 64bit system.

comment:3 Changed 10 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to dports@…
Port: texlive-bin added

In the future, please fill in the port field and Cc the maintainer(s).

comment:4 Changed 10 years ago by drkp (Dan Ports)

Status: newassigned

t1lib should provide /opt/local/lib/libt1.dylib, but I've seen at least one other report of it not existing. Try uninstalling and reinstalling t1lib?

comment:5 in reply to:  4 ; Changed 10 years ago by nilstec_inc@…

Replying to dports@…:

t1lib should provide /opt/local/lib/libt1.dylib, but I've seen at least one other report of it not existing. Try uninstalling and reinstalling t1lib?

I tried that a couple of times. It works without errors, but doesn't change the problem with texlive. I'll supply "sudo port -v install t1lib".

Changed 10 years ago by nilstec_inc@…

Attachment: t1libinstall.txt added

output of "sudo port -v install t1lib"

comment:6 in reply to:  3 Changed 10 years ago by nilstec_inc@…

Replying to macsforever2000@…:

In the future, please fill in the port field and Cc the maintainer(s).

I am sorry! Thanks for your effort!

comment:7 in reply to:  5 Changed 10 years ago by drkp (Dan Ports)

Replying to nilstec_inc@…:

I tried that a couple of times. It works without errors, but doesn't change the problem with texlive. I'll supply "sudo port -v install t1lib".

Thanks. Can you provide port contents t1lib too?

Changed 10 years ago by nilstec_inc@…

Attachment: contents1lib.txt added

Output of "port contents t1lib"

comment:8 Changed 10 years ago by nilstec_inc@…

Here it is. And thank you very much for your quick answers and help!

comment:9 Changed 10 years ago by nilstec_inc@…

I also want to mention my other ticket. So keep in mind, that i couldn't perform a complete upgrade of my port installation.

comment:10 Changed 10 years ago by drkp (Dan Ports)

Port: t1lib added; texlive-bin removed
Summary: The file /opt/local/lib/libt1.dylib does not exist, texlive-bin build failure on SnowLeopard 10.6.4t1lib did not build /opt/local/lib/libt1.dylib

comment:11 Changed 10 years ago by drkp (Dan Ports)

From the log, it looks like libtool is not building shared libraries for some reason. I haven't been able to reproduce this.

The only other difference between your log output and mine is that you have gfortran installed, but I can't imagine that'd make a difference.

comment:12 Changed 10 years ago by nilstec_inc@…

I renamed gfortran and tried again. But unfortunately it didn't help. I'll supply the log of the new run.

Changed 10 years ago by nilstec_inc@…

Attachment: t1libinstall-gfortran.txt added

Output of sudo port -v install t1lib

comment:13 Changed 10 years ago by gabrielesvelto (Gabriele Svelto)

Cc: gabriele.svelto@… added

Cc Me!

comment:14 Changed 10 years ago by vortexfive@…

I've had this problem for some time as well. For me it was solved after reinstalling libtool (I replaced libtool+darwin with libtool). However I don't know if that was the solution, or something else I might have changed during the months I've been having that problem.

comment:15 Changed 10 years ago by vortexfive@…

Cc: vortexfive@… added

Cc Me!

comment:16 in reply to:  14 Changed 10 years ago by nilstec_inc@…

Replying to vortexfive@…:

I've had this problem for some time as well. For me it was solved after reinstalling libtool (I replaced libtool+darwin with libtool). However I don't know if that was the solution, or something else I might have changed during the months I've been having that problem.

Thank you for your message! I had three libtools installed:

--->  The following versions of libtool are currently installed:
--->      libtool @2.2.6b_1+darwin
--->      libtool @2.2.10_0 (active)
--->      libtool @2.2.10_0+universal

I uninstalled all of them, and reinstalled using sudo port install libtool. Sadly this didn't change the error when trying to install texlive-bin. Can you remember anything else you did?

comment:17 Changed 10 years ago by vortexfive@…

I forgot to mention that I reinstalled t1lib as well, after reinstalling libtool. (The logs of the t1lib installation mentioned some problem about libtool.) If you've already tried this, I realy have no further ideas. I'm sorry I'cant help you.

comment:18 Changed 10 years ago by drkp (Dan Ports)

Cc: ted@… added

#26908 is a duplicate; cc'ing reporter. Note that there are also some logs attached to that ticket.

comment:19 Changed 10 years ago by drkp (Dan Ports)

Looks like this is being caused by a libtool problem -- maybe the one in #26384?

I don't understand libtool well enough to know what's going on, but uninstalling and rebuilding libtool may be a workaround.

comment:20 Changed 10 years ago by rob.patro@…

Cc: rob.patro@… added

Cc Me!

comment:21 Changed 10 years ago by rob.patro@…

So I had this exact issue (it came up when attempting to instal texlive-bin. I resolved it by commenting out the following line in the portfile

build.args          LIBTOOL=${prefix}/bin/glibtool

I just placed a '#' in front of it so it's now:

#build.args          LIBTOOL=${prefix}/bin/glibtool

After this, I have libt1.dylib in /opt/local/bin, and texlive-bin installs fine.

comment:22 in reply to:  21 Changed 10 years ago by ted@…

Replying to rob.patro@…:

So I had this exact issue (it came up when attempting to instal texlive-bin. I resolved it by commenting out the following line in the portfile

build.args          LIBTOOL=${prefix}/bin/glibtool

I just placed a '#' in front of it so it's now:

#build.args          LIBTOOL=${prefix}/bin/glibtool

After this, I have libt1.dylib in /opt/local/bin, and texlive-bin installs fine.

Y can confirm that this allows the build to proceed. The interesting thing is that I'd messed around with the problem a little bit on my machine. Here's an observation. On my machine, ranlib is getting called. This is a symlink from /usr/local/libtool on my machine. Perhaps an incompatibility between the two?

comment:23 in reply to:  21 ; Changed 10 years ago by drkp (Dan Ports)

Replying to rob.patro@…:

#build.args LIBTOOL=${prefix}/bin/glibtool

I tried this but it broke the +universal variant. (I guess that answers the question of why we had that line in the first place.)

I still can't reproduce this, but am wondering if something causes libtool to fail to build dylibs if gfortran is installed when libtool is built. I'd be interested in hearing from someone who's experiencing this problem:

  • do you have /opt/local/bin/gfortran present? If so, where does the symlink point?
  • are you missing /opt/local/lib/libltdl.7.dylib?

comment:24 in reply to:  19 Changed 10 years ago by drkp (Dan Ports)

Replying to dports@…:

Looks like this is being caused by a libtool problem -- maybe the one in #26384?

Typo -- that should be #23684

comment:25 in reply to:  23 ; Changed 10 years ago by nilstec_inc@…

Replying to dports@…:

Replying to rob.patro@…:

#build.args LIBTOOL=${prefix}/bin/glibtool

I tried this but it broke the +universal variant. (I guess that answers the question of why we had that line in the first place.)

I still can't reproduce this, but am wondering if something causes libtool to fail to build dylibs if gfortran is installed when libtool is built. I'd be interested in hearing from someone who's experiencing this problem:

  • do you have /opt/local/bin/gfortran present? If so, where does the symlink point?
  • are you missing /opt/local/lib/libltdl.7.dylib?
  • First question:
    ls /opt/local/bin/gfortran
    ls: /opt/local/bin/gfortran: No such file or directory
    

But i do have gfortran:

gfortran
gfortran: no input files
which gfortran
/usr/bin/gfortran
  • Second question:
    ls /opt/local/lib/libltdl.7.dylib
    ls: /opt/local/lib/libltdl.7.dylib: No such file or directory
    

I hope this is satisfying. Please ask about any other information you need!

comment:26 in reply to:  25 Changed 10 years ago by drkp (Dan Ports)

Replying to nilstec_inc@…:

But i do have gfortran:

gfortran
gfortran: no input files
which gfortran
/usr/bin/gfortran

This gfortran isn't from ports, and AFAIK there isn't one in the dev tools -- where did you get it?

  • Second question:
    ls /opt/local/lib/libltdl.7.dylib
    ls: /opt/local/lib/libltdl.7.dylib: No such file or directory
    

Thanks -- that's a pretty good indication that this is related to #23684.

comment:27 Changed 10 years ago by nilstec_inc@…

I did some research on where i got that gfortran from. It seems i used a file named gfortran-intel-bin.tar.gz. Searching the web, it could have been http://hpc.sourceforge.net/. As this was about half a year ago i have to admit that i do not perfectly remember. I'm sorry.

I think these were PREmacports times for me, and i didn't bother to exchange the file when getting Macports. Could this be a solution?

comment:28 in reply to:  27 Changed 10 years ago by drkp (Dan Ports)

Replying to nilstec_inc@…:

I think these were PREmacports times for me, and i didn't bother to exchange the file when getting Macports. Could this be a solution?

It's certainly worth a try to uninstall that gfortran and install a new one from MacPorts (via one of the gcc ports), then rebuild libtool and t1lib. Even if it doesn't fix the problem it should provide some useful troubleshooting information.

comment:29 Changed 10 years ago by nilstec_inc@…

I didn't try what you mentioned above, as i am too dependend on my gfortran working like it does now (don't wake a sleeping tiger!). But i did try installing texlive-bin and it works now! I still don't have /opt/local/lib/libt1.dylib but it seems it's not neccesary anymore :) Thanks all!

comment:30 Changed 9 years ago by nilstec_inc@…

I recently tried doing a port upgrade outdated, and the problem pops up again, but now for a different port: ImageMagick. This could be related to #23684 and #29823. In the second one, it is stated, that the dependency of ImageMagick on libtool was only recently added. I'll supply the log of the failed ImageMagick installation.

Changed 9 years ago by nilstec_inc@…

Attachment: main.log added

output of sudo port -u upgrade outdated

comment:31 Changed 9 years ago by nilstec_inc@…

Perhaps I should open a new ticket "libtool did not build /opt/local/lib/libltdl.dylib"? Thanks for any advice!

comment:32 in reply to:  25 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

Does there remain anything in this ticket that needs to be addressed or has everybody been able to resolve their respective issues?

Replying to ted@…:

On my machine, ranlib is getting called. This is a symlink from /usr/local/libtool on my machine. Perhaps an incompatibility between the two?

It is not supported to have anything in /usr/local while using MacPorts. Files installed there will likely interfere with many MacPorts ports.

Replying to nilstec_inc@…:

which gfortran
/usr/bin/gfortran

It is not supported to have the file /usr/bin/gfortran while using MacPorts. This file will interfere with some MacPorts ports.

Replying to nilstec_inc@…:

Perhaps I should open a new ticket "libtool did not build /opt/local/lib/libltdl.dylib"?

libtool needs to provide /opt/local/lib/libltdl.dylib; if it does not, that is a problem with the libtool port. This issue is being handled in #30018.

comment:33 Changed 9 years ago by nilstec_inc@…

Great, everything's alright now! I deleted /usr/bin/gfortran and now everything works fine. Thanks a lot!

comment:34 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: invalid
Status: assignedclosed

comment:35 Changed 9 years ago by drkp (Dan Ports)

If there's an issue, it's with libtool not building libltdl.dylib, but it seems that's really a problem with having a non-MacPorts gfortran installed.

I am curious as to why gfortran would cause libtool to fail to build in that way, though!

comment:36 Changed 9 years ago by roy@…

Found the same issue when trying to install TexLive on Lion using Xcode 4.2 tools. Same libtool error. I discovered that I had two versions of libtool installed.

$ port search libtool
libtool @2.4 (devel, sysutils)
    GNU Libtool - The GNU Portable Library Tool

libtool-devel @2.3a (devel)
    The GNU Portable Library Tool

I removed the older development version, reinstalled the current version, and t1lib port then compiled happily.

comment:37 Changed 9 years ago by ryandesign (Ryan Schmidt)

Duplicate of #23684. FYI I've marked libtool-devel as replaced_by libtool in r86788.

Note: See TracTickets for help on using tickets.