Opened 10 years ago

Closed 10 years ago

#26908 closed defect (duplicate)

Unable to install texlive-bin due to broken tilib

Reported by: ted@… Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: t1lib

Description (last modified by mf2k (Frank Schima))

When trying to install texlive-bin ports blows blow up with:

Error: The file /opt/local/lib/libt1.dylib does not exist, though it was
Error: expected to have been provided by one of texlive-bin's dependencies. Try
Error: rebuilding the port that should have provided that file by running
Error: 
Error:     sudo port -n upgrade --force <portname>
Error: 
Error: Target org.macports.configure returned: missing required file

So far, I've tried completely uninstalling and reinstalling ports in accordance with the uninstall page -- including the remove all traces command. Making sure that libtool is installed, making sure that I have the latest xcode.

I've attached install log files for both t1lib and tex-live

Attachments (2)

tex-live-install-log.log (87.3 KB) - added by ted@… 10 years ago.
t1lib-install.log (43.2 KB) - added by ted@… 10 years ago.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by ted@…

Attachment: tex-live-install-log.log added

Changed 10 years ago by ted@…

Attachment: t1lib-install.log added

comment:1 Changed 10 years ago by mf2k (Frank Schima)

Description: modified (diff)
Owner: changed from macports-tickets@… to dports@…
Port: texlive-bin added

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Port: t1lib added; texlive-bin removed

comment:3 Changed 10 years ago by drkp (Dan Ports)

Looks like a duplicate of #25417 -- but I never did figure out what was going on there. Perhaps these logs will help...

comment:4 Changed 10 years ago by drkp (Dan Ports)

Resolution: duplicate
Status: newclosed

Please follow over at #25417.

Note: See TracTickets for help on using tickets.