Opened 9 years ago

Closed 8 years ago

#25780 closed defect (fixed)

uif2iso fails to build

Reported by: bhadder@… Owned by: billitch@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: julio.lopez@…
Port: uif2iso

Description (last modified by mf2k (Frank Schima))

Error: Target org.macports.build returned: shell command failed
Log for uif2iso is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_uif2iso/main.log

Attachments (1)

main.log (3.0 KB) - added by bhadder@… 9 years ago.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by bhadder@…

Attachment: main.log added

comment:1 Changed 9 years ago by mf2k (Frank Schima)

Description: modified (diff)
Keywords: uif2iso removed
Owner: changed from macports-tickets@… to billitch@…

comment:2 Changed 9 years ago by julio.lopez@…

Cc: julio.lopez@… added

Cc Me!

comment:3 Changed 9 years ago by julio.lopez@…

If the compilation process includes /opt/local/include/zlib.h, then it fails to compile.

This fails: CFLAGS="-L/opt/local/lib" make CC=gcc CPATH="/opt/local/include" all

If it includes the system zlib.h in /usr/include/zlib.h then it succeeds.

This works: make CC=gcc all

The problem is that a type is defined in Types.h, which is included in the sources for the package, and the zlib port defines it as well in /usr/include/zconf.h which is included from zlib.h

comment:4 in reply to:  3 Changed 9 years ago by perfunctorily@…

If it includes the system zlib.h in /usr/include/zlib.h then it succeeds.

This works: make CC=gcc all

I changed the Portfile build.args to be 'CC=gcc all' and still getting the same byte redefinition from /opt/local/include/zconf.h. Not sure what else to try.

comment:5 Changed 8 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.