Opened 10 years ago

Closed 10 years ago

#25923 closed defect (duplicate)

rabbitmq-server (1.8.1) infinite loop

Reported by: mwalz@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: rabbitmq-server

Description (last modified by mf2k (Frank Schima))

The Rabbit MQ port is throwing an error during installation. Tried upgrading first and failed. Uninstalled, cleaned then tried to install and received the same error. The debug dump is quite long, this is the bottom portion.

DEBUG: Searching for dependency: pkgconfig
DEBUG: Found Dependency: receipt exists for pkgconfig
DEBUG: Searching for dependency: tiff
DEBUG: Found Dependency: receipt exists for tiff
DEBUG: Searching for dependency: jasper
DEBUG: Found Dependency: receipt exists for jasper
DEBUG: Searching for dependency: atk
DEBUG: Found Dependency: receipt exists for atk
DEBUG: Searching for dependency: pango
DEBUG: Found Dependency: receipt exists for pango
DEBUG: Searching for dependency: gettext
DEBUG: Found Dependency: receipt exists for gettext
DEBUG: Searching for dependency: xorg-libXi
DEBUG: Didn't find receipt, going to depspec regex for: xorg-libXi
DEBUG: Searching for dependency: xorg-libXrandr
DEBUG: Found Dependency: receipt exists for xorg-libXrandr
DEBUG: Searching for dependency: xorg-libXcursor
DEBUG: Didn't find receipt, going to depspec regex for: xorg-libXcursor
DEBUG: Searching for dependency: xorg-libXinerama
DEBUG: Didn't find receipt, going to depspec regex for: xorg-libXinerama
DEBUG: Searching for dependency: xorg-libXdamage
DEBUG: Didn't find receipt, going to depspec regex for: xorg-libXdamage
DEBUG: Searching for dependency: xorg-libXcomposite
DEBUG: Didn't find receipt, going to depspec regex for: xorg-libXcomposite
DEBUG: Searching for dependency: xorg-libXfixes
DEBUG: Didn't find receipt, going to depspec regex for: xorg-libXfixes
DEBUG: Searching for dependency: shared-mime-info
DEBUG: Didn't find receipt, going to depspec regex for: shared-mime-info
DEBUG: Searching for dependency: pkgconfig
DEBUG: Found Dependency: receipt exists for pkgconfig
DEBUG: Searching for dependency: xmlto
DEBUG: Didn't find receipt, going to depspec regex for: xmlto
DEBUG: Searching for dependency: asciidoc
DEBUG: Didn't find receipt, going to depspec regex for: asciidoc
DEBUG: Searching for dependency: xorg-libXext
DEBUG: Found Dependency: receipt exists for xorg-libXext
DEBUG: Searching for dependency: xorg-inputproto
DEBUG: Found Dependency: receipt exists for xorg-inputproto
DEBUG: Searching for dependency: coreutils
DEBUG: Found Dependency: receipt exists for coreutils
DEBUG: Searching for dependency: findutils
DEBUG: Found Dependency: receipt exists for findutils
DEBUG: Searching for dependency: getopt
DEBUG: Found Dependency: receipt exists for getopt
DEBUG: Searching for dependency: libpaper
DEBUG: Found Dependency: receipt exists for libpaper
DEBUG: Searching for dependency: texlive
DEBUG: Didn't find receipt, going to depspec regex for: texlive
DEBUG: Searching for dependency: texlive-htmlxml
DEBUG: Didn't find receipt, going to depspec regex for: texlive-htmlxml
DEBUG: Searching for dependency: libxml2
DEBUG: Found Dependency: receipt exists for libxml2
DEBUG: Searching for dependency: libxslt
DEBUG: Found Dependency: receipt exists for libxslt
DEBUG: Searching for dependency: docbook-xml
DEBUG: Found Dependency: receipt exists for docbook-xml
DEBUG: Searching for dependency: docbook-xsl
DEBUG: Found Dependency: receipt exists for docbook-xsl
DEBUG: Searching for dependency: fop
DEBUG: Didn't find receipt, going to depspec regex for: fop
DEBUG: Searching for dependency: dblatex
DEBUG: Didn't find receipt, going to depspec regex for: dblatex
DEBUG: Searching for dependency: texlive-basic
DEBUG: Didn't find receipt, going to depspec regex for: texlive-basic
DEBUG: too many nested evaluations (infinite loop?)
    while executing
"lshift args"
    (procedure "try" line 7)
    invoked from within
"try {
                    seek $fd $offset
                    gets $fd line
                    set name [lindex $line 0]
                    set len..."
    (procedure "mportlookup" line 23)
    invoked from within
"mportlookup $dep_portname"
Error: Internal error: port lookup failed: too many nested evaluations (infinite loop?)
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Change History (1)

comment:1 Changed 10 years ago by mf2k (Frank Schima)

Description: modified (diff)
Keywords: rabbitmq-server rabbitmq infinite loop removed
Resolution: duplicate
Status: newclosed

Duplicate of #25912

Note: See TracTickets for help on using tickets.