Opened 10 years ago

Closed 10 years ago

#25924 closed defect (invalid)

Problem getting macports to work !

Reported by: maria18t@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: fetchmail

Description (last modified by ryandesign (Ryan Schmidt))

MacPorts running without privileges. You may be unable to complete certain actions (e.g. install).
Error: Requested variants "+universal" do not match original selection "+ssl+universal".
Please use the same variants again, perform 'port clean fetchmail' or specify the force option (-f).
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Change History (4)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Description: modified (diff)
Port: fetchmail added

So... you were trying to install fetchmail? Did you try to clean fetchmail, as the error message said?

Unless you specifically installed MacPorts to run as a different user, MacPorts runs as root, which means you must prefix your "port" commands with "sudo", as in "sudo port install fetchmail" or "sudo port clean fetchmail". (The notice "MacPorts running without privileges" means you were not doing this.)

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Resolution: invalid
Status: newclosed

Not a bug; try the mailing lists or IRC if you need help using MacPorts. http://www.macports.org/contact.php

comment:3 in reply to:  2 Changed 10 years ago by maria18t@…

Resolution: invalid
Status: closedreopened

Replying to jmr@…:

Not a bug; try the mailing lists or IRC if you need help using MacPorts. http://www.macports.org/contact.php

ok now i tried to clean the wine-devel using the sudo code but when i retry copy pasting the code to install wine-devel >> sudo port install wine-devel nothing happens excecpt i get a msg that says :

Computing dependencies for wine-devel

then i am prompted to enter a command once again..also it takes a while..are there any other suggestions.??

comment:4 Changed 10 years ago by jmroot (Joshua Root)

Resolution: invalid
Status: reopenedclosed

Please don't reopen this ticket. The bug tracker is not the place for this kind of discussion.

Note: See TracTickets for help on using tickets.