Opened 11 years ago

Closed 11 years ago

#26824 closed defect (worksforme)

w3m @0.5.2 Build failure

Reported by: macports@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: w3m

Description

:info:build main.c: In function 'main':
:info:build main.c:846: error: void value not ignored as it ought to be
:info:build make: *** [main.o] Error 1
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_w3m/work/w3m-0.5.2" && /usr/bin/make all " retur
ned error 2
:error:build Target org.macports.build returned: shell command failed
:debug:build Backtrace: shell command failed
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"

Attachments (2)

main.log (12.3 KB) - added by macports@… 11 years ago.
Build log
clean_main.log (25.6 KB) - added by macports@… 11 years ago.

Download all attachments as: .zip

Change History (13)

Changed 11 years ago by macports@…

Attachment: main.log added

Build log

comment:1 Changed 11 years ago by macports@…

Cc: macports@… added

Cc Me!

comment:2 Changed 11 years ago by jmroot (Joshua Root)

Cc: macports@… removed
Keywords: w3m removed

You don't need to be in cc when you are the reporter.

I can't reproduce this on an x86_64 machine (even with build_arch=i386). What version of Xcode are you using?

comment:3 Changed 11 years ago by ryandesign (Ryan Schmidt)

Do you have a Str.h or str.h in /opt/local/include or /usr/include or /usr/local/include, and if so, where did it come from?

comment:4 in reply to:  2 Changed 11 years ago by macports@…

Replying to jmr@…:

You don't need to be in cc when you are the reporter.

I can't reproduce this on an x86_64 machine (even with build_arch=i386). What version of Xcode are you using?

$ xcodebuild -version
Xcode 3.2.4
Component versions: DevToolsCore-1705.0; DevToolsSupport-1591.0
BuildVersion: 10M2309

And my hardware:

Hardware Overview:

  Model Name:	MacBook
  Model Identifier:	MacBook1,1
  Processor Name:	Intel Core Duo
  Processor Speed:	2 GHz
  Number Of Processors:	1
  Total Number Of Cores:	2
  L2 Cache:	2 MB
  Memory:	2 GB
  Bus Speed:	667 MHz
  Boot ROM Version:	MB11.0061.B03
  SMC Version (system):	1.4f12

comment:5 in reply to:  3 ; Changed 11 years ago by macports@…

Replying to ryandesign@…:

Do you have a Str.h or str.h in /opt/local/include or /usr/include or /usr/local/include, and if so, where did it come from?

No, I don't have Str.h or str.h in any of those three locations.

comment:6 in reply to:  5 Changed 11 years ago by macports@…

Replying to macports@…:

Replying to ryandesign@…:

Do you have a Str.h or str.h in /opt/local/include or /usr/include or /usr/local/include, and if so, where did it come from?

No, I don't have Str.h or str.h in any of those three locations.

However, I did a search and found Str.h here:

/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_w3m/work/w3m-0.5.2/Str.h

comment:7 Changed 11 years ago by ryandesign (Ryan Schmidt)

Then I don't know what's wrong. Please clean w3m and try again, and attach the full log (one that does not contain lines "Skipping completed ...")

comment:8 Changed 11 years ago by macports@…

I've cleaned it, and attached a new log called clean_main.log

Changed 11 years ago by macports@…

Attachment: clean_main.log added

comment:9 Changed 11 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

Hm. Well your log looks basically the same as mine, up to the point where you get the error and mine continues building. (You are not using configure pipes and I am, and you are using nawk and I am using gawk, but I confirmed that neither of those changes causes a problem on my system.)

So let's look at the error message. It says:

main.c:846: error: void value not ignored as it ought to be

This means a void function is being called in a manner that expects it to have a non-void return type.

Line 846 of main.cpp reads:

    orig_GC_warn_proc = GC_set_warn_proc(wrap_GC_warn_proc);

GC_set_warn_proc is part of boehmgc, and as far as I can tell from reading boehmgc's source, GC_set_warn_proc is meant to have a non-void return type, so this error should not be happening.

Perhaps an earlier version of boehmgc defined GC_set_warn_proc as a void function, and you have that older version of boehmgc installed in a location where it would be found, like /usr/local? Do you have anything in /usr/local? If so, rename /usr/local (e.g. to /usr/local-off), clean w3m, and try again.

comment:10 Changed 11 years ago by macports@…

Hmm... OK. I renamed /usr/local/ and tried again, but no joy.

However following the clues from your post about GC, I uninstalled boehmgc then reinstalled boehmgc from scratch. Then I was able to compile w3m and install it with no problems after that. Very odd.

Thanks very much for your help.

comment:11 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: worksforme
Status: newclosed

Ok, glad you got it working. I guess something was wrong with your boehmgc installation.

Note: See TracTickets for help on using tickets.