Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#26959 closed defect (duplicate)

php5-curl is failing to install

Reported by: plowman@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: curl-ca-bundle

Description

Looks like there might be a problem with a dependency on the curl or curl-ca-bundle ports.

It complains that the file curl-7.21.2.tar.bz2 doesn't exist in /opt/local/var/macports/distfiles/curl, however the file curl-7.20.0.tar.bz2 does exist in that directory. Perhaps there is some version strangeness with the macport?

Here is what happens when I run the command:

$ sudo port install php5-curl
Password:
--->  Computing dependencies for php5-curl
--->  Dependencies to be installed: curl curl-ca-bundle
--->  Verifying checksum(s) for curl-ca-bundle
Error: Target org.macports.checksum returned: curl-7.21.2.tar.bz2 does not exist in /opt/local/var/macports/distfiles/curl
Log for curl-ca-bundle is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_curl-ca-bundle/main.log
Error: The following dependencies failed to build: curl curl-ca-bundle
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Change History (3)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Keywords: php5-curl cul curl-ca-bundle php removed
Port: curl-ca-bundle added; php5-curl removed
Resolution: duplicate
Status: newclosed

Duplicate of #26276, #25739, #25418, #25937. Please "sudo port clean --all curl-ca-bundle" to fix. This problem will be fixed in MacPorts 1.9.2.

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

Cc Me!

comment:3 in reply to:  1 Changed 10 years ago by plowman@…

Replying to ryandesign@…:

Duplicate of #26276, #25739, #25418, #25937. Please "sudo port clean --all curl-ca-bundle" to fix. This problem will be fixed in MacPorts 1.9.2.

Wonderful! Sorry for the duplicate ticket. I tried to search for similar tickets but nothing turned up :-/

Note: See TracTickets for help on using tickets.