Opened 10 years ago

Closed 9 years ago

#27025 closed defect (fixed)

Error building py26-pyclutter

Reported by: abdel.g.martinez.l@… Owned by: nodamage@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: lsinger@…
Port: py26-pyclutter

Description (last modified by dbevans (David B. Evans))

--->  Computing dependencies for py26-pyclutter.
--->  Building py26-pyclutter
Making all in build
Making all in autotools
Making all in codegen
Making all in clutter
  CC    cogl.o
  CC    clutterglx.o
cogl.c: In function '_wrap_cogl_debug_flags_get_type':
cogl.c:1699: warning: implicit declaration of function 'cogl_debug_flags_get_type'
cogl.c: In function '_wrap_cogl_check_extension':
cogl.c:1879: warning: 'cogl_check_extension' is deprecated (declared at /opt/local/include/clutter-1.0/cogl/cogl.h:145)
cogl.c: In function '_wrap_cogl_viewport':
cogl.c:1973: warning: 'cogl_viewport' is deprecated (declared at /opt/local/include/clutter-1.0/cogl/cogl.h:334)
cogl.c: In function '_wrap_cogl_clip_push_window_rect':
cogl.c:2348: warning: 'cogl_clip_push_window_rect' is deprecated (declared at /opt/local/include/clutter-1.0/cogl/cogl.h:738)
cogl.c: In function '_wrap_cogl_clip_push':
cogl.c:2363: warning: 'cogl_clip_push' is deprecated (declared at /opt/local/include/clutter-1.0/cogl/cogl.h:794)
cogl.c: In function '_wrap_cogl_clip_ensure':
cogl.c:2403: warning: 'cogl_clip_ensure' is deprecated (declared at /opt/local/include/clutter-1.0/cogl/cogl.h:872)
cogl.c: In function '_wrap_cogl_clip_stack_save':
cogl.c:2413: warning: 'cogl_clip_stack_save' is deprecated (declared at /opt/local/include/clutter-1.0/cogl/cogl.h:892)
cogl.c: In function '_wrap_cogl_clip_stack_restore':
cogl.c:2423: warning: 'cogl_clip_stack_restore' is deprecated (declared at /opt/local/include/clutter-1.0/cogl/cogl.h:909)
./cogl.override: In function '_wrap_cogl_set_draw_buffer':
./cogl.override:627: warning: 'cogl_set_draw_buffer' is deprecated (declared at /opt/local/include/clutter-1.0/cogl/cogl.h:1037)
cogl.c: In function '_wrap_cogl_push_draw_buffer':
cogl.c:2458: warning: 'cogl_push_draw_buffer' is deprecated (declared at /opt/local/include/clutter-1.0/cogl/cogl.h:1047)
cogl.c: In function '_wrap_cogl_pop_draw_buffer':
cogl.c:2468: warning: 'cogl_pop_draw_buffer' is deprecated (declared at /opt/local/include/clutter-1.0/cogl/cogl.h:1057)
cogl.c: In function 'pycogl_add_constants':
cogl.c:3802: error: 'COGL_TYPE_DEBUG_FLAGS' undeclared (first use in this function)
cogl.c:3802: error: (Each undeclared identifier is reported only once
cogl.c:3802: error: for each function it appears in.)
make[2]: *** [_clutter_la-cogl.lo] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py26-pyclutter/work/pyclutter-1.0.2" && /usr/bin/make -j2 all " returned error 2
Error: Target org.macports.build returned: shell command failed
Warning: the following items did not execute (for py26-pyclutter): org.macports.destroot org.macports.build
Log for py26-pyclutter is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py26-pyclutter/main.log
Error: Unable to upgrade port: 1

Attachments (1)

Portfile-py26-pyclutter.diff (1.3 KB) - added by lsinger@… 10 years ago.
Proposed patch

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by dbevans (David B. Evans)

Description: modified (diff)
Keywords: clutter removed
Owner: changed from macports-tickets@… to nodamage@…

Please use WikiFormatting and copy the port maintainer when submitting your ticket

comment:2 Changed 10 years ago by dbevans (David B. Evans)

The problem is that the current released version of pyclutter does not support the new API in clutter 1.4. There has been some work upstream on this and a new 1.3 snapshot has been promised that supports both 1.2 and 1.4 but nothing has been released as yet.

See latest progress report

Changed 10 years ago by lsinger@…

Proposed patch

comment:3 in reply to:  2 Changed 10 years ago by lsinger@…

Replying to devans@…:

The problem is that the current released version of pyclutter does not support the new API in clutter 1.4. There has been some work upstream on this and a new 1.3 snapshot has been promised that supports both 1.2 and 1.4 but nothing has been released as yet.

See latest progress report

Apparently, this has been addressed in pyclutter 1.3.2. The attached patch for the Portfile updates the port version, updates the checksums, and also adds the --enable-doc configure argument (otherwise, destroot stage fails because the HTML documentation isn't installed into the destroot).

comment:4 Changed 10 years ago by lsinger@…

Cc: lsinger@… added

Cc Me!

comment:5 Changed 9 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.