Opened 10 years ago

Closed 10 years ago

#27036 closed defect (worksforme)

dbus configuration script looking for dbus-1.2.24 directory

Reported by: prestonkmoore@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: dbus

Description (last modified by jmroot (Joshua Root))

In trying to install dbus I get the following error

:debug:configure Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_dbus/work/dbus-1.2.24"     && autoreconf --install'                                                                                                                                           
:info:configure sh: line 0: cd: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_dbus/work/dbus-1.2.24: No such     file or directory                                                                                                                                                   
:info:configure shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_dbus/work/dbus-1.2.24" && a    utoreconf --install " returned error 1

I believe this is because the dbus working directory is called dbus-1.2.16. I cannot provide any reason for this. I was able to get dbus to install by renaming this directory to dbus-1.2.24 and running port install dbus

Change History (2)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Description: modified (diff)
Keywords: dbus removed
Milestone: MacPorts 1.9.2
Owner: changed from macports-tickets@… to mcalhoun@…

As per the ticket guidelines linked from the New Ticket page, please don't set the Milestone field, but do remember to cc the maintainer and use WikiFormatting (or better, just attach the log file).

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Resolution: worksforme
Status: newclosed

Can't reproduce.

Note: See TracTickets for help on using tickets.