Opened 10 years ago

Closed 10 years ago

#27037 closed defect (duplicate)

db46 fails to build 10.6.4 fresh XCode MacPort install

Reported by: traf@… Owned by: blair (Blair Zajac)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: db46

Description (last modified by jmroot (Joshua Root))

:info:build  /usr/bin/g++-4.2 -c -I. -I../dist/.. -I/opt/local/include -pipe -O2 -arch x86_64 ../dist/../cxx/cxx_seq.cpp -o cxx_seq.o >/dev/null 2>&1
:info:build  /usr/bin/gcc-4.2 -c -pipe -O2 -arch x86_64 -I../dist/.. -I/opt/local/include ../dist/../db_dump185/db_dump185.c -o db_dump185.o >/dev/null 2>&1
:info:build  /usr/bin/g++-4.2 -c -I. -I../dist/.. -I/opt/local/include -pipe -O2 -arch x86_64 ../dist/../cxx/cxx_txn.cpp -o cxx_txn.o >/dev/null 2>&1
:info:build Note: Some input files use unchecked or unsafe operations.
:info:build Note: Recompile with -Xlint:unchecked for details.
:info:build cd ./classes && jar cf ../db.jar ./com/sleepycat
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_db46/work/db-4.6.21/build_unix" && /usr/bin/make -j8 all " returned error 2
:error:build Target org.macports.build returned: shell command failed
:debug:build Backtrace: shell command failed
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for db46): org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Log for db46 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_db46/main.log
caprica:~# 

Attachments (1)

main.log.gz (16.9 KB) - added by grail@… 10 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Description: modified (diff)
Owner: changed from macports-tickets@… to blair@…
Port: db46 added

Please remember to preview and use WikiFormatting (or better, use an attachment), fill in the Port field, and cc the maintainer.

Attach the entire log file; the excerpt you've posted doesn't appear to contain the actual error.

Changed 10 years ago by grail@…

Attachment: main.log.gz added

comment:2 Changed 10 years ago by grail@…

Attached is the complete main.log file generated by this problem.

comment:3 Changed 10 years ago by grail@…

The problems appear to start with ":info:build ../dist/../libdb_java/db_java_wrap.c:123:17: error: jni.h: No such file or directory". I wonder if this has anything to do with the recent deprecation of Java?

comment:4 Changed 10 years ago by danielluke (Daniel J. Luke)

Resolution: duplicate
Status: newclosed

Duplicate of #26939

Blair - You could copy the check for jni.h that the cmake or subversion-javahlbindings ports do to redirect people to get the Java for Mac OS X Developer Package so they aren't opening a continuous series of duplicate tickets.

Note: See TracTickets for help on using tickets.