Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#27064 closed defect (duplicate)

help2man fails to configure while installing gimp (still)

Reported by: clay@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: help2man

Description (last modified by dbevans (David B. Evans))

I am not sure what is happening here, and if it is an easy fix, I will happily accept (and proudly display) a Stupid Sign...

Running as Sudo users (sudo su) or sudo'ing as my user...the same failure occurs. Here is what I get, and the log entry is at the bottom of this post:

Here is the error I see:

===========================
Error: Target org.macports.configure returned: configure failure: shell command failed
Log for help2man is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/main.log



sh-3.2# port install gimp
--->  Computing dependencies for gimp
--->  Dependencies to be installed: gimp-app gimp2 aalib autoconf help2man automake libtool curl libidn pkgconfig gegl babl librsvg cairo fontconfig freetype libpixman libpng xrender xorg-libX11 xorg-bigreqsproto xorg-inputproto xorg-kbproto xorg-libXau xorg-xproto xorg-libXdmcp xorg-libxcb python26 gdbm xorg-libpthread-stubs xorg-xcb-proto libxml2 xorg-util-macros xorg-xcmiscproto xorg-xextproto xorg-xf86bigfontproto xorg-xtrans xorg-renderproto glib2 dbus gtk2 atk gtk-doc docbook-xml docbook-xml-4.1.2 xmlcatmgr docbook-xml-4.2 docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 docbook-xml-5.0 docbook-xsl gnome-doc-utils intltool gnome-common p5-getopt-long p5-pathtools p5-scalar-list-utils p5-xml-parser iso-codes libxslt py26-libxml2 rarian getopt gdk-pixbuf2 jasper jpeg tiff pango Xft2 shared-mime-info xorg-libXcomposite xorg-compositeproto xorg-libXext xorg-libXfixes xorg-fixesproto xorg-libXcursor xorg-libXdamage xorg-damageproto xorg-libXi xorg-libXinerama xorg-xineramaproto xorg-libXrandr xorg-randrproto libart_lgpl libcroco libgsf gconf dbus-glib orbit2 libidl policykit eggdbus gnome-vfs desktop-file-utils popt gnome-mime-data libbonobo w3m boehmgc ffmpeg XviD dirac cppunit faac faad2 gmake lame libogg libsdl libtheora libvorbis libvpx yasm schroedinger orc speex texi2html x264 graphviz gd2 xpm xorg-libXt xorg-libsm xorg-libice ghostscript libpaper urw-fonts xorg-libXaw groff xorg-libXmu libopenraw boost boost-jam libspiro lua openexr ilmbase lcms libexif libgnomeui libbonoboui libgnome esound audiofile libgnomecanvas libglade2 libgnome-keyring gnome-keyring libgcrypt libgpg-error libtasn1 libmng libwmf poppler openjpeg poppler-data py26-gtk py26-cairo py26-numpy atlas gcc44 gmp mpfr gzip texinfo lzmautils fftw-3 py26-nose py26-distribute py26-gobject libffi gimp-jp2 gimp-lqr-plugin liblqr gtk-nodoka-engine coreutils gutenprint icns-gimp ufraw cfitsio dcraw exiv2 gtkimageview xsane sane-backends libusb-compat libusb
--->  Configuring help2man
Error: Target org.macports.configure returned: configure failure: shell command failed
Log for help2man is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/main.log
Error: The following dependencies failed to build: gimp-app gimp2 aalib autoconf help2man automake libtool curl libidn pkgconfig gegl babl librsvg cairo fontconfig freetype libpixman libpng xrender xorg-libX11 xorg-bigreqsproto xorg-inputproto xorg-kbproto xorg-libXau xorg-xproto xorg-libXdmcp xorg-libxcb python26 gdbm xorg-libpthread-stubs xorg-xcb-proto libxml2 xorg-util-macros xorg-xcmiscproto xorg-xextproto xorg-xf86bigfontproto xorg-xtrans xorg-renderproto glib2 dbus gtk2 atk gtk-doc docbook-xml docbook-xml-4.1.2 xmlcatmgr docbook-xml-4.2 docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 docbook-xml-5.0 docbook-xsl gnome-doc-utils intltool gnome-common p5-getopt-long p5-pathtools p5-scalar-list-utils p5-xml-parser iso-codes libxslt py26-libxml2 rarian getopt gdk-pixbuf2 jasper jpeg tiff pango Xft2 shared-mime-info xorg-libXcomposite xorg-compositeproto xorg-libXext xorg-libXfixes xorg-fixesproto xorg-libXcursor xorg-libXdamage xorg-damageproto xorg-libXi xorg-libXinerama xorg-xineramaproto xorg-libXrandr xorg-randrproto libart_lgpl libcroco libgsf gconf dbus-glib orbit2 libidl policykit eggdbus gnome-vfs desktop-file-utils popt gnome-mime-data libbonobo w3m boehmgc ffmpeg XviD dirac cppunit faac faad2 gmake lame libogg libsdl libtheora libvorbis libvpx yasm schroedinger orc speex texi2html x264 graphviz gd2 xpm xorg-libXt xorg-libsm xorg-libice ghostscript libpaper urw-fonts xorg-libXaw groff xorg-libXmu libopenraw boost boost-jam libspiro lua openexr ilmbase lcms libexif libgnomeui libbonoboui libgnome esound audiofile libgnomecanvas libglade2 libgnome-keyring gnome-keyring libgcrypt libgpg-error libtasn1 libmng libwmf poppler openjpeg poppler-data py26-gtk py26-cairo py26-numpy atlas gcc44 gmp mpfr gzip texinfo lzmautils fftw-3 py26-nose py26-distribute py26-gobject libffi gimp-jp2 gimp-lqr-plugin liblqr gtk-nodoka-engine coreutils gutenprint icns-gimp ufraw cfitsio dcraw exiv2 gtkimageview xsane sane-backends libusb-compat libusb
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>
sh-3.2# 


LOG INFO:
========================
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/main.log
-------------------------------

sh-3.2# cat /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/main.log
version:1
:debug:main Executing org.macports.main (help2man)
:debug:main Skipping completed org.macports.fetch (help2man)
:debug:main Skipping completed org.macports.checksum (help2man)
:debug:main Skipping completed org.macports.extract (help2man)
:debug:main Skipping completed org.macports.patch (help2man)
:msg:main --->  Configuring help2man
:debug:main Using compiler 'Mac OS X gcc 4.2'
:debug:configure configure phase started at Thu Oct 28 22:09:47 PDT 2010
:debug:configure Executing org.macports.configure (help2man)
:debug:configure Environment: CPATH='/opt/local/include' CFLAGS='-pipe -O2 -arch x86_64' CPPFLAGS='-I/opt/local/include' CXXFLAGS='-pipe -O2 -arch x86_64' LIBRARY_PATH='/opt/local/lib' MACOSX_DEPLOYMENT_TARGET='10.6' PERL='/opt/local/bin/perl' CXX='/usr/bin/g++-4.2' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/.CC_PRINT_OPTIONS' F90FLAGS='-pipe -O2 -m64' LDFLAGS='-L/opt/local/lib -arch x86_64' OBJC='/usr/bin/gcc-4.2' FCFLAGS='-pipe -O2 -m64' INSTALL='/usr/bin/install -c' OBJCFLAGS='-pipe -O2 -arch x86_64' FFLAGS='-pipe -O2 -m64' CC_PRINT_OPTIONS='YES' CC='/usr/bin/gcc-4.2'
:debug:configure Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/help2man-1.38.2" && ./configure --prefix=/opt/local --enable-nls'
:info:configure checking for perl... /opt/local/bin/perl
:info:configure checking for module Locale::gettext... no
:info:configure checking for msgfmt... /opt/local/bin/msgfmt
:info:configure checking for gcc... /usr/bin/gcc-4.2
:info:configure checking whether the C compiler works... yes
:info:configure checking for C compiler default output file name... a.out
:info:configure checking for suffix of executables... 
:info:configure checking whether we are cross compiling... no
:info:configure checking for suffix of object files... o
:info:configure checking whether we are using the GNU C compiler... yes
:info:configure checking whether /usr/bin/gcc-4.2 accepts -g... yes
:info:configure checking for /usr/bin/gcc-4.2 option to accept ISO C89... none needed
:info:configure checking for library containing dlsym... none required
:info:configure checking for library containing bindtextdomain... -lintl
:info:configure configure: error: perl module Locale::gettext required
:info:configure shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/help2man-1.38.2" && ./configure --prefix=/opt/local --enable-nls " returned error 1
:error:configure Target org.macports.configure returned: configure failure: shell command failed
:debug:configure Backtrace: configure failure: shell command failed
    while executing
"$procedure $targetname"
:info:configure Warning: the following items did not execute (for help2man): org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
:notice:configure Log for help2man is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/main.log




Change History (2)

comment:1 Changed 10 years ago by dbevans (David B. Evans)

Description: modified (diff)
Keywords: snow leopard shell command failed removed
Port: help2man added; gimp removed
Resolution: duplicate
Status: newclosed

Please use WikiFormatting when including text from terminals and/or log files so they are readable.

The port that is failing is help2man. Duplicate of #26540.

comment:2 Changed 10 years ago by dbevans (David B. Evans)

Summary: Snow Leopard problems...unable to install...almost anything (specifically GIMP, PHP): Error: Target org.macports.configure returned: configure failure: shell command failedhelp2man fails to configure while installing gimp (still)
Note: See TracTickets for help on using tickets.