Opened 10 years ago

Closed 10 years ago

#26540 closed defect (duplicate)

help2man fails to configure while installing gimp

Reported by: kh@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: dbevans (David B. Evans), cromick@…, clay@…
Port: help2man

Description

iMac 10.6.4 attempting to install gimp. help2man does not configure - looking for a directory help2man_1.38.2 - but the actual directory appears to be help2man-1.38.2. Changing the directory name did not cure the problem. Result is gimp failed to install.

Attachments (5)

help2man-log (829 bytes) - added by kh@… 10 years ago.
bug log
main.log (15.3 KB) - added by kh@… 10 years ago.
main log file showing bug
config.log (8.9 KB) - added by kh@… 10 years ago.
help2man config log
gettext.bundle (14.6 KB) - added by kh@… 10 years ago.
BVinary bundle
main.2.log (13.3 KB) - added by cromick@… 10 years ago.
log file from help2man install

Download all attachments as: .zip

Change History (25)

comment:1 Changed 10 years ago by dbevans (David B. Evans)

Keywords: help2man removed
Port: help2man added; gimp removed
Summary: gimp instal failed with help2manhelp2man fails to configure while installing gimp

I am unable to reproduce your problem.

Please do this

sudo port clean --all help2man
sudo port install help2man

and attach a copy of the log file if this fails so that we have something to work with

comment:2 Changed 10 years ago by dbevans (David B. Evans)

Cc: devans@… added

Changed 10 years ago by kh@…

Attachment: help2man-log added

bug log

Changed 10 years ago by kh@…

Attachment: main.log added

main log file showing bug

comment:3 Changed 10 years ago by kh@…

Sorry! misread your instructions - the second file is the actual log file.

comment:4 Changed 10 years ago by dbevans (David B. Evans)

Ok, the relevant error is

:info:configure configure: error: perl module Locale::gettext required

Locale::gettext is provided by port p5-locale-gettext which is a dependency of help2man and the log claims that you have it installed

:debug:main p5-locale-gettext 1.05_2 exists in the ports tree
:debug:main p5-locale-gettext 1.05_2  is the latest installed
:debug:main p5-locale-gettext 1.05_2  is active

So this seems to be contradictory information. To see more detail about why configure thinks its not there, please attach the file config.log which is found in the directory given by this command

% echo `port dir help2man`/work/help2man*

Changed 10 years ago by kh@…

Attachment: config.log added

help2man config log

comment:5 Changed 10 years ago by kh@…

Line 57 appears to be the interesting line - 'but wrong architecture'!!

comment:6 Changed 10 years ago by dbevans (David B. Evans)

Indeed. What does

file /opt/local/lib/perl5/vendor_perl/5.8.9/darwin-2level/auto/Locale/gettext/gettext.bundle

say?

Changed 10 years ago by kh@…

Attachment: gettext.bundle added

BVinary bundle

comment:7 Changed 10 years ago by kh@…

It doesn't say very much at all! It is, of course, binary - but Duckbill produces an app from which 'runs' though doing nothing as far as I can see. Hope this helps.

I have gettext.bs (empty) and a gettext.bundle.mp_1284776886 of 20kb which proclaims itself to be a Unix executable - but they don't reveal anything terribly useful either.

comment:8 Changed 10 years ago by dbevans (David B. Evans)

Sorry I wasn't clear in my request. The program "file" returns information about the type of file and what architecture it is. So what I meant (but didn't communicate well) was: What does the following command return?

% file /opt/local/lib/perl5/vendor_perl/5.8.9/darwin-2level/auto/Locale/gettext/gettext.bundle

on my system it returns (my version is built universal)

/opt/local/lib/perl5/vendor_perl/5.8.9/darwin-2level/auto/Locale/gettext/gettext.bundle: Mach-O universal binary with 2 architectures
/opt/local/lib/perl5/vendor_perl/5.8.9/darwin-2level/auto/Locale/gettext/gettext.bundle (for architecture x86_64):	Mach-O 64-bit bundle x86_64
/opt/local/lib/perl5/vendor_perl/5.8.9/darwin-2level/auto/Locale/gettext/gettext.bundle (for architecture i386):	Mach-O bundle i386

comment:9 Changed 10 years ago by kh@…

There we have it! No such file or directory!! The only two things in the gettext directory are .packlist and .packlist.mp_1284776886. So how should the bundle have got there? I certainly haven't changed anything there.

There is a 5.8.9 directory inside perl5 - but that doesn't lead anywhere to a Locale directory.

comment:10 Changed 10 years ago by dbevans (David B. Evans)

OK looks like a problem with p5-locale-gettext so try this:

sudo port -f uninstall p5-locale-gettext
sudo port install p5-locale-gettext
sudo port install help2man

If all that works then proceed with installing gimp

comment:11 Changed 10 years ago by ryandesign (Ryan Schmidt)

Note that I fixed p5-locale-gettext to install with the correct architecture earlier today in r71687, so if you haven't yet, "sudo port selfupdate" to get that change, then try again.

comment:12 Changed 10 years ago by kh@…

Not good news I'm afraid. I uninstalled help2man (in case) as well as p5-locale-gettext before doing a selfupdate. This reported the base version 1.9.1 installed.
I then installed p5-locale-gettext which reported @1.05_3.
Fiunally I attempted to install help2man - only to have the same bug reappear that you have been trying to solve. We do, however, have the expected result for the 'file' command - Mach-0 64-bit bundle x86_64
The following, however, may help -

sh-3.2# `port dir help2man`/work/help2man*
sh: /opt/local/var/macports/sources/rsync.macports.org/release/ports/textproc/help2man/work/help2man*: No such file or directory
sh-3.2# 

As you see, there is no configure log file.
Back, I'm sorry to say, in your court!

comment:13 Changed 10 years ago by ryandesign (Ryan Schmidt)

What is in the directory identified by the command "port work help2man"?

comment:14 Changed 10 years ago by kh@…

.CC_PRINT_OPTIONS .macports.help2man.state help2man-1.38.2

which appeared to be at the heart of the problem as originally given - note the hyphen although I believe that MacPorts is expectoing a low-line.

Being in New Zealand I am off to bed - so forgive any delay in further responses for another hour or 12.

Thanks for your patience and thoughts.

comment:15 in reply to:  14 Changed 10 years ago by ryandesign (Ryan Schmidt)

Replying to kh@…:

.CC_PRINT_OPTIONS
.macports.help2man.state
help2man-1.38.2

which appeared to be at the heart of the problem as originally given - note the hyphen although I believe that MacPorts is expectoing a low-line.

No, that's the directory name MacPorts is expecting. If you have a log that shows otherwise, please attach it.

Did you "sudo port selfupdate" as I suggested above? The error in the log you did attach, "perl module Locale::gettext required", is one I believe I have already fixed.

comment:16 Changed 10 years ago by kh@…

I bow to your superior knowledge. I had indeed done a selfupdate - but have again repeated the uninstalls, selfupdate, reinstalled p5-locale-gettext and tried help2man - which failed a shell command as before apparently the same one. So I went into the main logfile and found the complaint about a shell command "cd ... && ./configure ..." However, when I go into the .../work/help2man-1.38.2 directory indicated and try a manual configure the second line says -

checking for module Locale::gettext... no

tries a few other things OK and barfs with a final line

configure: error: perl module Locale::gettext required

and, it appears that it is installed as you said earlier.

I don't know where the Perl gettext module is supposed to be - but in /opt/local/lib/perl5/vendor_perl/5.8.9/darwin-2level/Locale there is a module gettext.pm - the file date is 1 Jun 2005 and the length 6834 bytes! It looks OK as a Perl module (mind you I'm more a Python man myself).

I manually ran the module test in the config file to see the detail of the failure. It reported -

sh-3.2# perl -mLocale::gettext -e 1
Can't load '/opt/local/lib/perl5/vendor_perl/5.8.9/darwin-2level/auto/Locale/gettext/gettext.bundle' for module Locale::gettext: dlopen(/opt/local/lib/perl5/vendor_perl/5.8.9/darwin-2level/auto/Locale/gettext/gettext.bundle, 1): no suitable image found.  Did find:
	/opt/local/lib/perl5/vendor_perl/5.8.9/darwin-2level/auto/Locale/gettext/gettext.bundle: mach-o, but wrong architecture at /opt/local/lib/perl5/5.8.9/darwin-2level/DynaLoader.pm line 230.
 at -e line 0
Compilation failed in require.
BEGIN failed--compilation aborted.

which might indicate something in the dynamic loader module.

Over to you again!

Changed 10 years ago by cromick@…

Attachment: main.2.log added

log file from help2man install

comment:17 Changed 10 years ago by cromick@…

I am having a similar problem with installing gnuplot

comment:18 Changed 10 years ago by cromick@…

Cc: cromick@… added

Cc Me!

comment:19 Changed 10 years ago by dbevans (David B. Evans)

Cc: clay@… added

See also duplicate #27064.

comment:20 Changed 10 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #21069.

Note: See TracTickets for help on using tickets.