Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#27085 closed defect (invalid)

automoc does not build after qt4-mac upgrade

Reported by: shane.wilkins@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: michaelld (Michael Dickens)
Port: automoc

Description (last modified by ryandesign (Ryan Schmidt))

I have just upgraded my qt4-mac to 4.7.0 and now it appears that automoc will not build (although I am not positive the two things are related.) Here is the portion of the debug info where something seems to go wrong:

-- Configuring incomplete, errors occurred!
shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_automoc/work/build" && cmake -DCMAKE_INSTALL_PREFIX=/opt/local -DCMAKE_OSX_ARCHITECTURES="x86_64;i386" -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_COLOR_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON -DCMAKE_INSTALL_NAME_DIR=/opt/local/lib -DCMAKE_SYSTEM_PREFIX_PATH="/opt/local;/usr" -DCMAKE_MODULE_PATH=/opt/local/share/cmake/modules -Wno-dev -DBUILD_doc=OFF -DBUILD_SHARED_LIBS=ON -DBUNDLE_INSTALL_DIR=/Applications/MacPorts/KDE4 -DKDE_DISTRIBUTION_TEXT="MacPorts/Mac OS X" -DQT_QT_INCLUDE_DIR=/opt/local/include  -DQT_LIBRARY_DIR=/opt/local/lib  -DQT_QMAKE_EXECUTABLE=/opt/local/bin/qmake  -DQT_ZLIB_LIBRARY=/opt/local/lib/libz.dylib  -DQT_PNG_LIBRARY=/opt/local/lib/libpng.dylib ../automoc4-0.9.88 " returned error 1
Error: Target org.macports.configure returned: configure failure: shell command failed
DEBUG: Backtrace: configure failure: shell command failed
    while executing
"$procedure $targetname"
Warning: the following items did not execute (for automoc): org.macports.destroot org.macports.configure org.macports.build
Log for automoc is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_automoc/main.log
DEBUG: couldn't open "/System/Library/Frameworks/Tcl.framework/Versions/8.5/Resources/tclIndex": no such file or directory
    while executing
"open [file join $dir tclIndex]"
Error: Unable to upgrade port: 1
To report a bug, see <http://guide.macports.org/#project.tickets>

Attachments (2)

automoc log.rtf (33.7 KB) - added by shane.wilkins@… 10 years ago.
main.log (7.1 KB) - added by shane.wilkins@… 10 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Please remember to use WikiFormatting.

automoc builds fine for me with qt4-mac 4.7.0. Please attach the complete main.log.

Changed 10 years ago by shane.wilkins@…

Attachment: automoc log.rtf added

comment:3 Changed 10 years ago by shane.wilkins@…

textfile of the complete error message, but I couldn't find main.log?

thanks

Changed 10 years ago by shane.wilkins@…

Attachment: main.log added

comment:4 Changed 10 years ago by shane.wilkins@…

Sorry, I am a stupid, I found the main.log and attached it.

best,

sw

comment:5 Changed 10 years ago by markus.doits@…

Cc: markus.doits@… added

Cc Me!

comment:6 Changed 10 years ago by jmroot (Joshua Root)

Cc: michaelld@… added

comment:7 Changed 10 years ago by michaelld (Michael Dickens)

@shane.wilkins: Does "/opt/local/bin/qmake" exist on your install? If you do "port installed qt4-mac" what is returned? The issue is, obviously, that CMake isn't finding Qt's install. I need to look up the CMake file that's doing the looking to see how else to debug.

comment:8 Changed 10 years ago by markus.doits@…

sudo port activate qt4-mac @4.7.0

was the solution for me. an upgrade before deactivated the old qt4-mac, but did not active the new one properly (i remember it gave an error but continued to upgrade other packages - that's why i didn't investigate it further)

comment:9 Changed 10 years ago by markus.doits@…

Cc: markus.doits@… removed

Cc Me!

comment:10 Changed 10 years ago by shane.wilkins@…

markus's solution worked for me too--I couldn't activate qt4-mac 4.7.0 directly: macports threw some weird error message, but it activated just fine when i did:

sudo port install qt4-mac@4.7.0

then automoc configured and built just fine.

thanks much.

comment:11 Changed 10 years ago by michaelld (Michael Dickens)

Resolution: invalid
Status: newclosed

You're welcome.

comment:12 Changed 9 years ago by ryandesign (Ryan Schmidt)

Has duplicate #29102.

Note: See TracTickets for help on using tickets.