Opened 10 years ago

Closed 9 years ago

#27205 closed defect (fixed)

kmymoney4 won't start

Reported by: strassh@… Owned by: mkae (Marko Käning)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: SBauer3@…, pixilla (Bradley Giesbrecht), nerdling (Jeremy Lavergne), michaelld (Michael Dickens)
Port: kmymoney4

Description

I finally succeed in installing kmymoney4 (my issue with kdelibs4 has been solved), but now it failed to launch.

Using the Application Menu (MacPorts/KDE4/KMyMoney) the icon show up in the dock and jump a while and nothing is lauched. Then I tried to launch in a terminal :

/opt/local/var/macports/software/kmymoney4/4.5_2/Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney

Same thing happened (jumping icon...) No output in the terminal

For info :

$ /opt/local/var/macports/software/kmymoney4/4.5_2/Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney -v
Qt: 4.7.0
KDE Development Platform: 4.5.3 (KDE 4.5.3)
KMyMoney: 4.5.0

Maybe I need to launch something before kmymoney ?

Thanks

Attachments (6)

Home.jpg (473.2 KB) - added by strassh@… 10 years ago.
Home screen with tip of the day
Ledger.jpg (413.3 KB) - added by strassh@… 10 years ago.
Ledger (with personal infos hidden)
Pie chart.jpg (296.8 KB) - added by strassh@… 10 years ago.
Pie chart
Report.jpg (468.7 KB) - added by strassh@… 10 years ago.
Text report, looks quite nice
Budget.jpg (303.3 KB) - added by strassh@… 10 years ago.
Budget, the only line chart that doesn't hang the app
sigsegv.txt.gz (16.6 KB) - added by mkae (Marko Käning) 10 years ago.
Crashlog for date edit error in legder

Download all attachments as: .zip

Change History (55)

comment:1 Changed 10 years ago by strassh@…

Cc: strassh@… added

Cc Me!

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: mk@… strassh@… removed
Owner: changed from macports-tickets@… to mk@…

comment:3 Changed 10 years ago by mkae (Marko Käning)

Yes, there is a message at some time telling you to start org.freedesktop.dbus-session.plist

So you should run

--->  Installing dbus @1.2.24_0
--->  Activating dbus @1.2.24_0
#################################################################################################
# Startup items have been generated that will aid in
# starting dbus with launchd. They are disabled
# by default. Execute the following command to start them,
# and to cause it to launch at startup:
#
# sudo launchctl load -w /Library/LaunchDaemons/org.freedesktop.dbus-system.plist
# launchctl load -w /Library/LaunchAgents/org.freedesktop.dbus-session.plist

After this your kmm should start up.

Wondering whether it will find the oxygen iconset on your machine...

comment:4 Changed 10 years ago by strassh@…

I executed those 2 lines but I still have the same issue, KMM won't start and no output in the terminal...

I must miss something else...

comment:5 Changed 10 years ago by SBauer3@…

Probably same problem: Having a working installation of kmm 1.05, I tested installing kmm 4.5 on a spare mac. I freshly installed Mac Develloper tools, macports and the port kmymoney4. Installation went through, but kmm does not start up. From command line, I get the note --bash ... command not found However, this reaction is the same for all installed KDE-ports QT-ports, in contrast, work. The default error (missing PATH-entry in .profile) seems not to apply. As a test, I installed kdebase4 as well - same problem (konquerer, mysql ... nothing works).

comment:6 Changed 10 years ago by SBauer3@…

Cc: SBauer3@… added

Cc Me!

comment:7 in reply to:  5 Changed 10 years ago by SBauer3@…

Replying to SBauer3@…:

Probably same problem:
Having a working installation of kmm 1.05, I tested installing kmm 4.5 on a spare mac. I freshly installed Mac Develloper tools, macports and the port kmymoney4. Installation went through, but kmm does not start up. From command line, I get the note
--bash: kmymoney: command not found
However, this reaction is the same for all installed KDE-ports. QT-ports, in contrast, work. The default error (missing PATH-entry in .profile) seems not to apply. As a test, I installed kdebase4 as well - same problem (konquerer, mysql ... nothing works).

Here ist the Error message:

Process:         kmymoney [26694]
Path:            /Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney
Identifier:      kmymoney
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  launchd [113]

Date/Time:       2010-11-10 13:05:10.533 +0100
OS Version:      Mac OS X 10.6.4 (10F569)
Report Version:  6

Interval Since Last Report:          665704 sec
Crashes Since Last Report:           120368
Per-App Crashes Since Last Report:   1
Anonymous UUID:                      361AC68D-4181-4E2C-8E86-30503F346C82

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
  Library not loaded: /opt/local/lib/liblzma.1.dylib
  Referenced from: /opt/local/lib/libkdecore.5.dylib
  Reason: image not found

Model: Macmini2,1, BootROM MM21.009A.B00, 2 processors, Intel Core 2 Duo, 1.83 GHz, 2 GB, SMC 1.19f0

comment:8 Changed 10 years ago by mkae (Marko Käning)

liblzma.1.dylib is missing, which means that there is a hidden dependency to libzma which somehow slipped through.

Please install port liblzma and try again.

(I currently can't test it myself, but will do a clean-slate install and try to reproduce as fast as I can.)

comment:9 Changed 10 years ago by mkae (Marko Käning)

Yep, I see now the above was the problem. Shall be fixed with r73349.

comment:10 Changed 10 years ago by strassh@…

It seems that my problem is different. I upgrade my ports and after a new build of qt4-mac and kdelibs4, the problem is still here.

The report from the Apple bug reporter isn't the same as above, it has no useful information :

Command:         kmymoney
Path:            /Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney
Version:          ()
Parent:          launchd [231]

PID:             30069
Event:           hang
Duration:        38.67s (sampling started after 2 seconds)
Steps:           366 (100ms sampling interval)

Pageins:         0
Pageouts:        0


Process:         kmymoney [30069]
Path:            /Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney
UID:             501

liblzma is installed on my system.

comment:11 Changed 10 years ago by mkae (Marko Käning)

Well, I now have a problem with phonon:

[ MP-devel ] :kdelibs4 marko$ /opt/macports-test/Applications/KDE4/kmymoney.app/Contents/MacOS/kmymoney
dyld: Library not loaded: libphonon.4.dylib
  Referenced from: /opt/macports-test/lib/libkhtml.5.dylib
  Reason: image not found
Trace/BPT trap
[ MP-devel ] :kdelibs4 marko$ ls -l /opt/macports-test/lib/libphonon.*
-rwxr-xr-x  2 root  admin  439568 Nov  5 20:42 /opt/macports-test/lib/libphonon.4.4.2.dylib
lrwxr-xr-x  1 root  admin      21 Nov  5 20:42 /opt/macports-test/lib/libphonon.4.4.dylib -> libphonon.4.4.2.dylib
lrwxr-xr-x  1 root  admin      21 Nov  5 20:42 /opt/macports-test/lib/libphonon.4.dylib -> libphonon.4.4.2.dylib
lrwxr-xr-x  1 root  admin      21 Nov  5 20:42 /opt/macports-test/lib/libphonon.dylib -> libphonon.4.4.2.dylib
-rw-r--r--  2 root  admin     746 Nov  5 20:42 /opt/macports-test/lib/libphonon.la
-rw-r--r--  2 root  admin     902 Nov  5 20:42 /opt/macports-test/lib/libphonon.prl

Am irritated as the library is indeed there as one can see above...

comment:12 Changed 10 years ago by strassh@…

Sorry, my last post was a mistake.

KMyMoney4 works well if I launch from the terminal : /opt/local/var/macports/software/kmymoney4/4.5_2/Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney

It doesn't work from the icon in the Applications/Macports/KDE4/ directory the first time. But now it works well... don't know why.

So this issue is solved for me. Thanks !


@mk: My feedback on the problems you listed :

So far known problems are:

  • oxygen icon theme is not found by the app => The icons seems to work well here, what icon are you referring to ? Maybe it's because I have the oxygen-icons port installed, I remember that it wasn't listed in the dependencies needed to be installed for kmymoney4.
  • reports let the app hang => I opened some reports, I didn't notice any hangs.
  • some fonts seem to be missing, since layout looks inhomogenious => The app doesn't look as nice as on KDE, but it's better integrated than the 1.0.5 one running using X11, maybe we should now work with the KMyMoney team on this, I'll see what info I can give them.
  • kmm_banking plugin doesn't work => I don't use that (I don't even know what's that suppose to do) so I didn't test it.

comment:13 Changed 10 years ago by mkae (Marko Käning)

Good to know that it works for you. I can't get it running myself at the moment due to the libkhtml and phonon thing. :( Would you be so kind as to post a jpeg which shows the app's main window so that I can compare with how it looks like on my end concerning fonts etc. Yep, the oxygen thing I also found in the meantime. But since it doesn't run I can't test for that. Good that reports work for you. kmm_banking is important for German HBCI bank access and I hope to get that patched in as soon as I can run kmm4 again.

Yep, you are right, further improvements should be done with the kmm developers directly.

I'm happy for you that you can run it on your end. Let me know if you find other than cosmetic glitches right away.

Changed 10 years ago by strassh@…

Attachment: Home.jpg added

Home screen with tip of the day

Changed 10 years ago by strassh@…

Attachment: Ledger.jpg added

Ledger (with personal infos hidden)

Changed 10 years ago by strassh@…

Attachment: Pie chart.jpg added

Pie chart

Changed 10 years ago by strassh@…

Attachment: Report.jpg added

Text report, looks quite nice

Changed 10 years ago by strassh@…

Attachment: Budget.jpg added

Budget, the only line chart that doesn't hang the app

comment:14 Changed 10 years ago by strassh@…

I tested some more charts and I find out that some of them hang the app.

It seems that line charts hang the app if you try to open them from the report list. But if you open them from a text report (clicking the "Chart" button), it's fine. It's also seems fine if you edit an already open report to make it look like a non working report.

I'll try to tell the KMyMoney developers to look at this bug report.

comment:15 Changed 10 years ago by mkae (Marko Käning)

Good to see that you strassh are able to achieve obviously more than I can. :) Wondering how I can fix my library problem here...

comment:16 Changed 10 years ago by mkae (Marko Käning)

Hi, I only now noticed that port qt4-mac missed an upgrade to 4.7.1. Building it now, hoping that this will later fix the issue above and I am back to a functioning kmm4.

comment:17 Changed 10 years ago by mkae (Marko Käning)

After building qt4-mac, kdelibs4, kdepimlibs4 and kmymoney4 anew my problem persists, but this time I issued a

export DYLD_FALLBACK_LIBRARY_PATH=/opt/macports-test/lib

before running kmm and it eventually started, now with icons. It runs so far nicely, but seems a little slow compared to version 1.0.5.

Next I'll try to implement the HBCI stuff.

I'm going to open a new ticket concerning the weird phonon library issue. This ticket can be closed then. But now I am too tired and shift that to another day, presumably during the weekend.

comment:18 Changed 10 years ago by strassh@…

I think I should file an other bug report about that, but do you have the problem I describe in that thread : http://forum.kde.org/viewtopic.php?f=69&t=91357

It's quite annoying...

comment:19 Changed 10 years ago by mkae (Marko Käning)

Oh, that sounds bad. Well, good that you posted it there. I checked it out and see I have the same thing. I'll attach the crashlog to the forum post.

Changed 10 years ago by mkae (Marko Käning)

Attachment: sigsegv.txt.gz added

Crashlog for date edit error in legder

comment:20 Changed 10 years ago by mkae (Marko Käning)

Xes, and it would be good to separate the various issues here into dedicated tickets, I guess.

comment:21 Changed 10 years ago by mkae (Marko Käning)

Filed a separate ticket (#27292) concerning the phonon issue.

comment:22 Changed 10 years ago by strassh@…

From my part I have filled a bug on the KMyMoney Bugtracker : https://sourceforge.net/tracker/index.php?func=detail&aid=3108099&group_id=4708&atid=204708

comment:23 Changed 10 years ago by mkae (Marko Käning)

Please point them to the sigsegv.txt.gz crash log, just to make sure they have that info.

comment:24 Changed 10 years ago by mkae (Marko Käning)

Have just now - following Thomas' advice - KMM 4.5 successfully patched concerning kbanking plugin. Now HBCI works just like in version 1.0.5!

See r73414

comment:25 Changed 10 years ago by mkae (Marko Käning)

Could successfully patch up to KMM's current revision 1194935. Will ask what developers think about officially distributing it via MacPorts already. (Thinking about perhaps adding a variant for it, since that would allow us to up-to-date with the developers in testing their latest additions.)

comment:26 Changed 10 years ago by mkae (Marko Käning)

But sorry, strassh, the date bug is also present in this very latest version. :(

comment:27 Changed 10 years ago by mkae (Marko Käning)

Resolution: fixed
Status: newclosed

Edit field bug temporally "fixed" in r73470.

However, note that version 4.5.1 does at the moment not support the KBanking plugin (there are still some build issues).

I have all relevant bugs now at http://bugs.kde.org, so I think we should close the issues here and try to stick to only that, as long as it concerns non-MacPorts issues. The date edit field bug is rather a KDE issue, as it looks like.

comment:28 Changed 10 years ago by mkae (Marko Käning)

Watch out for the new port kmymoney4-devel introduced with r73532

I plan to keep it in sync with SVN HEAD as long as there are no build problems.

comment:29 in reply to:  description Changed 10 years ago by SBauer3@…

Resolution: fixed
Status: closedreopened

Replying to strassh@…:

After several weeks of not looking at the problem, I made a new attempt to install kmymoney4. I completely removed macports and started from scratch. It did not work. It still does not work (except for a jumping jack on the dock)

Here is something I found: Here is the content of kmymoney.shell

#!/bin/sh                                                                       
# created by cmake, don't edit, changes will be lost                            

DYLD_LIBRARY_PATH=/opt/local/var/macports/build/_opt_local_var_macports_sources\
_rsync.macports.org_release_ports_kde_kmymoney4/work/build/lib/./:/opt/local/li\
b${DYLD_LIBRARY_PATH:+:$DYLD_LIBRARY_PATH} "/opt/local/var/macports/build/_opt_\
local_var_macports_sources_rsync.macports.org_release_ports_kde_kmymoney4/work/\
build/kmymoney/kmymoney.app/Contents/MacOS/kmymoney" "$@"

However, there are no files
_opt_local_var_macports_sources
_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kmymoney4
in the path
/opt/local/var/macports/build/

The strange thing is that I got kmymoney4 to work on a different mac after the same sort of fiddling around as you guys described in this thread. But on this machine I cannot replicate this.

For the moment I am giving up on kmymoney4.

comment:30 Changed 10 years ago by SBauer3@…

Made a fresh install on another mac. Doesn't work either. Here's what the gdb-debugger says:

localhost:~ SBauer3$ gdb 
GNU gdb 6.3.50-20050815 (Apple version gdb-1510) (Wed Sep 22 02:45:02 UTC 2010)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-apple-darwin".
(gdb) run /Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney
Starting program:  /Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney
No executable file specified.
Use the "file" or "exec-file" command.
(gdb) file /Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney
Reading symbols for shared libraries ...................................... done
Reading symbols from /Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney...done.
(gdb) run /Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney
Starting program: /Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney /Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney
Reading symbols for shared libraries .+++++++++++++++++++++++++++++++++++++...............................................................................................warning: Could not find object file "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_archivers_bzip2/work/bzip2-1.0.6/blocksort.o" - no debug information available for "blocksort.c".

warning: Could not find object file "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_archivers_bzip2/work/bzip2-1.0.6/huffman.o" - no debug information available for "huffman.c".

warning: Could not find object file "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_archivers_bzip2/work/bzip2-1.0.6/crctable.o" - no debug information available for "crctable.c".

warning: Could not find object file "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_archivers_bzip2/work/bzip2-1.0.6/randtable.o" - no debug information available for "randtable.c".

warning: Could not find object file "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_archivers_bzip2/work/bzip2-1.0.6/compress.o" - no debug information available for "compress.c".

warning: Could not find object file "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_archivers_bzip2/work/bzip2-1.0.6/decompress.o" - no debug information available for "decompress.c".

warning: Could not find object file "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_archivers_bzip2/work/bzip2-1.0.6/bzlib.o" - no debug information available for "bzlib.c".

..................... done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done



Program received signal SIGTERM, Terminated.
0x00007fff81010fca in __semwait_signal ()
(gdb) 
(gdb) 
(gdb) kill
Kill the program being debugged? (y or n) y
(gdb) quit

comment:31 Changed 10 years ago by mkae (Marko Käning)

I noticed that there is additional trouble for ports kmymoney4 and kmymoney4-devel, due to the latest version of kdelibs 4.5.4, causing the homepage to be misformatted (perhaps due to not found CSS or so).

But more important is: due to SBauer3's hint I have verified that there is indeed some permission problem when installing the application via "sudo port install kmymoney4" as one user and then to try to run it as another user. The application would simply not start... That's what quite a few testers have already experienced with the app. Why this happens is still unclear to me. :-(

comment:32 Changed 10 years ago by mkae (Marko Käning)

This might be related to #27555.

comment:33 Changed 10 years ago by mkae (Marko Käning)

If kmymoney4 in your case would only lead to a jumping icon in the dock, please check whether you can actually find kmymoney.app in /opt/local/Applications/KDE4, assuming that /opt/local is your MacPorts installation's ${prefix}. There are reported cases that the Applications folder wasn't installed at all...

comment:34 Changed 10 years ago by mkae (Marko Käning)

Hi,

any changes to the positive concerning the execution problems since version 4.5.3 is out?

Greets, Marko

comment:35 Changed 10 years ago by mkae (Marko Käning)

Resolution: fixed
Status: reopenedclosed

Bauer3 told me that the problem is solved for him: all three machines build and run KMM4 fine. Since there is no feedback from strassh I assume that this ticket can be closed. Please open a new ticket with more info if the problem isn't solved.

comment:36 Changed 9 years ago by strassh@…

Resolution: fixed
Status: closedreopened

The problem is back !!

Always the same thing, just after I compiled for the KDE 4.7 upgrade, kmymoney stoped launching again...

I tried some of the things I remembered from last time:

  • I unload/reload org.freedesktop.dbus-session.plist
  • I tried to launch KMyMoney by hand from /Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney (still no output, bouncing icon, that's it)
  • I tried to reinstall it.
  • I tried the -devel version

Here is some informations : $ /Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney -v Qt: 4.7.3 KDE Development Platform: 4.7.00 (4.7.0) KMyMoney: 4.5.96

$ gdb GNU gdb 6.3.50-20050815 (Apple version gdb-1515) (Sat Jan 15 08:33:48 UTC 2011) Copyright 2004 Free Software Foundation, Inc. GDB is free software, covered by the GNU General Public License, and you are welcome to change it and/or distribute copies of it under certain conditions. Type "show copying" to see the conditions. There is absolutely no warranty for GDB. Type "show warranty" for details. This GDB was configured as "x86_64-apple-darwin". (gdb) file /Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney Reading symbols for shared libraries ............................................ done Reading symbols from /Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney...done. (gdb) run /Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney Starting program: /Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney /Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney Reading symbols for shared libraries .+++++++++++++++++++++++++++++++++++++++++++......warning: Could not find object file "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_archivers_bzip2/work/bzip2-1.0.6/blocksort.o" - no debug information available for "blocksort.c".

warning: Could not find object file "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_archivers_bzip2/work/bzip2-1.0.6/huffman.o" - no debug information available for "huffman.c".

warning: Could not find object file "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_archivers_bzip2/work/bzip2-1.0.6/crctable.o" - no debug information available for "crctable.c".

warning: Could not find object file "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_archivers_bzip2/work/bzip2-1.0.6/randtable.o" - no debug information available for "randtable.c".

warning: Could not find object file "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_archivers_bzip2/work/bzip2-1.0.6/compress.o" - no debug information available for "compress.c".

warning: Could not find object file "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_archivers_bzip2/work/bzip2-1.0.6/decompress.o" - no debug information available for "decompress.c".

warning: Could not find object file "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_archivers_bzip2/work/bzip2-1.0.6/bzlib.o" - no debug information available for "bzlib.c".

............................................................................................................... done Reading symbols for shared libraries . done Reading symbols for shared libraries . done Reading symbols for shared libraries . done Reading symbols for shared libraries . done Reading symbols for shared libraries . done Reading symbols for shared libraries . done Reading symbols for shared libraries . done C Program received signal SIGINT, Interrupt. 0x00007fff842a2f8a in semwait_signal () (gdb) kill Kill the program being debugged? (y or n) y (gdb) quit

comment:37 Changed 9 years ago by mkae (Marko Käning)

Can you post your output of

ps aux | grep dbus

please!

comment:38 Changed 9 years ago by strassh@…

Whaou ! Quick reply !

Here it is :

$ ps aux | grep dbus
messagebus    60   0,0  0,0  2435472    632   ??  Ss   25jul11   0:00.02 /opt/local/bin/dbus-daemon --system --nofork
pierre   18909   0,0  0,0  2425520    168 s002  R+   11:11     0:00.00 grep dbus

comment:39 Changed 9 years ago by mkae (Marko Käning)

:-)

Well, dear Pierre, it looks like you are now in the same situation like me. I am suffering since weeks and weeks from the fact that my dbus wouldn't start up anymore.

:-(

I am sorry to have caused this to your installation, I am back to KMyMoney 1.0.5 since then. :-/

Please check out #29409 for reference.

comment:40 Changed 9 years ago by strassh@…

Don't worry, I'm going to holiday at the end of the week, my accounts can wait ! Maybe a magical solution will come before I came back !

comment:41 Changed 9 years ago by mkae (Marko Käning)

So be it, I am waiting for a solution falling from heaven since quite a while already. :-(

comment:42 Changed 9 years ago by mkae (Marko Käning)

Cc: pixilla@… added

comment:43 Changed 9 years ago by gleirsch@…

Having still kind of the same problem with the current ports:

/Applications/MacPorts/KDE4/kmymoney.app/Contents/MacOS/kmymoney -v
Qt: 4.7.3
KDE Development Platform: 4.7.00 (4.7.0)
KMyMoney: 4.6.0

Starting the app ends up in a bouncing icon and a process which is not even listed in the activity monitor but only when task switching.

However, ps aux | grep dbus tells me that dbus seems to be fully started or available:

(user) 24801   0,0  0,0  2446936    872   ??  S    Mi11am    0:00.01 /opt/local/bin/dbus-daemon --nofork --session
messagebus    54   0,0  0,0  2435472    744   ??  Ss   Mi08am    0:00.01 /opt/local/bin/dbus-daemon --system --nofork
(user) 61609   0,0  0,0  2435120    544 s001  S+    9:24am   0:00.00 grep dbus

comment:44 Changed 9 years ago by gleirsch@…

All of a sudden I could get KMM to start up. I don't know what happened except that before using KMM I startet kile and other kde stuff, e.g. kate. So, maybe someone can confirm KMM working in order to close this issue.

comment:45 Changed 9 years ago by mkae (Marko Käning)

I am very happy to see that KMM again started to work for you.

That sounds very much as if we're missing a certain installation step. Perhaps kbuildsycoca4?

But I guess you won't have a way to reproduce what you experienced...

Unfortunately I still can't test anything here: My KMM is still dead due to the dbus issue. All I can do right now is to blindly check whether kmymoney4-devel builds and commit it as is. :-(

comment:46 Changed 9 years ago by strassh@…

Hi,

I "repaired" my system. Here what I have done :

  • Uninstall all ports (as kmymoney is the only port I use everyday)
    $ sudo port uninstall installed
    
  • Install kmymoney4
    $ sudo port install kmymoney4
    
  • Install kate
    $ sudo port install kate
    
  • Tried to launch kate (nothing...)
  • Tried to launch kwrite (it works !!)
  • Tried to launch kate (it works now !!)
  • Tried to launch kmymoney4 successfully !!

What I haven't tried :

  • I didn't tried to launch kwrite before the uninstall/install step
  • I didn't tried to launch kwrite before the kate installation

So maybe this is working :

  • Uninstall everything then install kmymoney4
  • launch kwrite
  • launch kmymoney4

Hope it helps !

Cheers !

comment:47 Changed 9 years ago by mkae (Marko Käning)

Cc: snc@… michaelld@… added

That's a hell job. This procedure needs at least 6 hrs on my dual core iMac... (I already have 5 different MP installs on my system, none of them works as wanted.)

:-/ :-(

I'm afraid we've got different problems anyway, because your dbus is working, while mine isn't!!!

comment:48 Changed 9 years ago by mkae (Marko Käning)

For some reason my kmymoney4(-devel) installations run normally again. :-)

The sad thing though is that I don't know why... :-(

comment:49 Changed 9 years ago by mkae (Marko Käning)

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.