Opened 8 years ago

Closed 7 years ago

#29465 closed defect (duplicate)

Atlas install shell command failed

Reported by: barry.newberger@… Owned by: jameskyle@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: atlas

Description (last modified by ryandesign (Ryan Schmidt))

Atlas install fails with the above error message. Prior to installing, I executed the following:

port selfupdate
port clean atlas outdated
port outdated
port upgrade outdated
port install atlas

main.log attached

Attachments (1)

main.log (5.0 MB) - added by barry.newberger@… 8 years ago.

Change History (5)

Changed 8 years ago by barry.newberger@…

Attachment: main.log added

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to jameskyle@…
Port: atlas added

I see you're on a PowerPC running Mac OS X 10.4, which could be relevant.

Interesting parts of the log are:

:info:build Timeout waiting for file /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_atlas/work/atlas-3.9.37/build/include/atlas_pthreads.h!!
:info:build 
:info:build /opt/local/bin/gcc-mp-4.4 -o ATL_ptflushcache.o -c -DL2SIZE=4194304 -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_atlas/work/atlas-3.9.37/build/include -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_atlas/work/atlas-3.9.37/build/..//include -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_atlas/work/atlas-3.9.37/build/..//include/contrib -DAdd_ -DF77_INTEGER=int -DStringSunStyle -DATL_OS_OSX -DATL_ARCH_PPCG4 -DATL_CPUMHZ=466 -DATL_AltiVec -DATL_GAS_PPC -DATL_AVgcc -DWALL -DATL_FULL_LAPACK -O3 -maltivec -mabi=altivec -mcpu=7400 -mtune=7400 -fPIC -m32 -m32 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_atlas/work/atlas-3.9.37/build/..//src/auxil/ATL_ptflushcache.c
:info:build In file included from /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_atlas/work/atlas-3.9.37/build/..//src/auxil/ATL_ptflushcache.c:33:
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_atlas/work/atlas-3.9.37/build/..//include/atlas_threads.h:13:78: error: atlas_pthreads.h: No such file or directory
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_atlas/work/atlas-3.9.37/build/..//src/auxil/ATL_ptflushcache.c: In function 'ATL_ptflushcache':
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_atlas/work/atlas-3.9.37/build/..//src/auxil/ATL_ptflushcache.c:71: error: 'ATL_NTHREADS' undeclared (first use in this function)
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_atlas/work/atlas-3.9.37/build/..//src/auxil/ATL_ptflushcache.c:71: error: (Each undeclared identifier is reported only once
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_atlas/work/atlas-3.9.37/build/..//src/auxil/ATL_ptflushcache.c:71: error: for each function it appears in.)
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_atlas/work/atlas-3.9.37/build/..//src/auxil/ATL_ptflushcache.c: In function 'ATL_ptFlushAreasByCL':
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_atlas/work/atlas-3.9.37/build/..//src/auxil/ATL_ptflushcache.c:123: error: 'ATL_NTHREADS' undeclared (first use in this function)
:info:build make[3]: *** [ATL_ptflushcache.o] Error 1
:info:build make[2]: *** [IBuildPtlibs0] Error 2

and:

:debug:build Executing proc-post-org.macports.build-build-0
:info:build /usr/bin/ld: warning -L: directory name (/opt/local/lib/gcc44/ppc) does not exist
:info:build /usr/bin/ld: Undefined symbols:
:info:build rest_world
:info:build save_world

The latter makes this look like a duplicate of #28996.

comment:2 Changed 8 years ago by Ink_Blot2001@…

I am also having the same problem, though I am on a PowerPC running Mac OS X 10.5. The log file is essentially the same, though with some slight differences in formatting and possibly some added info. Will upload if there is any interest.

comment:3 Changed 8 years ago by Veence (Vincent)

I am currently evaluating the 3.9.41 new release which has a lot of OSX bugs fixed, I'll keep you posted.

comment:4 Changed 7 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.