Opened 9 years ago

Closed 9 years ago

#29466 closed enhancement (duplicate)

MacPorts should let ports indicate OS version compatibility

Reported by: rudloff@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 1.9.2
Keywords: Cc: ryandesign (Ryan Schmidt)
Port:

Description

I still use Tiger so there are some ports I can't build.
The problem is that MacPorts will first download all the dependencies before telling me I can't install the port.
So there should be some kind of check at the very beginning of the install.

Change History (2)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Milestone: MacPorts Future
Summary: Portfile should contain information about OSX compatible versionsMacPorts should let ports indicate OS version compatibility

Indeed it would be nice if ports could indicate something like this, rather than having to add blocks of code like we currently do (which has the deficiency you point out, that dependencies are still built first).

But it would be better to assume that a port will work with any Mac OS X version, and let the port specify OS versions with which it is not compatible. We don't have the manpower to test every single port on a new OS release, so we should just assume it will work, and if we discover that it does not, then we can mark the port as being incompatible.

comment:2 Changed 9 years ago by jmroot (Joshua Root)

Milestone: MacPorts Future
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.