Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#30022 closed defect (fixed)

Building xorg-xcb-util fails when gperf is installed

Reported by: henne@… Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez), szepesva@…, shane.wilkins@…, mf2k (Frank Schima)
Port: gperf xorg-xcb-util

Description

Trying to install py27-gtk the dependency xorg-xcb-util causes error.

Console:

--->  Building xorg-xcb-util
Making all in src
/usr/bin/make  all-am
  CC     atoms.lo
atoms.gperf:36: error: duplicate 'static'
atoms.gperf:38: warning: function declaration isn't a prototype
atoms.gperf: In function 'hash':
atoms.gperf:40: warning: old-style function definition
atoms.gperf: At top level:
atoms.gperf:243: warning: function declaration isn't a prototype
atoms.gperf: In function 'in_word_set':
atoms.gperf:245: warning: old-style function definition
make[2]: *** [atoms.lo] Error 1
make[1]: *** [all] Error 2
make: *** [all-recursive] Error 1
shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_xorg-xcb-util/work/xcb-util-0.3.8" && /usr/bin/make -j2 all " returned error 2
Error: Target org.macports.build returned: shell command failed (see log for details)
Warning: the following items did not execute (for xorg-xcb-util): org.macports.activate org.macports.build org.macports.destroot org.macports.install
Log for xorg-xcb-util is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_xorg-xcb-util/main.log
Error: Status 1 encountered during processing.

Log:

:msg:main --->  Building xorg-xcb-util
:debug:build build phase started at Mon Jul  4 15:02:18 CEST 2011
:debug:build Executing org.macports.build (xorg-xcb-util)
:debug:build Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_xorg-xcb-util/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.6'
:debug:build Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_xorg-xcb-util/work/xcb-util-0.3.8" && /usr/bin/make -j2 all'
:info:build Making all in src
:info:build /usr/bin/make  all-am
:info:build   CC     atoms.lo
:info:build atoms.gperf:36: error: duplicate 'static'
:info:build atoms.gperf:38: warning: function declaration isn't a prototype
:info:build atoms.gperf: In function 'hash':
:info:build atoms.gperf:40: warning: old-style function definition
:info:build atoms.gperf: At top level:
:info:build atoms.gperf:243: warning: function declaration isn't a prototype
:info:build atoms.gperf: In function 'in_word_set':
:info:build atoms.gperf:245: warning: old-style function definition
:info:build make[2]: *** [atoms.lo] Error 1
:info:build make[1]: *** [all] Error 2
:info:build make: *** [all-recursive] Error 1
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_xorg-xcb-util/work/xcb-util-0.3.8" && /usr/bin/make -j2 all " returned error 2
:error:build Target org.macports.build returned: shell command failed (see log for details)
:debug:build Backtrace: shell command failed (see log for details)
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for xorg-xcb-util): org.macports.activate org.macports.build org.macports.destroot org.macports.install

Attachments (1)

main.log (41.7 KB) - added by shane.wilkins@… 8 years ago.
log

Download all attachments as: .zip

Change History (17)

comment:1 Changed 8 years ago by henne@…

Cc: henne@… added

Cc Me!

comment:2 Changed 8 years ago by szepesva@…

Cc: szepesva@… added

Cc Me!

comment:3 Changed 8 years ago by shane.wilkins@…

Cc: shane.wilkins@… added

Cc Me!

comment:4 Changed 8 years ago by jmroot (Joshua Root)

Cc: henne@… removed
Owner: changed from macports-tickets@… to jeremyhu@…
Port: xorg-xcb-util added

Please remember to fill in the Port field and cc the maintainer.

comment:5 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Please attach the full log.

Changed 8 years ago by shane.wilkins@…

Attachment: main.log added

log

comment:6 Changed 8 years ago by jmroot (Joshua Root)

Cc: mcalhoun@… added
Port: gperf added
Summary: Building xorg-xcb-util crashesBuilding xorg-xcb-util fails when gperf is installed

Happens iff gperf is installed with the latest changes.

comment:7 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Thanks, I can reproduce it now... hrm...

comment:8 Changed 8 years ago by mf2k (Frank Schima)

Cc: macsforever2000@… added

Cc Me!

comment:9 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: newclosed

comment:10 Changed 8 years ago by allanjos@…

Hi. How can I use this change? I am trying "upgrade outdated", but still getting this error. I've upgraded from Tiger (10.4) to Leopard (10.5).

Thank you. Best.

comment:11 in reply to:  10 Changed 8 years ago by mf2k (Frank Schima)

You need to selfupdate first.

sudo port selfupdate

When you upgraded the OS, did you follow the migration instructions?

comment:12 Changed 8 years ago by larrynator@…

I'm new to OSX and to MacPorts. I had this problem. I've done selfupdate and upgrade outdated, but still get the same error when trying to install xorg-xcb-util. I'm on Snow Leopard. Are there any other steps I need to do?

comment:13 in reply to:  12 Changed 8 years ago by keith@…

Replying to larrynator@…:

I'm new to OSX and to MacPorts. I had this problem. I've done selfupdate and upgrade outdated, but still get the same error when trying to install xorg-xcb-util. I'm on Snow Leopard. Are there any other steps I need to do?

Hi, I had the same issu. I managed to solve it by going to the xorg-xcb-util dir and getting it to rebuild atom.c from the gperf souyrce ( touch atom.gperf ) It looks like although the patch fixes the double static, the datestamps of the files on the port seem to mean it doesnt rebuild this intermediate product.

I had deleted the port then reinstalled it before I did this.

comment:14 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

sudo port -v clean xorg-xcb-util

comment:15 Changed 8 years ago by allanjos@…

Hi. The step that I didn't was the Migration (https://trac.macports.org/wiki/Migration). I've reinstalled MacPorts for Leopard.

Now all the things are working again.

Thank you very much. Best.

comment:16 Changed 8 years ago by larrynator@…

Clean did the trick. Thanks, Jeremy, slowly learning my way through it all.

Note: See TracTickets for help on using tickets.