Opened 9 years ago

Closed 8 years ago

#30299 closed defect (fixed)

pdftk @1.44 build failure on Lion

Reported by: moninec@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.0.0
Keywords: lion Cc: lawrence.ong@…, melanochaitus@…, 81joe81@…, ratberryjam@…, joefitz@…, Garfield-fr (Bertrand Zuchuat), dannowolk@…, maehne (Torsten Maehne), shayanlinux@…, akeyo82@…, maverickwoo (Maverick Woo), skew41@…, lincoln@…, vishketan@…, Sam.Halliday@…, jmehnle (Julian Mehnle), Angelo.Graziosi@…, mww@…, mullen.rob@…, hweber@…, robsonpeixoto@…, arty.net2@…, jamal@…, macports.org@…, hiyjtsuj@…, lev_@…, fondacio@…, hraban@…, Josef.Buergler@…
Port: pdftk, gcc45

Description

Mac OS X 10.7 build 11A511, Xcode 4.2

pdftk failed to build with error:

:info:build /opt/local/bin/gcj-mp-4.5 -Wall -fsource=1.3 -O2 --encoding=UTF-8 --classpath="/opt/local/share/java/libgcj-4.5.3.jar:/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_pdftk/pdftk/work/pdftk-1.44-dist/java:." -c java_lib.jar
:info:build gcj-mp-4.5: java_lib.jar: No such file or directory
:info:build gcj-mp-4.5: no input files
:info:build make[1]: [java_lib.o] Error 1 (ignored)
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_pdftk/pdftk/work/pdftk-1.44-dist/java'
:info:build make: *** No rule to make target `../java/java_lib.o', needed by `pdftk.o'.  Stop.

Attachments (3)

main.log (1.4 MB) - added by moninec@… 9 years ago.
full build log
main.2.log (1.4 MB) - added by tristan.klocke@… 9 years ago.
Another mainlog from lion (10.7)
main.3.log (281.0 KB) - added by hraban@… 8 years ago.
build log on OSX 10.5.8 (some java error)

Change History (60)

Changed 9 years ago by moninec@…

Attachment: main.log added

full build log

comment:1 Changed 9 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to ryandesign@…

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Keywords: lion added

pdftk's build has always been extremely fragile. I do not have Lion to test solutions to this. If someone finds the solution, let me know.

comment:3 Changed 9 years ago by lawrence.ong@…

Cc: lawrence.ong@… added

Cc Me!

comment:4 Changed 9 years ago by melanochaitus@…

Cc: melanochaitus@… added

Cc Me!

comment:5 Changed 9 years ago by 81joe81@…

Cc: 81joe81@… added

Cc Me!

comment:6 Changed 9 years ago by lincoln@…

I have the identical problem. cc Me!

comment:7 Changed 9 years ago by tristan.klocke@…

Cc: tristan.klocke@… added

Cc Me!

Changed 9 years ago by tristan.klocke@…

Attachment: main.2.log added

Another mainlog from lion (10.7)

comment:8 Changed 9 years ago by tristan.klocke@…

There is an installer for 10.6 which could be working for 10.7 http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/pdftk-1.44-osx10.6.dmg

comment:9 Changed 9 years ago by tristan.klocke@…

Cc: tristan.klocke@… removed

Cc Me!

comment:10 Changed 9 years ago by ratberryjam@…

Cc: ratberryjam@… added

Cc Me!

comment:11 Changed 9 years ago by joefitz@…

Cc: joefitz@… added

Cc Me!

comment:12 Changed 9 years ago by Garfield-fr (Bertrand Zuchuat)

Cc: bertrand.zuchuat@… added

Cc Me!

comment:13 Changed 9 years ago by dannowolk@…

Cc: dannowolk@… added

Cc Me!

comment:14 Changed 9 years ago by maehne (Torsten Maehne)

Cc: Torsten.Maehne@… added

Cc Me!

comment:15 Changed 9 years ago by shayanlinux@…

Cc: shayanlinux@… added

Cc Me!

comment:16 Changed 9 years ago by akeyo82@…

Cc: akeyo82@… added

Cc Me!

comment:17 Changed 9 years ago by maverickwoo (Maverick Woo)

Cc: maverick.woo@… added

Cc Me!

comment:18 Changed 9 years ago by skew41@…

Cc: skew41@… added

Cc Me!

comment:19 in reply to:  8 Changed 9 years ago by baggins613@…

Replying to tristan.klocke@…:

There is an installer for 10.6 which could be working for 10.7 http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/pdftk-1.44-osx10.6.dmg

The pdftk 1.44 installer for 10.6 works great for me on 10.7. Thanks!

comment:20 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: lincoln@… added

comment:21 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: vishketan@… added

Has duplicate #32213.

If anybody knows how to fix this problem, by all means let me know, better yet attach a portfile patch to fix it.

comment:22 in reply to:  8 Changed 9 years ago by macports.org@…

Replying to tristan.klocke@…:

There is an installer for 10.6 which could be working for 10.7 http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/pdftk-1.44-osx10.6.dmg

Works for me, too. Thanks so much.

comment:23 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: Sam.Halliday@… added

Has duplicate #32382.

comment:24 Changed 9 years ago by jmehnle (Julian Mehnle)

Cc: julian@… added

Cc Me!

comment:25 Changed 9 years ago by jmehnle (Julian Mehnle)

Ryan, you said you don't have Lion to test. Would it help to give you an SSH account on my Lion machine? Or, assuming you'd consider upgrading to Lion, to donate a Lion upgrade to you?

comment:26 Changed 9 years ago by samaburden@…

Cc: samaburden@… added

Cc Me!

comment:27 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: Angelo.Graziosi@… mww@… added
Port: gcc45 added
Summary: pdftk @1.44 build failurepdftk @1.44 build failure on Lion

I believe this is one of the problems gcc 4.5.4 will fix; see: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=49461 It looks like the developers fixed it 6 months ago; I don't know why they haven't released gcc 4.5.4 by now. Perhaps we could backport the fix ourselves.

See also http://lists.macosforge.org/pipermail/macports-dev/2011-July/015287.html in which patches were submitted to I believe fix this problem for gcc44; however that doesn't help us here since pdftk does not have a gcc44 variant (and won't be getting one).

comment:28 Changed 9 years ago by mullen.rob@…

Cc: mullen.rob@… added

Cc Me!

comment:29 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: hweber@… added

Has duplicate #33027.

comment:30 Changed 8 years ago by mas@…

Cc: mas@… added

Cc Me!

comment:31 Changed 8 years ago by markusp12@…

I installed the latest GCC 4.5 Snapshot from a local port directory and successfully built pdftk! So i can confirm that GCC 4.5.4 fixes the build error when it officially gets released.

comment:32 Changed 8 years ago by robsonpeixoto@…

Cc: robsonpeixoto@… added

Cc Me!

comment:33 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: arty.net2@… added

Has duplicate #33729.

comment:34 Changed 8 years ago by ryandesign (Ryan Schmidt)

Angelo Graziosi sent the following questions by email; I'm entering them into the ticket to preserve them in the correct place:

On Mar 23, 2012, at 03:09, Angelo Graziosi wrote:

I have seen that a gcc-4.5.3_2 has been released...

while at it, why has it not be patched (backport) to build pdftk as suggested by this thread?

...and also... now that 4.7.0 is out (and it supports java..), it should build pdftk.. or not? (usually the last version of an applications should have been fixed the bugs of previous ones...)

Ciao,
Angelo.

comment:35 in reply to:  34 Changed 8 years ago by ryandesign (Ryan Schmidt)

Replying to Angelo.Graziosi@…:

I have seen that a gcc-4.5.3_2 has been released...

All that revision 2 changed was to add a forgotten dependency on ppl.

while at it, why has it not be patched (backport) to build pdftk as suggested by this thread?

If you can supply a patch that does that, we could consider it.

...and also... now that 4.7.0 is out (and it supports java..), it should build pdftk.. or not? (usually the last version of an applications should have been fixed the bugs of previous ones...)

The gcc47 port was only updated to 4.7.0 final one day ago, and before that time, fortran and java support were not enabled by default (as is the custom of our gcc maintainer). I have not yet tried to build gcc47 final to see if pdftk will work with it. Others are welcome to try it out share their findings.

comment:36 Changed 8 years ago by ryandesign (Ryan Schmidt)

In r91245 I have fixed gcc47 so that it installs ecj so that gcj works.

Then I tried adding a gcc47 variant to pdftk. It doesn't build. I reported the problem to the developer of pdftk.

comment:37 Changed 8 years ago by internetj@…

Just had this error today in macports with gcc45 @4.5.3_2 on Lion 10.7.3.

comment:38 Changed 8 years ago by jamal@…

Cc: jamal@… added

Cc Me!

comment:39 Changed 8 years ago by macports.org@…

Cc: macports.org@… added

Cc Me!

comment:40 Changed 8 years ago by hiyjtsuj@…

"pdftk" cannot be built. 9 months passed, and still no patch is given :-( Why do you even list "pdftk" in your available ports ? For decoration purposes ?

comment:41 Changed 8 years ago by hiyjtsuj@…

Cc: hiyjtsuj@… added

Cc Me!

comment:42 Changed 8 years ago by ryandesign (Ryan Schmidt)

Last I checked, pdftk built and worked correctly on Tiger, Leopard and Snow Leopard. I don't have Lion, sorry. Patches welcome.

comment:43 Changed 8 years ago by lev_@…

It still doesn't compile on Lion (10.7.3).

comment:44 Changed 8 years ago by lev_@…

Cc: lev_@… added

Cc Me!

comment:45 Changed 8 years ago by samaburden@…

Cc: samaburden@… removed

Cc Me!

comment:46 Changed 8 years ago by samaburden@…

Cc: samaburden@… added

Cc Me!

comment:47 Changed 8 years ago by samaburden@…

Cc: samaburden@… removed

Cc Me!

comment:48 Changed 8 years ago by samaburden@…

Cc: samaburden@… added

Cc Me!

comment:49 Changed 8 years ago by samaburden@…

Cc: samaburden@… removed

Cc Me!

comment:50 Changed 8 years ago by mas@…

Cc: mas@… removed

Cc Me!

comment:51 in reply to:  43 Changed 8 years ago by ryandesign (Ryan Schmidt)

Replying to lev_@…:

It still doesn't compile on Lion (10.7.3).

And it will continue to not compile on Lion until the gcc45 port is updated to version 4.5.4, which has not yet been released.

comment:52 Changed 8 years ago by fondacio@…

Cc: fondacio@… added

Cc Me!

Changed 8 years ago by hraban@…

Attachment: main.3.log added

build log on OSX 10.5.8 (some java error)

comment:53 Changed 8 years ago by hraban@…

build fails with gcc 4.5.3_4 on OSX 10.5.8, see log (maybe a different error than before) why is gcc42 default for pdftk? that fails to build, too

comment:54 Changed 8 years ago by Josef.Buergler@…

Cc Me! I have the same problem on Lion (10.7.3).

comment:55 in reply to:  54 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: hraban@… Josef.Buergler@… added

Replying to hraban@…:

build fails with gcc 4.5.3_4 on OSX 10.5.8, see log (maybe a different error than before) why is gcc42 default for pdftk? that fails to build, too

The reason gcc42 was chosen as the default for Leopard and earlier is #27154.

Replying to Josef.Buergler@…:

Cc Me! I have the same problem on Lion (10.7.3).

I've Cc'd you now. In the future please Cc yourself by clicking the "Cc Me!" button.

comment:56 in reply to:  31 Changed 8 years ago by shayanlinux@…

Replying to markusp12@…:

I installed the latest GCC 4.5 Snapshot from a local port directory and successfully built pdftk! So i can confirm that GCC 4.5.4 fixes the build error when it officially gets released.

GCC 4.5.4 is officially released today and therefore you should be able to build pdftk again on Lion. [looking forward to Mountain Lion? ;) ]

comment:57 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.