Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#30513 closed defect (fixed)

Unable to install emacs on Lion - Unable to verify file checksums

Reported by: mail@… Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 2.0.0
Keywords: checksum Cc: cssdev
Port: emacs

Description (last modified by ryandesign (Ryan Schmidt))

I'm trying to install the latest emacs (23.3) on Lion and getting

Here's the transcript:

dhcp-04:~ vijay$ sudo port install emacs
--->  Computing dependencies for emacs
--->  Fetching archive for emacs
--->  Fetching emacs
--->  Attempting to fetch emacs-23.3.tar.gz from http://mirrors.kernel.org/gnu/emacs
--->  Verifying checksum(s) for emacs
Error: Checksum (md5) mismatch for emacs-23.3.tar.gz
Error: Checksum (sha1) mismatch for emacs-23.3.tar.gz
Error: Checksum (rmd160) mismatch for emacs-23.3.tar.gz
Error: Target org.macports.checksum returned: Unable to verify file checksums
Log for emacs is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_editors_emacs/emacs/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>
dhcp-04:~ vijay$ sudo port clean --all emacs
--->  Cleaning emacs
dhcp-04:~ vijay$ sudo port -v checksum emacs
--->  Fetching emacs
--->  emacs-23.3.tar.gz doesn't seem to exist in /opt/local/var/macports/distfiles/emacs
--->  Attempting to fetch emacs-23.3.tar.gz from http://mirrors.kernel.org/gnu/emacs
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 45.7M  100 45.7M    0     0  10.0M      0  0:00:04  0:00:04 --:--:-- 10.0M
--->  Verifying checksum(s) for emacs
--->  Checksumming emacs-23.3.tar.gz
Error: Checksum (md5) mismatch for emacs-23.3.tar.gz
Portfile checksum: emacs-23.3.tar.gz md5 bf07c01ef473d8540c9c39f94506b1e6
Distfile checksum: emacs-23.3.tar.gz md5 20aef9ea5b5bf8050d39f8b1e96a1c04
Error: Checksum (sha1) mismatch for emacs-23.3.tar.gz
Portfile checksum: emacs-23.3.tar.gz sha1 53bdfe584f98c13265caa3eea3cfdf79ca0f7584
Distfile checksum: emacs-23.3.tar.gz sha1 d9fa8d121577dddb192297b8caa55cb8123e2e8a
Error: Checksum (rmd160) mismatch for emacs-23.3.tar.gz
Portfile checksum: emacs-23.3.tar.gz rmd160 e38a133735202c10bdd264e561d29dbbaaf558de
Distfile checksum: emacs-23.3.tar.gz rmd160 47104bebe70c509b82fd469bab0dea07e9e10fef
The correct checksum line may be:
checksums           md5     20aef9ea5b5bf8050d39f8b1e96a1c04 \
                    sha1    d9fa8d121577dddb192297b8caa55cb8123e2e8a \
                    rmd160  47104bebe70c509b82fd469bab0dea07e9e10fef
Error: Target org.macports.checksum returned: Unable to verify file checksums
Warning: the following items did not execute (for emacs): org.macports.checksum
Log for emacs is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_editors_emacs/emacs/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>
dhcp-04:~ vijay$ 

Change History (9)

comment:1 Changed 9 years ago by mail@…

Cc: mail@… added

Cc Me!

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: mail@… removed
Description: modified (diff)
Keywords: emacs removed
Owner: changed from macports-tickets@… to dports@…
Port: emacs added

comment:3 Changed 9 years ago by drkp (Dan Ports)

Status: newassigned

I can reproduce this, so it looks like the problem isn't on your end...

comment:4 Changed 9 years ago by drkp (Dan Ports)

Cc: css@… added
Resolution: fixed
Status: assignedclosed

Yes, this was a stealth update from the maintainers of emacs, because some source files weren't included in the 23.3 release.

Updated checksums in r81584.

emacs-app will probably need to do the same thing...

comment:5 Changed 9 years ago by lucas@…

dports@…, how do I pick up your updated version? I tried selfupdate and it didn't work.

Thanks in advance.

comment:6 Changed 9 years ago by drkp (Dan Ports)

It should be available by selfupdate; if you have emacs @23.3 revision 2 you should have the latest checksums. I don't think emacs-app has been updated yet...

comment:7 Changed 9 years ago by jmroot (Joshua Root)

FYI there's now a new distfile labelled 23.3a.

comment:8 in reply to:  7 Changed 9 years ago by drkp (Dan Ports)

Replying to jmr@…:

FYI there's now a new distfile labelled 23.3a.

Apparently they saw the error of their stealth-updating ways. r81680.

comment:9 Changed 9 years ago by drkp (Dan Ports)

Looks like they missed a couple other source files and released 23.3b; updated the port in r87595.

Note: See TracTickets for help on using tickets.