Opened 9 years ago

Closed 9 years ago

#30514 closed defect (fixed)

fuse4x-kext @0.8.8_0: Error activating on OS X 10.7 Lion

Reported by: david@… Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 2.0.0
Keywords: Cc: anatol (Anatol Pomozov)
Port: fuse4x-kext

Description

--->  Activating fuse4x-kext @0.8.8_0
Error: Target org.macports.activate returned: couldn't execute "/sbin/kextstat": no such file or directory

Though macports seems to think it succeeded anyway:

$ port installed | grep fuse
  fuse4x-kext @0.8.8_0 (active)

Change History (5)

comment:1 Changed 9 years ago by david@…

It definitely works in spite of the error message -- I installed sshfs and it all works.

comment:2 Changed 9 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to dports@…

Please remember to cc the maintainer.

kextstat is in /usr/sbin on 10.6 as well as 10.7.

comment:3 Changed 9 years ago by david@…

Thanks. (And sorry). :-) So is the correct solution to change the path to /usr/sbin (does macports support OS X versions prior to 10.6?),

or to remove the path altogether? (which isn't ideal, but it's what all other portfiles using kextstat do: fuse/macfuse, net/aiccu, and net/tuntaposx).

comment:4 Changed 9 years ago by drkp (Dan Ports)

Status: newassigned

comment:5 Changed 9 years ago by drkp (Dan Ports)

Resolution: fixed
Status: assignedclosed

Thanks, that was just an oversight on my part. Fixed in r81550.

Note: See TracTickets for help on using tickets.