Opened 10 years ago

Closed 9 years ago

#30648 closed defect (duplicate)

ghc: can't read "ghc_bootversion": no such variable

Reported by: schinder@… Owned by: gwright@…
Priority: Normal Milestone:
Component: ports Version: 2.0.1
Keywords: lion Cc: birk@…
Port: ghc

Description (last modified by mf2k (Frank Schima))

On a 2x2.4 GHz Quad-Core Intel Xeon MacPro, running Lion (OS X 10.7)

--->  Computing dependencies for ghc
--->  Applying patches to ghc
Error: Target org.macports.patch returned: shell command failed (see log for details)
Log for ghc is at: 
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_ghc/ghc/main.log
Error: Unable to upgrade port: 1

Attachments (3)

main.log (3.5 KB) - added by schinder@… 10 years ago.
main.2.log (26.2 KB) - added by schinder@… 10 years ago.
main.3.log (41.2 KB) - added by cjlacz@… 10 years ago.
Build log error

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by schinder@…

Attachment: main.log added

comment:1 Changed 10 years ago by mf2k (Frank Schima)

Description: modified (diff)
Owner: changed from macports-tickets@… to gwright@…
Port: ghc added

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Summary: "shell command failed" during ghc upgrade via "port install outdated"ghc patch failure

Please generate a complete log; this one starts with the build process already partly completed.

sudo port clean ghc
sudo port upgrade ghc

Changed 10 years ago by schinder@…

Attachment: main.2.log added

comment:3 Changed 10 years ago by schinder@…

mp$ sudo port clean ghc
--->  Cleaning ghc
mp$ sudo port upgrade ghc
--->  Computing dependencies for ghc
--->  Fetching archive for ghc
--->  Attempting to fetch ghc-6.10.4_5.darwin_11.x86_64.tbz2 from http://packages.macports.org/ghc
--->  Fetching ghc
--->  Verifying checksum(s) for ghc
--->  Extracting ghc
--->  Applying patches to ghc
Error: Target org.macports.patch returned: can't read "ghc_bootversion": no such variable
Log for ghc is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_ghc/ghc/main.log
Error: Unable to upgrade port: 1

comment:4 in reply to:  3 Changed 10 years ago by alun.j.carr@…

I have exactly the same problem on Lion with Xcode 4.1.

Changed 10 years ago by cjlacz@…

Attachment: main.3.log added

Build log error

comment:5 Changed 10 years ago by cjlacz@…

I'm having the same error and attached my log file.

comment:6 Changed 9 years ago by birk@…

Cc: birk@… added

Cc Me!

comment:7 Changed 9 years ago by ryandesign (Ryan Schmidt)

Keywords: lion added
Resolution: duplicate
Status: newclosed
Summary: ghc patch failureghc: can't read "ghc_bootversion": no such variable

Duplicate of #30364.

Note: See TracTickets for help on using tickets.