Opened 10 years ago

Closed 10 years ago

#31337 closed defect (duplicate)

gnome-doc-utils: perl 5.8.1 is required for intltool

Reported by: scanny@… Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: larryv (Lawrence Velázquez)
Port: gnome-doc-utils

Description (last modified by ryandesign (Ryan Schmidt))

I attempted 'sudo port install gimp'

First failure was:

Error: Target org.macports.configure returned: configure failure: shell command failed (see log for details)
Error: Failed to install cairo

I ran 'sudo port install cairo'

A lot of stuff got installed.

I re-ran 'sudo port install gimp'

Second failure was:

--->  Configuring gnome-doc-utils
Error: Target org.macports.configure returned: configure failure: shell command failed (see log for details)
Error: Failed to install gnome-doc-utils

I ran 'sudo port install gnome-doc-utils'

Error persisted:

--->  Configuring gnome-doc-utils
Error: Target org.macports.configure returned: configure failure: shell command failed (see log for details)
Log for gnome-doc-utils is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_gnome-doc-utils/gnome-doc-utils/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Tail of log file is:

:info:configure checking for perl... /opt/local/bin/perl
:info:configure checking for perl >= 5.8.1... configure: error: perl 5.8.1 is required for intltool
:info:configure shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_gnome-doc-utils/gnome-doc-utils/work/gnome-doc-utils-0.20.6" && ./configure --prefix=/opt/local --disable-scrollkeeper am_cv_python_pythondir=/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/ " returned error 1
:error:configure Target org.macports.configure returned: configure failure: shell command failed (see log for details)
:debug:configure Backtrace: configure failure: shell command failed (see log for details)
    while executing
"$procedure $targetname"
:info:configure Warning: the following items did not execute (for gnome-doc-utils): org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
:notice:configure Log for gnome-doc-utils is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_gnome-doc-utils/gnome-doc-utils/main.log

Feel free to reach out for more details if this doesn't give you enough.

Best,
Steve

Change History (4)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to devans@…
Port: gnome-doc-utils added
Summary: gimp install fails on cairo and other dependency installsgnome-doc-utils: perl 5.8.1 is required for intltool

Please remember to use WikiFormatting and to preview before submitting.

What version of perl is /opt/local/bin/perl? Or is this possibly a duplicate of #28565?

comment:2 Changed 10 years ago by larryv (Lawrence Velázquez)

Cc: larry.velazquez@… added

Cc Me!

comment:3 Changed 10 years ago by larryv (Lawrence Velázquez)

I just ran into a similar problem:

:info:configure checking for intltool >= 0.35.0... 0.40.6 found
:info:configure checking for intltool-update... /opt/local/bin/intltool-update
:info:configure checking for intltool-merge... /opt/local/bin/intltool-merge
:info:configure checking for intltool-extract... /opt/local/bin/intltool-extract
[…snip…]
:info:configure checking for perl... /opt/local/bin/perl
:info:configure checking for perl >= 5.8.1... 5.14.1
:info:configure checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

Even though intltool requires perl5.12, the gnome-doc-utils configure script checks for perl5, which might not be perl5 +perl5_12. I personally have perl5 +perl5_14 installed. Since XML::Parser is installed for perl5.12 (p5.12-xml-parser) and not perl5.14, the configure script can't find it and fails.

comment:4 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.