Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#32202 closed defect (fixed)

glib2, glib2-devel built with clang: GLib-ERROR (recursed) **: The thread system is not yet initialised

Reported by: bernhard.fisseni@… Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: clang Cc: ryandesign (Ryan Schmidt), bonoba@…, cooljeanius (Eric Gallager)
Port: glib2, glib2-devel

Description

after updating glib2 to 2.30.2, mc does not work any more; it takes some time to start up while displaying:

  (process:68270): GLib-ERROR (recursed) **: The thread system is not yet initialised.

and then returns to the shell prompt. Recompiling mc@4.7.5.2_0 (+ncurses or +slang2) did not change anything.

(As for searching the tickets: it is unfortunately not possible to search for mc bugs on this site, because search terms must have at least three letters. I could not find a reference to this error w.r.t. mc otherwise; sorry.)

Change History (19)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Owner: changed from macports-tickets@… to waqar@…
Summary: with glib2@2.30.2, mc@4.7.5.2_0 does not work any moremc@4.7.5.2_0 does not work with glib2@2.30.2

You can search for tickets against specific ports using report:16 e.g. report:16?PORT=^mc$.

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

mc 4.7.5.2 works fine for me, but I built it after installing glib 2.30.2. So perhaps your efforts to rebuild the port did not succeed. In any case, mc 4.8.0 is out, so I updated the port in r87471; see how that works for you.

comment:3 Changed 7 years ago by bernhard.fisseni@…

Thank you for your quick reply. The update does not heelp, even though I also rebuilt autoconf, perl5 (I was trying to use +perl5_14, which seems to be a bad idea), and the immediate dependencies of glib2 (gettext libiconv zlib libffi perl5) and some others. The error message is still everything I can get from mc.

Also thank you for your hint regarding searching for port bugs.

I am not quite sure I understand what you mean by saying that the rebuild did not succeed: I uninstalled, built (overall five times now, one with nurses instead of slang2), got no error message and a ‘runnable’ mc. Does that not count as ‘success’?

comment:4 Changed 7 years ago by ryandesign (Ryan Schmidt)

The same error was reported on Lion against gtk2; see #32204. Are you on Lion as well? It may be Lion-specific; I am on Snow Leopard.

comment:5 Changed 7 years ago by bernhard.fisseni@…

Yes, indeed, Lion.

comment:6 Changed 7 years ago by bonoba@…

Cc: bonoba@… added

Cc Me!

comment:7 Changed 7 years ago by bonoba@…

Hello, a guy in the other ticket has found out it's a compiler issue in Lion. Apparently clang does not compile glib2 well.

Here is the workaround:

sudo port uninstall glib2
sudo port install glib2 configure.compiler=llvm-gcc-4.2

comment:8 Changed 7 years ago by bernhard.fisseni@…

Thank you very much, this worked for me, too!

comment:9 Changed 7 years ago by ryandesign (Ryan Schmidt)

Keywords: clang added
Port: glib2 glib2-devel added; mc removed
Resolution: fixed
Status: newclosed
Summary: mc@4.7.5.2_0 does not work with glib2@2.30.2glib2, glib2-devel built with clang: GLib-ERROR (recursed) **: The thread system is not yet initialised

Fixed glib2 in r87537 and glib2-devel in r87539.

comment:10 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: closedreopened

Reopening. We need to figure out what it is miscompiling. What version of clang did you try this with? Does it still happen with XCode 4.3 using clang?

comment:11 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Owner: changed from waqar@… to jeremyhu@…
Status: reopenednew

comment:12 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

ping

comment:13 Changed 7 years ago by ryandesign (Ryan Schmidt)

At least on Mountain Lion, I cannot reproduce this problem. I installed mc and verified it works. Then I reinstalled glib2 with clang from Xcode 4.4.1, clang from the clang-3.0 port, and clang from the clang-2.9 port. After each one I tried re-running mc, which still worked. Then I tried rebuilding mc with each of those compilers and it still worked.

comment:14 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

So if this doesn't reproduce, can we get rid of the blacklisting?

comment:15 in reply to:  14 ; Changed 6 years ago by jmroot (Joshua Root)

Replying to jeremyhu@…:

So if this doesn't reproduce, can we get rid of the blacklisting?

+1

comment:16 in reply to:  15 Changed 6 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Replying to jmr@…:

Replying to jeremyhu@…:

So if this doesn't reproduce, can we get rid of the blacklisting?

+1

r106490

comment:17 Changed 6 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: newclosed

comment:18 Changed 6 years ago by ryandesign (Ryan Schmidt)

clang 211 from Xcode 4.2 fails to build glib2 +universal (see comment:ticket:39246:25); blacklisted in r106550.

comment:19 Changed 6 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

Note: See TracTickets for help on using tickets.