Opened 9 years ago

Closed 9 years ago

#32394 closed defect (duplicate)

gst-ffmpeg 0.10.13 i386 build fail

Reported by: reid@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: haspatch Cc: rmstonecipher@…
Port: gst-ffmpeg

Description (last modified by ryandesign (Ryan Schmidt))

It fails as ebx gets clobbered in asm. As per:

http://code.google.com/p/ossbuild/wiki/MacBuild

I added:

post-configure {
        if { $build_arch == "i386" } {
                reinplace "s|HAVE_EBX_AVAILABLE 1|HAVE_EBX_AVAILABLE 0|g" ${worksrcpath}/gst-libs/ext/libav/config.h
        }
}

And it installed.

Change History (1)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: rmstonecipher@… added
Description: modified (diff)
Keywords: haspatch added
Port: gst-ffmpeg added
Resolution: duplicate
Status: newclosed

Please use WikiFormatting, fill in the Port field, and Cc the maintainer of the affected port.

Duplicate of #24636 and/or #28182.

Note: See TracTickets for help on using tickets.