Opened 9 years ago

Closed 9 years ago

#32395 closed defect (duplicate)

gst-plugins-gl 0.10.2 i386 build fail w/ possible solution

Reported by: reid@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: ryandesign (Ryan Schmidt), rmstonecipher@…
Port: gst-plugins-gl

Description (last modified by ryandesign (Ryan Schmidt))

It was gstglwindow_cocoa.m -> libgstgl_0.10_la-gstglwindow_cocoa.o (x86_64) that was causing problems. Adding this did I think:

if { $build_arch == "i386" } {
        #configure.env-append "GST_CFLAGS=-arch ${build_arch}"
        configure.cflags-append "-arch ${build_arch}"
        configure.cppflags-append "-arch ${build_arch}"
        configure.cxxflags-append "-arch ${build_arch}"
}

Change History (1)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… rmstonecipher@… added
Description: modified (diff)
Port: gst-plugins-gl added
Resolution: duplicate
Status: newclosed

Please use WikiFormatting, fill in the Port field, and Cc the maintainer of that port.

This "solution" seems strange. Why would adding the -arch flag only be needed for i386? Why not for the three other archs we support? MacPorts already adds -arch flags to CFLAGS, CXXFLAGS, LDFLAGS for you, for all archs, and they shouldn't be necessary in CPPFLAGS.

This looks like a duplicate of #27898.

Note: See TracTickets for help on using tickets.