Opened 9 years ago

Closed 9 years ago

#32848 closed defect (duplicate)

cairo build fails when /usr/bin/gcc-4.2 is present with Xcode 4.2

Reported by: jxzhu@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: cairo

Description (last modified by ryandesign (Ryan Schmidt))

During the stage of installing gnuplot, I encountered the error for cairo installation. I then did

port uninstall cairo
port clean cairo
port install cairo 

I have Lion 7.2 on my MacBook Pro with Xcode 4.2.1.

I have also read the ticket # 30405 and tried using the trick there

port install cairo configure.compiler=llvm-gcc-4.2

or

port install cairo configure.compiler=gcc-4.2

But neither worked.

The main.log file is attached.

Your help is appreciated.

Jian-Xin Zhu

%%%%%%%%%

The terminal output is listed at the end of the description.

--->  Computing dependencies for cairo
--->  Fetching archive for cairo
--->  Attempting to fetch cairo-1.10.2_4+x11.darwin_11.x86_64.tbz2 from http://packages.macports.org/cairo
--->  Fetching cairo
--->  Verifying checksum(s) for cairo
--->  Extracting cairo
--->  Applying patches to cairo
--->  Configuring cairo
--->  Building cairo
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for cairo is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_cairo/cairo/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Attachments (1)

main.log (104.0 KB) - added by jxzhu@… 9 years ago.
log for installation of cairo

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by jxzhu@…

Attachment: main.log added

log for installation of cairo

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to ryandesign@…
Port: cairo added
Priority: HighNormal
Summary: failed to install cairocairo build fails when /usr/bin/gcc-4.2 is present with Xcode 4.2

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #32087.

Note: See TracTickets for help on using tickets.