Opened 9 years ago

Closed 9 years ago

#33098 closed defect (duplicate)

opencv: ld: duplicate symbol std::tr1::placeholders::(anonymous namespace)::_10

Reported by: o.schmalz@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: leopard Cc:
Port: opencv

Description

I cannot build the opencv, I need it for digikam. Mac OS X 10.5, OpenCV 2.3.1a

Error: Target org.macports.build returned: shell command failed (see log for details)
Error: Failed to install opencv
Log for opencv is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_opencv/opencv/main.log
Error: The following dependencies were not installed: opencv
Error: Status 1 encountered during processing.

Log attached, please help me! I need your help very much! :)

Attachments (1)

main.log (803.1 KB) - added by o.schmalz@… 9 years ago.
opencv log

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by o.schmalz@…

Attachment: main.log added

opencv log

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: o.schmalz@… removed
Keywords: opencv digikam mac os x 10.5 removed
Milestone: MacPorts 2.0.4
Summary: opencv @2.3.1a Mac OS X 10.5 build failedopencv: ld: duplicate symbol std::tr1::placeholders::(anonymous namespace)::_10

The error in the log is:

:info:build ld: duplicate symbol std::tr1::placeholders::(anonymous namespace)::_10                                                                                                                                                                                   in CMakeFiles/opencv_ts.dir/src/ts.o and CMakeFiles/opencv_ts.dir/src/precomp.o
:info:build collect2: ld returned 1 exit status
:info:build make[2]: *** [lib/libopencv_ts.2.3.1.dylib] Error 1

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #32094.

Note: See TracTickets for help on using tickets.