Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#32094 closed defect (fixed)

opencv: ld: duplicate symbol std::tr1::placeholders::(anonymous namespace)::_10

Reported by: trog24 (Frank J. R. Hanstick) Owned by: raphael-st (Raphael Straub)
Priority: Normal Milestone:
Component: ports Version:
Keywords: leopard Cc: ebudda@…, dershow, o.schmalz@…
Port: opencv

Description

I started out with the same cannot be built error:

Error: opencv 2.3.1a cannot be built while opencv 2.2.0 is installed and active.
Error: Please deactivate opencv 2.2.0 first.
Error: Target org.macports.build returned: incompatible opencv version active
Log for opencv is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_opencv/opencv/main.log
Error: Unable to upgrade port: 1
To report a bug, see <http://guide.macports.org/#project.tickets>

I then deactivated opencv and continued the upgrade of outdated. Opencv did not update.

I then tried sudo port install opencv and got the following error:

Error: Target org.macports.build returned: shell command failed (see log for details)
Log for opencv is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_opencv/opencv/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

I thought that it remnants remained from the previous attempt and did the following: sudo port clean opencv

Before reattempting the install, I thought that it may be better if I uninstalled opencv.

I then made another attempt at installing and got the following error:

--->  Computing dependencies for opencv
--->  Fetching archive for opencv
--->  Attempting to fetch opencv-2.3.1a_1.darwin_9.ppc.tgz from http://packages.macports.org/opencv
--->  Fetching opencv
--->  Verifying checksum(s) for opencv
--->  Extracting opencv
--->  Applying patches to opencv
--->  Configuring opencv
--->  Building opencv
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for opencv is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_opencv/opencv/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Attached is the log file from the failure. Please note that this is the PowerPC version.

Attachments (5)

main.log (828.2 KB) - added by trog24 (Frank J. R. Hanstick) 9 years ago.
build failure log file
main.2.log (208.5 KB) - added by ebudda@… 8 years ago.
Same Errors, Not sure if it's the same problem.
main3.log (807.1 KB) - added by dershow 8 years ago.
main.3.log (829.2 KB) - added by trog24 (Frank J. R. Hanstick) 8 years ago.
build failure log file
main.4.log (803.1 KB) - added by o.schmalz@… 8 years ago.
Mac OS X 10.5, OpenCV 2.3.1a

Change History (16)

comment:1 Changed 9 years ago by trog24 (Frank J. R. Hanstick)

Cc: trog24@… added

Cc Me!

Changed 9 years ago by trog24 (Frank J. R. Hanstick)

Attachment: main.log added

build failure log file

comment:2 Changed 9 years ago by mf2k (Frank Schima)

Cc: trog24@… removed

Changed 8 years ago by ebudda@…

Attachment: main.2.log added

Same Errors, Not sure if it's the same problem.

comment:3 Changed 8 years ago by ebudda@…

Fixed by using 3rd party libpng installer

comment:4 Changed 8 years ago by dershow

For what it is worth, I am having a similar problem. But the log file looks a little different, so I decided to post as well. My log file is attached.

Changed 8 years ago by dershow

Attachment: main3.log added

comment:5 Changed 8 years ago by trog24 (Frank J. R. Hanstick)

opencv still will not build. See attached log.

Changed 8 years ago by trog24 (Frank J. R. Hanstick)

Attachment: main.3.log added

build failure log file

comment:6 Changed 8 years ago by o.schmalz@…

Same error, log attached. Mac OS X 10.5, OpenCV 2.3.1a How can I build opencv?

Changed 8 years ago by o.schmalz@…

Attachment: main.4.log added

Mac OS X 10.5, OpenCV 2.3.1a

comment:7 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: ebudda@… dersh@… o.schmalz@… added
Keywords: leopard added
Summary: opencv will not buildopencv: ld: duplicate symbol std::tr1::placeholders::(anonymous namespace)::_10

The error in trog24's first and second logs is:

:info:build ld: duplicate symbol std::tr1::placeholders::(anonymous namespace)::_10 in CMakeFiles/opencv_ts.dir/src/ts.o and CMakeFiles/opencv_ts.dir/src/precomp.o
:info:build collect2: ld returned 1 exit status
:info:build make[2]: *** [lib/libopencv_ts.2.3.1.dylib] Error 1

This is the error this ticket will be about. Has duplicate #33098 (o.schmalz's ticket). Both users are on Leopard.


ebudda's log shows a different error:

:info:build ld: warning: ignoring file /Library/Frameworks//libpng.framework/libpng, missing required architecture x86_64 in file
:info:build Undefined symbols for architecture x86_64:
:info:build   "_png_create_write_struct", referenced from:

This is unrelated, and not a MacPorts problem; the problem is that /Library/Frameworks/libpng.framework exists; delete it, clean opencv, try again.


dersh's log shows yet a third different error:

:info:build ld: warning: duplicate dylib /opt/local/lib/libz.dylib
:info:build Undefined symbols:
:info:build   "_png_set_gray_1_2_4_to_8", referenced from:
:info:build       cv::PngDecoder::readData(cv::Mat&)     in grfmt_png.o
:info:build ld: symbol(s) not found

This is unrelated. This Homebrew bug report includes the suggestion that this could be due to the presence of /Library/Frameworks/Mono.framework; if you have this, or /Library/Frameworks/libpng.framework, delete them, clean opencv, and try again. If that doesn't work, file a new ticket, since the issue is unrelated to the issue this ticket was filed about.

comment:8 in reply to:  6 Changed 8 years ago by ryandesign (Ryan Schmidt)

Replying to o.schmalz@…:

Same error, log attached. Mac OS X 10.5, OpenCV 2.3.1a How can I build opencv?

I do not know, and we do not have a MacPorts maintainer for opencv right now. I suggest you report the problem to the developers of opencv.

comment:9 Changed 8 years ago by raphael-st (Raphael Straub)

Owner: changed from macports-tickets@… to raphael@…
Status: newassigned
Version: 2.0.3

According to this mailing list post disabling the build of the tests helps. I'll test that.

comment:10 Changed 8 years ago by raphael-st (Raphael Straub)

Resolution: fixed
Status: assignedclosed

Fixed in r89507.

comment:11 in reply to:  7 Changed 8 years ago by dershow

Replying to ryandesign@…:

This is unrelated. This Homebrew bug report includes the suggestion that this could be due to the presence of /Library/Frameworks/Mono.framework; if you have this, or /Library/Frameworks/libpng.framework, delete them, clean opencv, and try again. If that doesn't work, file a new ticket, since the issue is unrelated to the issue this ticket was filed about.

Deleting the Mono framework did the job for me (it has been there for many years, and hasn't caused problems before.)

Note: See TracTickets for help on using tickets.